Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be unavailable on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 1201053 - Installation of KDE Plasma 5 fails Due To Packaging Conflict
Summary: Installation of KDE Plasma 5 fails Due To Packaging Conflict
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: plasma-workspace
Version: 21
Hardware: x86_64
OS: Linux
unspecified
urgent
Target Milestone: ---
Assignee: KDE SIG
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-03-11 23:37 UTC by David Green
Modified: 2015-03-19 18:40 UTC (History)
7 users (show)

Fixed In Version: kde-baseapps-14.12.3-1.fc21
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-03-19 18:40:03 UTC
Type: Bug


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
KDE Software Compilation 345057 0 None None None Never

Description David Green 2015-03-11 23:37:02 UTC
Description of problem:
Installation of KDE Plasma 5 (plasma shell) results in package conflict with package not installed on my system.

Version-Release number of selected component (if applicable):
Fedora 21, plasma 5

How reproducible:


Steps to Reproduce:
teps to Reproduce:
1. Install Fedora 21 using live-desktop CD.

 2. set up /etc/yum.repos.d repository file with contents:
[dvratil-plasma-5]
name=Copr repo for plasma-5 owned by dvratil
baseurl=https://copr-be.cloud.fedoraproject.org/results/dvratil/plasma-5/fedora-$releasever-$basearch/
skip_if_unavailable=True
gpgcheck=1
gpgkey=https://copr-be.cloud.fedoraproject.org/results/dvratil/plasma-5/pubkey.gpg
enabled=1

3.  run yum update

4.  Run yum install plasma-5

Actual Results:  
Gives this result:
 Processing Conflict: kdesu-5.2.1-4.fc21.x86_64 conflicts kde-runtime < 14.12.3-2
--> Finished Dependency Resolution
Error: kdesu conflicts with kde-runtime-14.12.1-2.fc21.x86_64
 You could try using --skip-broken to work around the problem

Yum list installed | grep kde-runtime returns that package is not installed.


Expected results:
Plasma 5 Installs without error.

Additional info:
Opened this bug against KDE, update is that it is a packaging bug:
https://bugs.kde.org/show_bug.cgi?id=345057

Comment 1 Fedora Update System 2015-03-12 12:45:01 UTC
kde-baseapps-14.12.3-1.fc21, kdelibs-4.14.6-2.fc21, kdepimlibs-4.14.6-1.fc21, oxygen-icon-theme-14.12.3-1.fc21, kde-runtime-14.12.3-2.fc21 has been submitted as an update for Fedora 21.
https://admin.fedoraproject.org/updates/FEDORA-2015-3595/kde-baseapps-14.12.3-1.fc21,kdelibs-4.14.6-2.fc21,kdepimlibs-4.14.6-1.fc21,kde-runtime-14.12.3-2.fc21,oxygen-icon-theme-14.12.3-1.fc21

Comment 2 Fedora Update System 2015-03-13 17:27:28 UTC
Package kde-baseapps-14.12.3-1.fc21, kdelibs-4.14.6-2.fc21, kdepimlibs-4.14.6-1.fc21, oxygen-icon-theme-14.12.3-1.fc21, kde-runtime-14.12.3-2.fc21:
* should fix your issue,
* was pushed to the Fedora 21 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing kde-baseapps-14.12.3-1.fc21 kdelibs-4.14.6-2.fc21 kdepimlibs-4.14.6-1.fc21 oxygen-icon-theme-14.12.3-1.fc21 kde-runtime-14.12.3-2.fc21'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2015-3595/kde-baseapps-14.12.3-1.fc21,kdelibs-4.14.6-2.fc21,kdepimlibs-4.14.6-1.fc21,kde-runtime-14.12.3-2.fc21,oxygen-icon-theme-14.12.3-1.fc21
then log in and leave karma (feedback).

Comment 3 Fedora Update System 2015-03-19 18:40:03 UTC
kde-baseapps-14.12.3-1.fc21, kdelibs-4.14.6-2.fc21, kdepimlibs-4.14.6-1.fc21, oxygen-icon-theme-14.12.3-1.fc21, kde-runtime-14.12.3-2.fc21 has been pushed to the Fedora 21 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.