Bug 1201124 - Essential Xfce package missing from EPEL7
Summary: Essential Xfce package missing from EPEL7
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora EPEL
Classification: Fedora
Component: gtk-xfce-engine
Version: epel7
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Mukundan Ragavan
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 1144025 1204452 (view as bug list)
Depends On: 1156632 1203043 1204495 1206895 1208459 xfce-bluetooth 1224801 xfce-polkit
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-03-12 05:14 UTC by Toni Spets
Modified: 2016-01-09 00:29 UTC (History)
8 users (show)

Fixed In Version: gtk-xfce-engine-3.0.1-4.el7
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-01-09 00:29:39 UTC


Attachments (Terms of Use)

Description Toni Spets 2015-03-12 05:14:37 UTC
When backporting Xfce packages to EPEL7, it seems that this fairly essential theming package was missed. It is available for EPEL5 and 6 and all supported Fedora releases.

Could we get this rather small package backported as well for the complete Xfce experience?

Thanks.

Comment 1 Mukundan Ragavan 2015-03-12 22:06:47 UTC
Yes, xfce packages for EPEL-7 is not complete yet. Will take care of this ...

Comment 2 Fedora Update System 2015-03-19 01:50:40 UTC
gtk-xfce-engine-3.0.1-4.el7 has been submitted as an update for Fedora EPEL 7.
https://admin.fedoraproject.org/updates/gtk-xfce-engine-3.0.1-4.el7

Comment 3 Mukundan Ragavan 2015-03-19 01:52:22 UTC
This is built ... we are getting there, slowly but surely. :)

Comment 4 Fedora Update System 2015-03-20 04:52:45 UTC
gtk-xfce-engine-3.0.1-4.el7 has been pushed to the Fedora EPEL 7 testing repository.

Comment 5 Mukundan Ragavan 2015-03-22 16:13:57 UTC
*** Bug 1204452 has been marked as a duplicate of this bug. ***

Comment 6 Mukundan Ragavan 2015-03-23 02:10:03 UTC
*** Bug 1144025 has been marked as a duplicate of this bug. ***

Comment 7 Toni Spets 2015-03-23 07:01:52 UTC
To recap in this tracker, these packages have been fixed and uploaded to testing since my spree of requests:

 - xfce4-settings
 - xfdesktop

And these new packages have been pushed to testing:

 - gtk-xfce-engine
 - ristretto
 - tumbler

These would still be "required" in my opinion for a full Xfce desktop:

 - xfwm4-themes
 - mousepad

These are in the wish list that are not yet in:

 - xfce4-whiskermenu-plugin (two separate requests)
 - xfce4-notifyd
 - xfce4-indicator-plugin

Did I miss anything in any set? Many thanks to Mukundan Ragavan for taking care of these packaging issues very quickly.

Also the comps are still broken. I have a test set that I constantly update and tweak to see what would produce the best desktop experience. After the "required" packages are in testing, I'm going to try to produce the final set that would install the full Xfce desktop and propose that in a separate bug to be taken look at for inclusion as per instructions.

Thanks everyone!

Comment 8 Toni Spets 2015-03-23 20:19:33 UTC
Noticed there is no mixer application or dock item available. Adding 'xfce4-mixer' to the required list as you have no GUI volume control at all without it.

Maybe backporting 'pavucontrol' would be benefitical as well so you can find a volume mixer from the applications menu that can control all aspects of PA? I've found it useful on Xfce myself.

Comment 9 Fedora Update System 2015-03-24 01:23:48 UTC
xfwm4-themes-4.10.0-5.el7 has been submitted as an update for Fedora EPEL 7.
https://admin.fedoraproject.org/updates/xfwm4-themes-4.10.0-5.el7

Comment 10 Mukundan Ragavan 2015-03-24 01:29:35 UTC
Ok, that's (xfwm4-themes) done.

I will discuss with kevin, cwickert and other folks maintaining the plugins and see what needs to be done.

Comment 11 Toni Spets 2015-03-25 16:47:31 UTC
Actually xfdesktop could use /usr/share/backgrounds/day.jpg as the default background as it is provided by RHEL and CentOS. Plus it is also used for lightdm as its default background on EPEL right now.

If it could be changed to that, I'll file a bug against Scientific Linux if they could symlink one of their default backgrounds in sl-logos package to day.jpg. This way the experience will be consistent between all three.

Sorry for not noticing this day.jpg symlink before in centos-logos and checking against redhat-logos first.

What do you think?

Comment 12 Mukundan Ragavan 2015-03-26 02:19:45 UTC
I guess that could be done as well. But, I will revisit this after plugins. 

I would like to get most things in EPEL first before worrying about backgrounds. :)

Comment 13 Fedora Update System 2015-03-29 04:12:05 UTC
xfce4-equake-plugin-1.3.6-1.el7,xfce4-battery-plugin-1.0.5-7.el7,xfce4-genmon-plugin-3.4.0-6.el7,xfce4-cpugraph-plugin-1.0.5-7.el7,xfce4-smartbookmark-plugin-0.4.4-9.el7,xfce4-datetime-plugin-0.6.2-5.el7,xfce4-mount-plugin-0.6.7-3.el7,xfce4-eyes-plugin-4.4.2-4.el7,xfce4-xkb-plugin-0.5.6-4.el7,xfce4-verve-plugin-1.0.1-3.el7,xfce4-diskperf-plugin-2.5.4-8.el7,xfce4-cpufreq-plugin-1.1.1-2.el7,xfce4-fsguard-plugin-1.0.2-1.el7,xfce4-clipman-plugin-1.2.6-4.el7,xfce4-sensors-plugin-1.2.5-1.el7,xfce4-mailwatch-plugin-1.2.0-7.el7,xfce4-whiskermenu-plugin-1.5.0-1.el7 has been submitted as an update for Fedora EPEL 7.
https://admin.fedoraproject.org/updates/xfce4-equake-plugin-1.3.6-1.el7,xfce4-battery-plugin-1.0.5-7.el7,xfce4-genmon-plugin-3.4.0-6.el7,xfce4-cpugraph-plugin-1.0.5-7.el7,xfce4-smartbookmark-plugin-0.4.4-9.el7,xfce4-datetime-plugin-0.6.2-5.el7,xfce4-mount-plugin-0.6.7-3.el7,xfce4-eyes-plugin-4.4.2-4.el7,xfce4-xkb-plugin-0.5.6-4.el7,xfce4-verve-plugin-1.0.1-3.el7,xfce4-diskperf-plugin-2.5.4-8.el7,xfce4-cpufreq-plugin-1.1.1-2.el7,xfce4-fsguard-plugin-1.0.2-1.el7,xfce4-clipman-plugin-1.2.6-4.el7,xfce4-sensors-plugin-1.2.5-1.el7,xfce4-mailwatch-plugin-1.2.0-7.el7,xfce4-whiskermenu-plugin-1.5.0-1.el7

Comment 14 Mukundan Ragavan 2015-03-29 04:25:14 UTC
As can be seen from the update above, many of the plugins have been built.

The following plugins built fine but cannot even be enabled on the panel - :(

clipman
wavelan
netload
timer
places
weather (0.8.5)


The following packages have also been built. While the main packages work fine, the panel-plugins don't. :(

dict
https://koji.fedoraproject.org/koji/buildinfo?buildID=624462

screenshooter
https://koji.fedoraproject.org/koji/buildinfo?buildID=624465

Testing and patches welcome.

Comment 15 Raphael Groner 2015-03-29 22:16:32 UTC
Bug #1156632 counts for xfce4-hamster-plugin with currently broken dependency.

Comment 16 Toni Spets 2015-04-02 14:40:38 UTC
xfce4-whiskermenu-plugin tested to be working as well as on Fedora. Both suffer from the defaults where clicking on your profile picture tries to start "mugshot" which isn't available on Fedora nor EPEL AFAIK or is under some other name in packages.

I've now also completed a full install on my laptop using my comps ("Xfce Desktop Environment"). Only one package is still missing from my initial comps and that is mousepad, everything else are satisfied from epel-testing.

Comment 17 Raphael Groner 2015-04-02 14:53:24 UTC
(In reply to Toni Spets from comment #16)
> xfce4-whiskermenu-plugin tested to be working as well as on Fedora. Both
> suffer from the defaults where clicking on your profile picture tries to
> start "mugshot" which isn't available on Fedora nor EPEL AFAIK or is under
> some other name in packages.

Reproducible for me.

Mugshot is available in Linux Mint. Maybe it should be packaged for Fedora?
http://community.linuxmint.com/idea/view/5031https://launchpad.net/mugshot

> I've now also completed a full install on my laptop using my comps ("Xfce
> Desktop Environment"). Only one package is still missing from my initial
> comps and that is mousepad, everything else are satisfied from epel-testing.

Mousepad should become redundant with Leafpad.

Comment 18 Toni Spets 2015-04-02 16:00:12 UTC
(In reply to Raphael Groner from comment #17)
> (In reply to Toni Spets from comment #16)
> > xfce4-whiskermenu-plugin tested to be working as well as on Fedora. Both
> > suffer from the defaults where clicking on your profile picture tries to
> > start "mugshot" which isn't available on Fedora nor EPEL AFAIK or is under
> > some other name in packages.
> 
> Reproducible for me.
> 
> Mugshot is available in Linux Mint. Maybe it should be packaged for Fedora?
> http://community.linuxmint.com/idea/view/5031
> → https://launchpad.net/mugshot

There's no other lightweight alternative AFAIK currently available anyway so it does sound like a good idea. The plugin should definitely also depend on it since it can be considered broken without it.

If the Fedora Xfce SIG could use it then it should definitely be packaged if possible and backported to EPEL probably so that we could make use of it here as well.

> 
> > I've now also completed a full install on my laptop using my comps ("Xfce
> > Desktop Environment"). Only one package is still missing from my initial
> > comps and that is mousepad, everything else are satisfied from epel-testing.
> 
> Mousepad should become redundant with Leafpad.

Well, doesn't every choice make the others redundant? :)

Mousepad is the official text editor for Xfce (right?) so that's why I thought it should be in and in default comps. I don't have anything bad to say about Leafpad though as they both do the same thing in the end.

So, if you're prepared to bring Leafpad to EPEL 7 then that's the way to go.

I'll switch my comps to Leafpad and will wait for all testing packages (and Leafpad) to drop into stable and then go forward with the comps suggestion.

Comment 19 Raphael Groner 2015-04-02 17:24:48 UTC
(In reply to Toni Spets from comment #18)
…
> There's no other lightweight alternative AFAIK currently available anyway so
> it does sound like a good idea. The plugin should definitely also depend on
> it since it can be considered broken without it.

Can you please open a new bug against Component: xfce4-whiskermenu-plugin and Version: rawhide for this individual issue and block this bug with it? It's not the right place here to discuss individual plugin related bugs.
Maybe someone then could see if there's time to request a review for an official mugshot package.

> If the Fedora Xfce SIG could use it then it should definitely be packaged if
> possible and backported to EPEL probably so that we could make use of it
> here as well.

Sure. As said, please file another bug about that.

…
> > Mousepad should become redundant with Leafpad.
> 
> Well, doesn't every choice make the others redundant? :)

Well, mousepad is very minimalistic. We should think about an *usable* editor for the normal user. But that'll propably lead into the common vi vs. emacs flamewar and is also offtopic for this bug. ;-)

…
> I'll switch my comps to Leafpad and will wait for all testing packages (and
> Leafpad) to drop into stable and then go forward with the comps suggestion.

Leafpad is available, except for EPEL6 (branch exists though) and EPEL7 (new request necessary). Could you open new bugs for those individual issues and make this one depend on them?

Comment 20 Fedora Update System 2015-04-04 21:06:20 UTC
thunar-volman-0.8.0-6.el7 has been submitted as an update for Fedora EPEL 7.
https://admin.fedoraproject.org/updates/thunar-volman-0.8.0-6.el7

Comment 21 Fedora Update System 2015-04-06 03:09:51 UTC
gtk-xfce-engine-3.0.1-4.el7 has been pushed to the Fedora EPEL 7 stable repository.

Comment 22 Fedora Update System 2015-04-09 16:56:22 UTC
xfwm4-themes-4.10.0-5.el7 has been pushed to the Fedora EPEL 7 stable repository.

Comment 23 Fedora Update System 2015-04-17 18:14:22 UTC
xfce4-equake-plugin-1.3.6-1.el7, xfce4-genmon-plugin-3.4.0-6.el7, xfce4-smartbookmark-plugin-0.4.4-9.el7, xfce4-mount-plugin-0.6.7-3.el7, xfce4-xkb-plugin-0.5.6-4.el7, xfce4-diskperf-plugin-2.5.4-8.el7, xfce4-fsguard-plugin-1.0.2-1.el7, xfce4-sensors-plugin-1.2.5-1.el7, xfce4-whiskermenu-plugin-1.5.0-1.el7, xfce4-battery-plugin-1.0.5-7.el7, xfce4-cpugraph-plugin-1.0.5-7.el7, xfce4-datetime-plugin-0.6.2-5.el7, xfce4-eyes-plugin-4.4.2-4.el7, xfce4-verve-plugin-1.0.1-3.el7, xfce4-cpufreq-plugin-1.1.1-2.el7, xfce4-mailwatch-plugin-1.2.0-7.el7 has been pushed to the Fedora EPEL 7 stable repository.

Comment 24 Fedora Update System 2015-04-22 05:09:15 UTC
thunar-volman-0.8.0-6.el7 has been pushed to the Fedora EPEL 7 stable repository.

Comment 25 Kevin Fenzi 2015-05-18 14:41:22 UTC
*** Bug 1222545 has been marked as a duplicate of this bug. ***

Comment 26 Fedora Update System 2015-05-19 00:14:10 UTC
xfce4-mixer-4.10.0-7.el7 has been submitted as an update for Fedora EPEL 7.
https://admin.fedoraproject.org/updates/xfce4-mixer-4.10.0-7.el7

Comment 27 Raphael Groner 2015-08-07 14:22:47 UTC
xfce-bluetooth is ready for EPEL7.

Comment 28 Raphael Groner 2015-08-30 16:15:58 UTC
xfce-polkit is ready.

Comment 29 Kevin Fenzi 2015-08-30 18:38:59 UTC
I'd prefer to get some testing on xfce-polkit before enabling it.

Comment 30 Raphael Groner 2015-08-30 20:46:50 UTC
(In reply to Kevin Fenzi from comment #29)
> I'd prefer to get some testing on xfce-polkit before enabling it.

Sure. It's requested for inclusion into updates-testing, then it will go through the normal process to finally land in stable. Feel free to give karma.

Comment 31 Andrew J. Schorr 2016-01-08 01:37:47 UTC
I don't see xfce4-mixer in the stable epel repo yet. Is there some reason it's stuck in testing?

Comment 32 Mukundan Ragavan 2016-01-08 02:10:24 UTC
(In reply to Andrew J. Schorr from comment #31)
> I don't see xfce4-mixer in the stable epel repo yet. Is there some reason
> it's stuck in testing?

I forgot ... :(

Now pushed.

Comment 33 Fedora Update System 2016-01-09 00:29:26 UTC
xfce4-mixer-4.10.0-7.el7 has been pushed to the Fedora EPEL 7 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.