Bug 120113 - Mozilla won't start for regular user
Mozilla won't start for regular user
Product: Fedora
Classification: Fedora
Component: mozilla (Show other bugs)
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Christopher Blizzard
Ben Levenson
Depends On:
  Show dependency treegraph
Reported: 2004-04-06 00:02 EDT by Michael J. Kofler
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2004-04-13 13:11:08 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Michael J. Kofler 2004-04-06 00:02:50 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (compatible; Konqueror/3.2; Linux) (KHTML, like Gecko)

Description of problem:
Neither clicking on the Browse the Internet Mozilla button in the panel nor typing 'mozilla' in the command line opens the browser for regular users, although it does work as root.
mozilla -debug provides the following:
INTERNAL ERROR on Browser End: No manager for initializing factory?
System error?:: Permission denied

permissions for /usr/bin/mozilla are 
-rwxr-xr-x  1 root root 5799 Mar 12 15:17 /usr/bin/mozilla
as they were pre-upgrade from RH9. 

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1. click panel button for mozilla or type mozilla in terminal window as regular user

Actual Results:  mozilla failed to load as expected

Expected Results:  mozilla loads as normal

Additional info:

Fedora Core 2 test 2 upgraded from RH9
Comment 1 Christopher Blizzard 2004-04-12 15:09:45 EDT
Try uninstalling the java plugin.  I suspect that's the plugin bailing
out.  Did you change your user agent at some point?
Comment 2 Michael J. Kofler 2004-04-12 21:29:56 EDT
I ended up doing a fresh install, and now it works. I installed the
latest java plugin from sun, so that may have been it.
I'm not sure about the user agent ... I've disabled SELinux for now
because I was having other problems with up2date, etc (reported
elsewhere). But mozilla works now, so te bug can be closed.
Comment 3 Christopher Blizzard 2004-04-13 13:11:08 EDT
marking worksforme.

Note You need to log in before you can comment on or make changes to this bug.