Bug 1201142 - 003 failed in scsi-testsuite with scsi-block
Summary: 003 failed in scsi-testsuite with scsi-block
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: qemu-kvm
Version: 6.7
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: rc
: ---
Assignee: Fam Zheng
QA Contact: Virtualization Bugs
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-03-12 06:19 UTC by Chao Yang
Modified: 2015-03-24 02:38 UTC (History)
11 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-03-24 02:38:26 UTC
Target Upstream Version:


Attachments (Terms of Use)
output of 004 (836 bytes, text/plain)
2015-03-12 06:30 UTC, Chao Yang
no flags Details
output of 003 (401 bytes, text/plain)
2015-03-12 06:31 UTC, Chao Yang
no flags Details

Description Chao Yang 2015-03-12 06:19:58 UTC
Description of problem:

case 003 and 004 failed while running scsi-testsuite with scsi-block.

PLATFORM      -- Linux/x86_64 unused 2.6.32-541.el6.x86_64

001 0s ...
002 0s ...
003 0s ... - output mismatch (see 003.out.bad)
--- 003.out	2015-03-11 11:06:16.254000012 +0800
+++ 003.out.bad	2015-03-12 13:51:26.756000000 +0800
@@ -6,9 +6,13 @@
 sense buffer empty
 
     cdb to send: 1a 00 01 00 00 00
-SCSI Status: Good
+SCSI Status: Check Condition
 
 Sense Information:
-sense buffer empty
+ Fixed format, current;  Sense key: Illegal Request
+ Additional sense: Invalid field in cdb
+ Raw sense data (in hex):
+        70 00 05 00 00 00 00 0a  00 00 00 00 24 00 00 00
+        00 00
 
 *** done
004 1s ... - output mismatch (see 004.out.bad)
--- 004.out	2015-03-11 11:06:16.256000012 +0800
+++ 004.out.bad	2015-03-12 13:51:26.873000000 +0800
@@ -6,10 +6,14 @@
 sense buffer empty
 
     cdb to send: 2a 00 00 00 00 00 00 00 00 00
-SCSI Status: Good
+SCSI Status: Check Condition
 
 Sense Information:
-sense buffer empty
+ Fixed format, current;  Sense key: Data Protect
+ Additional sense: Write protected
+ Raw sense data (in hex):
+        70 00 07 00 00 00 00 0a  00 00 00 00 27 00 00 00
+        00 00
 
     cdb to send: 88 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00
 SCSI Status: Good
@@ -18,9 +22,13 @@
 sense buffer empty
 
     cdb to send: 8a 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00
-SCSI Status: Good
+SCSI Status: Check Condition
 
 Sense Information:
-sense buffer empty
+ Fixed format, current;  Sense key: Data Protect
+ Additional sense: Write protected
+ Raw sense data (in hex):
+        70 00 07 00 00 00 00 0a  00 00 00 00 27 00 00 00
+        00 00
 
 *** done
005 0s ...
006 0s ...
007 0s ...
Failures: 003 004
Failed 2 of 7 tests


Version-Release number of selected component (if applicable):
qemu-kvm-rhev-0.12.1.2-2.457.el6


How reproducible:
100%

Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

This is not a regression since qemu-kvm-448 is reproducible too.

CLI:
...
-drive file=/dev/disk/by-path/ip-10.66.73.12\:3260-iscsi-iqn.test\:sda1\:hp-bl460cg1-02.qe.lab.eng.nay.redhat.com-lun-1,if=none,id=drive-scsi0-0-0-1,format=raw,cache=none,readonly=on -device scsi-block,bus=scsi0.0,channel=0,scsi-id=1,lun=1,drive=drive-scsi0-0-0-1,id=scsi0-0-0-1
...

Comment 1 Chao Yang 2015-03-12 06:22:30 UTC
003 004 passed with scsi-hd

Comment 2 Chao Yang 2015-03-12 06:30:20 UTC
Created attachment 1000815 [details]
output of 004

Comment 4 Chao Yang 2015-03-12 06:31:28 UTC
Created attachment 1000816 [details]
output of 003

Comment 5 Chao Yang 2015-03-13 04:52:27 UTC
As per Fam's remind through IRC, I noticed I added readonly=on mistakenly in cli.

Retested again by removing readonly=on, 004 failure was fixed. But 003 failure still happened.

-------------------------

QA output created by 003
    cdb to send: 03 00 00 00 00 00
SCSI Status: Good

Sense Information:
sense buffer empty

    cdb to send: 1a 00 01 00 00 00
SCSI Status: Check Condition

Sense Information:
 Fixed format, current;  Sense key: Illegal Request
 Additional sense: Invalid field in cdb
 Raw sense data (in hex):
        70 00 05 00 00 00 00 0a  00 00 00 00 24 00 00 00
        00 00

*** done

Comment 6 Fam Zheng 2015-03-24 02:38:26 UTC
I tried again, this is not a bug of qemu-kvm. Running 003 on host also fails.

The error status and sense data are the same.


Note You need to log in before you can comment on or make changes to this bug.