Bug 120118 - Dictionary words will force processor consumption
Dictionary words will force processor consumption
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: gnome-utils (Show other bugs)
rawhide
All Linux
high Severity high
: ---
: ---
Assigned To: Christopher Aillon
:
Depends On:
Blocks: FC3BugWeekTracker
  Show dependency treegraph
 
Reported: 2004-04-06 02:56 EDT by Scott Sloan
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-09-23 16:36:07 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Scott Sloan 2004-04-06 02:56:44 EDT
Description of problem:

Found that certain words will get gnome-dictionary to use 100% of the cpu

Version-Release number of selected component (if applicable):

gnome-utils-2.6.0-1

How reproducible:

Everytime

Steps to Reproduce:
1. Start gnome-dictionary
2. Lookup the word "force"
3. Look at your cpu usage.
  
Actual results:

uses 100% of the cpu

Expected results:

Don't!

Additional info:

Words that produce this bug:

force
call
Comment 1 Daniel Reed 2004-04-12 13:57:54 EDT
Similar behavior in Dictionary 2.4.0 as well; on my system it appears
to be stuck in:

#0  0x40932f32 in loser_poll () from /lib/libc.so.6
#1  0x40814c96 in g_main_loop_get_context () from
/usr/lib/libglib-2.0.so.0
#2  0x40814034 in g_main_context_dispatch () from
/usr/lib/libglib-2.0.so.0
#3  0x408147cf in g_main_loop_run () from /usr/lib/libglib-2.0.so.0
#4  0x403e643f in gtk_main () from /usr/lib/libgtk-x11-2.0.so.0
#5  0x08057294 in main ()
#6  0x4086fd06 in __libc_start_main () from /lib/libc.so.6

I have broken into it at various end points, but the backtrace always
includes through g_main_context_dispatch().
Comment 3 Christopher Aillon 2004-09-23 16:36:07 EDT
This looks like it is fixed in the gnome-utils-2.8.0-1 RPM i pushed to
rawhide last night.  Marking RAWHIDE, but reopen if you still see the
problem.

Note You need to log in before you can comment on or make changes to this bug.