Bug 1201191 - run 'make test' on ppc64, s390, s390x
Summary: run 'make test' on ppc64, s390, s390x
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: perl
Version: 6.6
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: ---
Assignee: Petr Pisar
QA Contact: Martin Kyral
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-03-12 09:41 UTC by Martin Kyral
Modified: 2015-07-22 05:59 UTC (History)
3 users (show)

Fixed In Version: perl-5.10.1-141.el6
Doc Type: Bug Fix
Doc Text:
Previously, due to earlier problems with threads, several tests were blocked for IBM S/390, IBM System z, or PowerPC platforms in the Perl specification file. Consequently, when building the perl package, internal tests were not performed on these platforms, even though the original problems no longer occurred. Now, when building the perl package, the tests are performed on all supported architectures.
Clone Of:
Environment:
Last Closed: 2015-07-22 05:59:53 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2015:1266 normal SHIPPED_LIVE perl bug fix update 2015-07-20 17:49:38 UTC
Red Hat Bugzilla 594768 None None None Never

Internal Links: 594768

Description Martin Kyral 2015-03-12 09:41:29 UTC
Description of problem:
On RHEL6, the ppc64, s390, s390x architectures are blacklisted from running the upstream test suite during the build. I tried to unblock them and the build passes fine (tried with ppc64 and s390x), so the is no reason to block them anymore.
Please, enable the tests on all supported architectures. Not running them raises the risk of regression.
On RHEL5 and 7, there is no such limitation.


Version-Release number of selected component (if applicable):
perl-5.10.1-140.el6

How reproducible:


Steps to Reproduce:
1. rpmbuild -bb perl.spec
2.
3.

Actual results:
'make test' is skipped, the built bit not tested

Expected results:
'make test' runs:


Additional info:

--- perl.spec.old       2015-03-12 05:31:03.541025171 -0400
+++ perl.spec   2015-03-12 05:04:10.041498718 -0400
@@ -1429,11 +1429,11 @@
 cp %{SOURCE4} lib/CGI/t/
 sed -i -e 's|\(t\/upload_post_text\.txt\)|../lib/CGI/\1|' lib/CGI/t/*.t
 # some updated modules check whether module is built from cpan or core
-%ifnarch ppc64 s390 s390x
+#%ifnarch ppc64 s390 s390x
 #ext/threads-shared/t/stress test fails on z10
 export PERL_CORE=1
 make test
-%endif
+#%endif

 %post libs -p /sbin/ldconfig

Comment 2 Petr Pisar 2015-03-12 09:59:58 UTC
The tests were disabled because ext/threads-shared/t/stress* (sometimes?) failed on s390. How many times did you performed the test on the platform?

Comment 3 Martin Kyral 2015-03-12 10:57:37 UTC
(In reply to Petr Pisar from comment #2)
> The tests were disabled because ext/threads-shared/t/stress* (sometimes?)
> failed on s390. How many times did you performed the test on the platform?

Just once on ppc64 and s390x. Didn't try s390 build. I'll try it in a loop and post here the results.

Comment 4 Martin Kyral 2015-03-13 08:16:30 UTC
Rebuilt on ppc64 18 times and on s390x 20 times using rpmbuild without single fail. I suppose at least these two architectures can be safely enabled back again. s390 doesn't really bother me as only perl-libs, perl-version and perl-debuginfo are being shipped for this architecture.

Anyways, if the tests are still being problematic, they can be blocked again.

Comment 5 Petr Pisar 2015-03-13 11:28:01 UTC
I stressed the threads on s390x and ppc64 and the works well. I could not get access to s390 machine, but a few builds in the build system pass. So I think we can enable the tests everywhere again.

Comment 10 errata-xmlrpc 2015-07-22 05:59:53 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2015-1266.html


Note You need to log in before you can comment on or make changes to this bug.