Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be unavailable on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 1201194 - Base Operating System requirement for a networkless DVD installation is at least RHEL 6.6
Summary: Base Operating System requirement for a networkless DVD installation is at le...
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Satellite
Classification: Red Hat
Component: Docs Install Guide
Version: Unspecified
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: Unspecified
Assignee: jsomers
QA Contact: Megan Lewis
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-03-12 09:49 UTC by David Gurtner
Modified: 2019-09-26 15:42 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Build Name: 22922, Installation Guide-6.0-1 Build Date: 07-10-2014 15:39:35 Topic ID: 10911-714915 [Latest]
Last Closed: 2015-07-09 13:38:18 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description David Gurtner 2015-03-12 09:49:02 UTC
Title: Prerequisites

Describe the issue:

If doing an installation for a disconnected Satellite, the requirements are misleading.

According to the following sentences:
- Install the operating system from disc, local ISO image, kickstart, or any other method that Red Hat supports and update the system to the latest set of packages in Red Hat Enterprise Linux.
- There should be at least one networked host with the following minimum specifications:
  - 64-bit architecture
  - Red Hat Enterprise Linux 6.5 or later

This implies that the following is a valid scenario:
Install 2 RHEL 6.5 servers from local ISO image (DVD), one of them (the synchronization host) has network connectivity, while the other (the Satellite) does not.

When now trying to install Satellite 6 from DVD (as described in section 2.2) on the host without network connectivity this fails because of missing packages (only available from the RHEL base channel, see Bug #1201193).
If configuring a base channel by mounting the DVD, this fails for RHEL 6.5:

[root@rhel6-sat6 iso]# ./install_packages
This script will install the katello packages on the current machine.
   - Ensuring we are in an expected directory.
   - Copying installation files.
   - Creating a Repository File
   - Creating RHSCL Repository File
   - Checking to see if Katello is already installed.
   - Importing the gpg key.
   - katello is not yet installed, installing it.
This system is not registered to Red Hat Subscription Management. You can use subscription-manager to register.
   - Installation repository will remain configured for future package installs.
   - Installation media can now be safely unmounted.

Install is complete. Please run katello-installer.
[root@rhel6-sat6 iso]# katello-installer•
 Execution of '/usr/bin/yum -d 0 -e 0 -y install katello-certs-tools' returned 1: Error: Package: katello-certs-tools-1.5.6-1.el6sat.noarch (katello-local)
 /Stage[main]/Certs::Install/Package[katello-certs-tools]/ensure: change from absent to present failed: Execution of '/usr/bin/yum -d 0 -e 0 -y install katello-certs-tools' returned 1: Error: Package: katello-certs-tools-1.5.6-1.el6sat.noarch (katello-local)
 /Stage[main]/Foreman::Database/Foreman::Rake[db:migrate]/Exec[foreman-rake-db:migrate]: Failed to call refresh: /usr/sbin/foreman-rake db:migrate returned 1 instead of one of [0]
 /Stage[main]/Foreman::Database/Foreman::Rake[db:migrate]/Exec[foreman-rake-db:migrate]: /usr/sbin/foreman-rake db:migrate returned 1 instead of one of [0]
 /Stage[main]/Candlepin::Service/Exec[cpinit]: Failed to call refresh: /usr/bin/wget --timeout=30 --tries=5 --retry-connrefused -qO- http://localhost:8080/candlepin/admin/init >/var/log/candlepin/cpinit.log 2>&1 && touch /var/lib/candlepin/cpinit_done returned 4 instead of one of [0]
 /Stage[main]/Candlepin::Service/Exec[cpinit]: /usr/bin/wget --timeout=30 --tries=5 --retry-connrefused -qO- http://localhost:8080/candlepin/admin/init >/var/log/candlepin/cpinit.log 2>&1 && touch /var/lib/candlepin/cpinit_done returned 4 instead of one of [0]
 /Stage[main]/Foreman::Database/Foreman::Rake[db:seed]/Exec[foreman-rake-db:seed]: Failed to call refresh: /usr/sbin/foreman-rake db:seed returned 1 instead of one of [0]
 /Stage[main]/Foreman::Database/Foreman::Rake[db:seed]/Exec[foreman-rake-db:seed]: /usr/sbin/foreman-rake db:seed returned 1 instead of one of [0]
 /Stage[main]/Foreman::Database/Foreman::Rake[apipie:cache]/Exec[foreman-rake-apipie:cache]: Failed to call refresh: /usr/sbin/foreman-rake apipie:cache returned 1 instead of one of [0]
 /Stage[main]/Foreman::Database/Foreman::Rake[apipie:cache]/Exec[foreman-rake-apipie:cache]: /usr/sbin/foreman-rake apipie:cache returned 1 instead of one of [0]
 Could not find a suitable provider for certs_bootstrap_rpm
Installing             Done                                               [100%] [....................................................................................]
  Something went wrong! Check the log for ERROR-level output
  The full log is at /var/log/katello-installer/katello-installer.log
[root@rhel6-sat6 iso]# yum install katello-certs-tools
Loaded plugins: product-id, security, subscription-manager
This system is not registered to Red Hat Subscription Management. You can use subscription-manager to register.
Setting up Install Process
Resolving Dependencies
--> Running transaction check
---> Package katello-certs-tools.noarch 0:1.5.6-1.el6sat will be installed
--> Processing Dependency: openssl >= 1.0.1e-16 for package: katello-certs-tools-1.5.6-1.el6sat.noarch
--> Processing Dependency: rpm-build for package: katello-certs-tools-1.5.6-1.el6sat.noarch
--> Running transaction check
---> Package katello-certs-tools.noarch 0:1.5.6-1.el6sat will be installed
--> Processing Dependency: openssl >= 1.0.1e-16 for package: katello-certs-tools-1.5.6-1.el6sat.noarch
---> Package rpm-build.x86_64 0:4.8.0-37.el6 will be installed
--> Processing Dependency: /usr/bin/gdb-add-index for package: rpm-build-4.8.0-37.el6.x86_64
--> Running transaction check
---> Package gdb.x86_64 0:7.2-60.el6_4.1 will be installed
---> Package katello-certs-tools.noarch 0:1.5.6-1.el6sat will be installed
--> Processing Dependency: openssl >= 1.0.1e-16 for package: katello-certs-tools-1.5.6-1.el6sat.noarch
--> Finished Dependency Resolution
Error: Package: katello-certs-tools-1.5.6-1.el6sat.noarch (katello-local)
           Requires: openssl >= 1.0.1e-16
           Installed: openssl-1.0.1e-15.el6.x86_64 (@anaconda-RedHatEnterpriseLinux-201311111358.x86_64/6.5)
               openssl = 1.0.1e-15.el6
 You could try using --skip-broken to work around the problem
 You could try running: rpm -Va --nofiles --nodigest



Suggestions for improvement:

As the above scenario works for RHEL 6.6 and Satellite 6.0.4, change the requirement to at least RHEL 6.6


Additional information:

Comment 1 RHEL Program Management 2015-03-12 09:53:14 UTC
Since this issue was entered in Red Hat Bugzilla, the release flag has been
set to ? to ensure that it is properly evaluated for this release.

Comment 2 Athene Chan 2015-03-16 03:19:48 UTC
Hi David,

From the whole message, it looks like the openssl requirement was bumped up, probably because the 6.5 version of the openssl had security issues. I agree that it should be called out if needed, but at the same time I think we need to tell the developers of this, in case it slipped past their attention as well.

Passing this to Mike Mccune to look over before we add it to the doc requirements.

Cheers,
Athene

Comment 3 Mike McCune 2015-03-17 03:52:12 UTC
+1 to updating the docs to 6.6

Comment 7 jsomers 2015-05-20 17:53:55 UTC
Hi Megan,
I found the content I changed in the Satellite 6.0 Installation Guide, Section 1.5 Prerequisites:
https://access.redhat.com/documentation/en-US/Red_Hat_Satellite/6.0/html/Installation_Guide/sect-Red_Hat_Satellite-Installation_Guide-Prerequisites.html


Note You need to log in before you can comment on or make changes to this bug.