Bug 1201207 - FormatDestroyError: error wiping old signatures from /dev/vda2: 1
Summary: FormatDestroyError: error wiping old signatures from /dev/vda2: 1
Keywords:
Status: CLOSED DUPLICATE of bug 1166598
Alias: None
Product: Fedora
Classification: Fedora
Component: anaconda
Version: 22
Hardware: x86_64
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Anaconda Maintenance Team
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: abrt_hash:68fc2b8e21c63a777b619dcfa76...
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-03-12 10:27 UTC by Lukas Brabec
Modified: 2015-03-12 12:20 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-03-12 12:20:06 UTC
Type: ---


Attachments (Terms of Use)
File: anaconda-tb (497.74 KB, text/plain)
2015-03-12 10:27 UTC, Lukas Brabec
no flags Details
File: anaconda.log (28.60 KB, text/plain)
2015-03-12 10:27 UTC, Lukas Brabec
no flags Details
File: dnf.log (13.57 KB, text/plain)
2015-03-12 10:27 UTC, Lukas Brabec
no flags Details
File: environ (492 bytes, text/plain)
2015-03-12 10:27 UTC, Lukas Brabec
no flags Details
File: lsblk_output (1.90 KB, text/plain)
2015-03-12 10:27 UTC, Lukas Brabec
no flags Details
File: nmcli_dev_list (1.02 KB, text/plain)
2015-03-12 10:27 UTC, Lukas Brabec
no flags Details
File: os_info (443 bytes, text/plain)
2015-03-12 10:27 UTC, Lukas Brabec
no flags Details
File: storage.log (166.10 KB, text/plain)
2015-03-12 10:27 UTC, Lukas Brabec
no flags Details
File: syslog (72.44 KB, text/plain)
2015-03-12 10:27 UTC, Lukas Brabec
no flags Details
File: ifcfg.log (2.25 KB, text/plain)
2015-03-12 10:27 UTC, Lukas Brabec
no flags Details
File: packaging.log (1.14 KB, text/plain)
2015-03-12 10:27 UTC, Lukas Brabec
no flags Details
File: program.log (30.92 KB, application/octet-stream)
2015-03-12 10:27 UTC, Lukas Brabec
no flags Details

Description Lukas Brabec 2015-03-12 10:27:23 UTC
Description of problem:
Tried to reproduce 1166598. 
Virtual machine with two virtio disks

1. select both disks in anaconda, delete all
2. go back to disk selection
3. unselect second, delete all on first disk
4. begin installation

Version-Release number of selected component:
anaconda-22.20.2-1

The following was filed automatically by anaconda:
anaconda 22.20.2-1 exception report
Traceback (most recent call first):
  File "/usr/lib/python2.7/site-packages/blivet/formats/__init__.py", line 396, in destroy
    raise FormatDestroyError(msg)
  File "/usr/lib/python2.7/site-packages/blivet/deviceaction.py", line 661, in execute
    self.format.destroy()
  File "/usr/lib/python2.7/site-packages/blivet/devicetree.py", line 361, in processActions
    action.execute(callbacks)
  File "/usr/lib/python2.7/site-packages/blivet/__init__.py", line 252, in doIt
    self.devicetree.processActions(callbacks)
  File "/usr/lib/python2.7/site-packages/blivet/osinstall.py", line 1063, in turnOnFilesystems
    storage.doIt(callbacks)
  File "/usr/lib64/python2.7/site-packages/pyanaconda/install.py", line 188, in doInstall
    turnOnFilesystems(storage, mountOnly=flags.flags.dirInstall, callbacks=callbacks_reg)
  File "/usr/lib64/python2.7/threading.py", line 766, in run
    self.__target(*self.__args, **self.__kwargs)
  File "/usr/lib64/python2.7/site-packages/pyanaconda/threads.py", line 238, in run
    threading.Thread.run(self, *args, **kwargs)
FormatDestroyError: error wiping old signatures from /dev/vda2: 1

Additional info:
addons:         com_redhat_kdump
cmdline:        /usr/bin/python2  /sbin/anaconda
cmdline_file:   BOOT_IMAGE=vmlinuz initrd=initrd.img inst.stage2=hd:LABEL=Fedora-22_B_T1-x86_64 quiet
dnf.rpm.log:    Mar 12 10:21:44 INFO --- logging initialized ---
executable:     /sbin/anaconda
hashmarkername: anaconda
kernel:         4.0.0-0.rc1.git0.1.fc22.x86_64
product:        Fedora"
release:        Cannot get release name.
type:           anaconda
version:        Fedora

Comment 1 Lukas Brabec 2015-03-12 10:27:27 UTC
Created attachment 1000905 [details]
File: anaconda-tb

Comment 2 Lukas Brabec 2015-03-12 10:27:29 UTC
Created attachment 1000906 [details]
File: anaconda.log

Comment 3 Lukas Brabec 2015-03-12 10:27:30 UTC
Created attachment 1000907 [details]
File: dnf.log

Comment 4 Lukas Brabec 2015-03-12 10:27:31 UTC
Created attachment 1000908 [details]
File: environ

Comment 5 Lukas Brabec 2015-03-12 10:27:32 UTC
Created attachment 1000909 [details]
File: lsblk_output

Comment 6 Lukas Brabec 2015-03-12 10:27:34 UTC
Created attachment 1000910 [details]
File: nmcli_dev_list

Comment 7 Lukas Brabec 2015-03-12 10:27:35 UTC
Created attachment 1000911 [details]
File: os_info

Comment 8 Lukas Brabec 2015-03-12 10:27:37 UTC
Created attachment 1000912 [details]
File: storage.log

Comment 9 Lukas Brabec 2015-03-12 10:27:39 UTC
Created attachment 1000913 [details]
File: syslog

Comment 10 Lukas Brabec 2015-03-12 10:27:40 UTC
Created attachment 1000914 [details]
File: ifcfg.log

Comment 11 Lukas Brabec 2015-03-12 10:27:41 UTC
Created attachment 1000915 [details]
File: packaging.log

Comment 12 Lukas Brabec 2015-03-12 10:27:43 UTC
Created attachment 1000916 [details]
File: program.log

Comment 13 Lukas Brabec 2015-03-12 12:14:08 UTC
Another user experienced a similar problem:

tried to reproduce bug 1201207

addons:         com_redhat_kdump
cmdline:        /usr/bin/python2  /sbin/anaconda
cmdline_file:   BOOT_IMAGE=vmlinuz initrd=initrd.img inst.stage2=hd:LABEL=Fedora-22_B_T1-x86_64 quiet
dnf.rpm.log:    Mar 12 12:11:37 INFO --- logging initialized ---
hashmarkername: anaconda
kernel:         4.0.0-0.rc1.git0.1.fc22.x86_64
package:        anaconda-22.20.2-1
product:        Fedora"
reason:         FormatDestroyError: error wiping old signatures from /dev/sda2: 1
release:        Cannot get release name.
version:        Fedora

Comment 14 Lukas Brabec 2015-03-12 12:20:06 UTC

*** This bug has been marked as a duplicate of bug 1166598 ***


Note You need to log in before you can comment on or make changes to this bug.