Bug 1201224 - auto-attach with an invalid servicelevel does NOT show a concise info
Summary: auto-attach with an invalid servicelevel does NOT show a concise info
Keywords:
Status: CLOSED DEFERRED
Alias: None
Product: Red Hat Satellite
Classification: Red Hat
Component: Registration
Version: Nightly
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: Unspecified
Assignee: satellite6-bugs
QA Contact: Katello QA List
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-03-12 11:14 UTC by qianzhan
Modified: 2019-09-26 13:53 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-03-13 20:12:55 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description qianzhan 2015-03-12 11:14:59 UTC
Description of problem:
auto-attach with an invalid servicelevel does NOT show a concise info

Version-Release number of selected component (if applicable):

Nightly SAM6.1
subscription-manager: 1.13.22-1.el7
python-rhsm: 1.13.10-1.el7

How reproducible:
always

Steps to Reproduce:
1.Register and auto-attach with an invalid servicelevel.
[root@dhcp-128-77 ~]# subscription-manager register --username=admin --password=123qwe --servicelevel=foo --auto-attach
Organization: Default_Organization
The system has been registered with ID: 648a2210-3cda-4864-87dc-a81088dcd11c 
Task 28170b4b-24ca-42d8-9b0d-2300cfd87a29: Katello::Errors::CandlepinError: Service level 'foo' is not available to units of organization Default_Organization.
[root@dhcp-128-77 ~]# 


Actual results:
As step 1.

Expected results:
It would be conciser to remove this part:"Task 28170b4b-24ca-42d8-9b0d-2300cfd87a29: Katello::Errors::CandlepinError:" 

Additional info:

Comment 1 RHEL Program Management 2015-03-12 11:33:19 UTC
Since this issue was entered in Red Hat Bugzilla, the release flag has been
set to ? to ensure that it is properly evaluated for this release.

Comment 3 qianzhan 2015-03-20 03:27:17 UTC
Conciser info is also need when setting a wrong service level:

[root@dhcp-128-77 ~]# subscription-manager service-level --set=w
Task c86a6767-d830-4612-9bab-4b0297bc7ea8: Katello::Errors::CandlepinError: Service level 'w' is not available to units of organization Default_Organization.

Comment 4 Bryan Kearney 2016-07-08 20:32:47 UTC
Per 6.3 planning, moving out non acked bugs to the backlog

Comment 6 Bryan Kearney 2017-03-13 20:12:55 UTC
I do not see this bug being addressed in the near term. If you believe closing this is an issue, please feel free to re-open with additional information.


Note You need to log in before you can comment on or make changes to this bug.