Bug 120124 - policy prevents spamd working
Summary: policy prevents spamd working
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: spamassassin (Show other bugs)
(Show other bugs)
Version: rawhide
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Chip Turner
QA Contact:
URL:
Whiteboard:
Keywords: SELinux
Depends On:
Blocks: FC2Target
TreeView+ depends on / blocked
 
Reported: 2004-04-06 08:37 UTC by Tim Waugh
Modified: 2007-11-30 22:10 UTC (History)
1 user (show)

Fixed In Version: 1.11.2-6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-04-15 10:50:46 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
spamd-audit (4.17 KB, text/plain)
2004-04-06 13:52 UTC, Tim Waugh
no flags Details
full spamassassin policy (5.54 KB, text/plain)
2004-04-14 15:16 UTC, Colin Walters
no flags Details

Description Tim Waugh 2004-04-06 08:37:31 UTC
Description of problem:
When fetching mail using Evolution with a filter running
'/usr/bin/spamc -c' (and spamd is running), I get this audit message
and lots of spam:

audit(1081239865.400:0): avc:  denied  { getattr } for  pid=3898
exe=/usr/bin/perl path=/home dev=hda6 ino=2
scontext=system_u:system_r:spamd_t
tcontext=system_u:object_r:home_root_t tclass=dir

Version-Release number of selected component (if applicable):
spamassassin-2.63-7
policy-1.9.2-12

How reproducible:
100%

Comment 1 Daniel Walsh 2004-04-06 10:44:18 UTC
Could you run the same command in non enforcing mode and submit the
avc messages.

Thanks Dan

Comment 2 Tim Waugh 2004-04-06 13:52:48 UTC
Created attachment 99141 [details]
spamd-audit

Comment 3 Colin Walters 2004-04-13 20:44:12 UTC
Hmm.  I think this is because half of my spamd policy never got into
Russell's tree.  I'll bug him...

Comment 4 Colin Walters 2004-04-14 15:16:10 UTC
Created attachment 99409 [details]
full spamassassin policy

Comment 5 Tim Waugh 2004-04-15 10:50:46 UTC
This is working in policy-1.11.2-6.


Note You need to log in before you can comment on or make changes to this bug.