Bug 120128 - After Grub install unable to boot Windows XP
Summary: After Grub install unable to boot Windows XP
Status: CLOSED DUPLICATE of bug 115980
Alias: None
Product: Fedora
Classification: Fedora
Component: grub   
(Show other bugs)
Version: rawhide
Hardware: athlon
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Jeremy Katz
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-04-06 09:14 UTC by David Richards
Modified: 2007-11-30 22:10 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 19:02:25 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description David Richards 2004-04-06 09:14:17 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.6)
Gecko/20040206 Firefox/0.8

Description of problem:
Installed Fedora Core Test 2. Can happily boot into Fedora, but I am
now unable to boot into windows XP

Section taken from grub.conf

title Windows XP
rootnoverify (hd0,0)
makeactive
chainloader +1

When this option is selected, grub starts and Fedora boots fine but
trying to boot Win XP, the following prints to the screen:

rootnoverify (hd0,0)
makeactive
chainloader+1

(blinking cursor)


I have tried using the windows XP recover console, and runing fixboot
and fixmbr, but even after runing these I'm still unable to run
windows. After running these I reinstall grub using recovery mode from
the fedora disks, which lets me boot Fedora again.

Version-Release number of selected component (if applicable):


How reproducible:
Didn't try

Steps to Reproduce:
1. Have windows XP installed
2. Insatll Fedora Test 2, (leaving all options as default)
3. Try booting from Windows XP
    

Actual Results:  Fedora boots fine but trying to boot Win XP, the
following prints to the screen:

rootnoverify (hd0,0)
makeactive
chainloader+1

(blinking cursor)




Expected Results:  Windows Xp should start

Additional info:

Comment 1 Need Real Name 2004-05-05 13:46:30 UTC
I'm thinking this is a duplicate of Bug# 115980.  This still hasn't 
been resolved (to my knowledge).

Comment 2 Confushion 2004-05-10 01:50:01 UTC
This just happened to me with Fedora Core 2 Test 3!  It's not fixed.

Comment 3 Nils Philippsen 2004-05-17 20:42:36 UTC

*** This bug has been marked as a duplicate of 115980 ***

Comment 4 Revant Nandgaonkar 2004-05-30 08:28:41 UTC
Make your default boot loader NTLDR
Make the linux.bin
with
-- one-line command--
dd if=/dev/{bootpartition} of=/mnt/windows_root_c/Linux.bin bs=512 count=1

--- command end ----

edit C:\boot.ini and add line:
C:\Linux.bin="Fedora Core 2"

set active boot partition to win partition


Comment 5 Red Hat Bugzilla 2006-02-21 19:02:25 UTC
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.


Note You need to log in before you can comment on or make changes to this bug.