Bug 1201281 - Free glfs structure pointers when destroying fs object.
Summary: Free glfs structure pointers when destroying fs object.
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: GlusterFS
Classification: Community
Component: libgfapi
Version: mainline
Hardware: x86_64
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Sheetal Pamecha
QA Contact: Sudhir D
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-03-12 13:05 UTC by Humble Chirammal
Modified: 2018-10-23 05:56 UTC (History)
3 users (show)

Fixed In Version: glusterfs-4.1.4
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-10-23 05:56:56 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)

Description Humble Chirammal 2015-03-12 13:05:45 UTC
Description of problem:

Currently glfs  oldvolfile member is not freed in glfs_free_from_ctx().


Version-Release number of selected component (if applicable):

GlusterFS 3.6.2

How reproducible:
N/A

Steps to Reproduce:
N/A

Actual results:

The member is not freed when ctx is destroyed.

Expected results:

It should free all the members.

Additional info:

Comment 1 Anand Avati 2015-03-12 13:06:43 UTC
REVIEW: http://review.gluster.org/9867 (libgfapi: free fs->oldvolfile in destroy function.) posted (#1) for review on master by Humble Devassy Chirammal (humble.devassy@gmail.com)

Comment 2 Anand Avati 2015-03-12 16:37:54 UTC
REVIEW: http://review.gluster.org/9867 (libgfapi: free fs->oldvolfile in destroy function.) posted (#2) for review on master by Humble Devassy Chirammal (humble.devassy@gmail.com)

Comment 3 Anand Avati 2015-03-13 04:15:06 UTC
REVIEW: http://review.gluster.org/9867 (libgfapi: free fs->oldvolfile in destroy function.) posted (#3) for review on master by Humble Devassy Chirammal (humble.devassy@gmail.com)

Comment 4 Anand Avati 2015-03-13 04:19:25 UTC
REVIEW: http://review.gluster.org/9867 (libgfapi: free fs->oldvolfile in destroy function.) posted (#4) for review on master by Humble Devassy Chirammal (humble.devassy@gmail.com)

Comment 5 Anand Avati 2015-03-13 13:49:31 UTC
REVIEW: http://review.gluster.org/9867 (libgfapi: free fs->oldvolfile in destroy function.) posted (#5) for review on master by Humble Devassy Chirammal (humble.devassy@gmail.com)

Comment 6 Anand Avati 2015-03-13 19:35:52 UTC
REVIEW: http://review.gluster.org/9881 (libgfapi: free oldvolfile memory in free_from_context) posted (#1) for review on master by Humble Devassy Chirammal (humble.devassy@gmail.com)

Comment 7 Anand Avati 2015-03-13 20:01:19 UTC
REVIEW: http://review.gluster.org/9881 (libgfapi: free oldvolfile memory in free_from_context.) posted (#2) for review on master by Humble Devassy Chirammal (humble.devassy@gmail.com)

Comment 8 Anand Avati 2015-03-13 20:27:36 UTC
REVIEW: http://review.gluster.org/9867 (libgfapi: free fs->oldvolfile in destroy function.) posted (#6) for review on master by Humble Devassy Chirammal (humble.devassy@gmail.com)

Comment 9 Anand Avati 2015-03-16 10:59:35 UTC
REVIEW: http://review.gluster.org/9867 (libgfapi: free fs->oldvolfile in destroy function.) posted (#7) for review on master by Humble Devassy Chirammal (humble.devassy@gmail.com)

Comment 10 Anand Avati 2015-03-16 19:57:01 UTC
REVIEW: http://review.gluster.org/9867 (libgfapi: free fs->oldvolfile in destroy function.) posted (#8) for review on master by Humble Devassy Chirammal (humble.devassy@gmail.com)

Comment 11 Anand Avati 2015-03-17 08:48:51 UTC
REVIEW: http://review.gluster.org/9867 (libgfapi: free fs->oldvolfile in destroy function.) posted (#9) for review on master by Humble Devassy Chirammal (humble.devassy@gmail.com)

Comment 12 Anand Avati 2015-03-17 12:39:05 UTC
REVIEW: http://review.gluster.org/9867 (libgfapi: free fs->oldvolfile in destroy function) posted (#10) for review on master by Humble Devassy Chirammal (humble.devassy@gmail.com)

Comment 13 Anand Avati 2015-03-17 17:06:47 UTC
REVIEW: http://review.gluster.org/9867 (libgfapi: free fs->oldvolfile in destroy function) posted (#11) for review on master by Humble Devassy Chirammal (humble.devassy@gmail.com)

Comment 14 Anand Avati 2015-03-18 09:34:33 UTC
REVIEW: http://review.gluster.org/9867 (libgfapi: free fs->oldvolfile in destroy function) posted (#12) for review on master by Humble Devassy Chirammal (humble.devassy@gmail.com)

Comment 15 Anand Avati 2015-03-18 11:38:51 UTC
REVIEW: http://review.gluster.org/9867 (libgfapi: free fs->oldvolfile in destroy function) posted (#13) for review on master by Humble Devassy Chirammal (humble.devassy@gmail.com)

Comment 16 Anand Avati 2015-03-18 18:59:29 UTC
REVIEW: http://review.gluster.org/9867 (libgfapi: free fs->oldvolfile in destroy function) posted (#14) for review on master by Humble Devassy Chirammal (humble.devassy@gmail.com)

Comment 17 Amar Tumballi 2018-10-08 10:15:41 UTC
Sheetal, see if this is still happening, and can you resubmit the above patch?

Comment 18 Sheetal Pamecha 2018-10-23 04:50:24 UTC
Hello Amar, The problem is already resolved. oldvolfile member is now getting freed when ctx is destroyed.


Note You need to log in before you can comment on or make changes to this bug.