Bug 1201284 - tools/glusterfind: Use Changelogs more effectively for GFID to Path conversion
Summary: tools/glusterfind: Use Changelogs more effectively for GFID to Path conversion
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: GlusterFS
Classification: Community
Component: glusterfind
Version: mainline
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Aravinda VK
QA Contact: bugs@gluster.org
URL:
Whiteboard:
Depends On:
Blocks: qe_tracker_everglades 1219475 glusterfs-3.7.1
TreeView+ depends on / blocked
 
Reported: 2015-03-12 13:11 UTC by Aravinda VK
Modified: 2016-06-16 12:43 UTC (History)
6 users (show)

Fixed In Version: glusterfs-3.8rc2
Doc Type: Bug Fix
Doc Text:
Clone Of:
: 1219475 (view as bug list)
Environment:
Last Closed: 2016-06-16 12:43:55 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)

Description Aravinda VK 2015-03-12 13:11:44 UTC
Description of problem:
Tool is collecting GFIDs from Changelogs and Using pgfid or find to convert to Path. We can utilize information present in Changelogs as first approach and then fallback to pgfid/find approach.

Additional info:
Patch is yet to get merged. http://review.gluster.org/#/c/9682/

Comment 1 Anand Avati 2015-04-21 17:59:35 UTC
REVIEW: http://review.gluster.org/10320 ([WIP] tools/glusterfind: Partial Find and GFID to Path using Changelogs) posted (#1) for review on master by Aravinda VK (avishwan@redhat.com)

Comment 2 Anand Avati 2015-04-24 11:30:39 UTC
REVIEW: http://review.gluster.org/10320 ([WIP] tools/glusterfind: Partial Find and GFID to Path using Changelogs) posted (#2) for review on master by Aravinda VK (avishwan@redhat.com)

Comment 3 Anand Avati 2015-04-27 04:28:30 UTC
REVIEW: http://review.gluster.org/10320 (tools/glusterfind: Partial Find and GFID to Path using Changelogs) posted (#3) for review on master by Aravinda VK (avishwan@redhat.com)

Comment 4 Anand Avati 2015-04-29 18:40:52 UTC
REVIEW: http://review.gluster.org/10320 (tools/glusterfind: Partial Find) posted (#4) for review on master by Aravinda VK (avishwan@redhat.com)

Comment 5 Anand Avati 2015-04-30 06:44:05 UTC
REVIEW: http://review.gluster.org/10320 (tools/glusterfind: Partial Find) posted (#5) for review on master by Aravinda VK (avishwan@redhat.com)

Comment 6 Anand Avati 2015-04-30 08:45:41 UTC
REVIEW: http://review.gluster.org/10320 (tools/glusterfind: Partial Find) posted (#6) for review on master by Aravinda VK (avishwan@redhat.com)

Comment 7 Anand Avati 2015-04-30 08:45:43 UTC
REVIEW: http://review.gluster.org/10463 (tools/glusterfind: GFID to Path conversion using Changelog) posted (#1) for review on master by Aravinda VK (avishwan@redhat.com)

Comment 8 Anand Avati 2015-05-02 13:41:52 UTC
REVIEW: http://review.gluster.org/10320 (tools/glusterfind: Partial Find) posted (#7) for review on master by Aravinda VK (avishwan@redhat.com)

Comment 9 Anand Avati 2015-05-02 18:22:49 UTC
REVIEW: http://review.gluster.org/10463 (tools/glusterfind: GFID to Path conversion using Changelog) posted (#2) for review on master by Aravinda VK (avishwan@redhat.com)

Comment 10 Anand Avati 2015-05-08 10:54:59 UTC
REVIEW: http://review.gluster.org/10463 (tools/glusterfind: GFID to Path conversion using Changelog) posted (#4) for review on master by Aravinda VK (avishwan@redhat.com)

Comment 11 Anand Avati 2015-05-09 04:59:14 UTC
COMMIT: http://review.gluster.org/10463 committed in master by Vijay Bellur (vbellur@redhat.com) 
------
commit e88837ed0ff68093912c2b8e996c5851c53674ca
Author: Aravinda VK <avishwan@redhat.com>
Date:   Thu Apr 30 12:28:17 2015 +0530

    tools/glusterfind: GFID to Path conversion using Changelog
    
    Records fop information collected from Changelogs in sqlite database.
    This is only working database, not required after processing.
    
    After post processing, output file is generated by reading these
    database files.
    
    This is applicable only in incremental run, When a changelog is
    parsed, all the details are saved in Db. GFID to Path is converted
    to those files for which information is available in Changelogs.
    
    For all the failed cases, it tries to convert to Path using Pgfid,
    if not found GFID to Path is done using find.
    
    BUG: 1201284
    Change-Id: I53f168860dae15a0149004835e67f97aebd822be
    Signed-off-by: Aravinda VK <avishwan@redhat.com>
    Reviewed-on: http://review.gluster.org/10463
    Reviewed-by: Kotresh HR <khiremat@redhat.com>
    Tested-by: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: Vijay Bellur <vbellur@redhat.com>

Comment 12 Aravinda VK 2015-05-27 08:08:50 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.7.0, please open a new bug report.

Comment 13 Niels de Vos 2016-06-16 12:43:55 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.8.0, please open a new bug report.

glusterfs-3.8.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://blog.gluster.org/2016/06/glusterfs-3-8-released/
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user


Note You need to log in before you can comment on or make changes to this bug.