Bug 1201289 - tools/glusterfind: Support Partial Find feature
Summary: tools/glusterfind: Support Partial Find feature
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: GlusterFS
Classification: Community
Component: glusterfind
Version: mainline
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Aravinda VK
QA Contact: bugs@gluster.org
URL:
Whiteboard:
Depends On:
Blocks: qe_tracker_everglades 1219467
TreeView+ depends on / blocked
 
Reported: 2015-03-12 13:17 UTC by Aravinda VK
Modified: 2016-06-16 12:43 UTC (History)
6 users (show)

Fixed In Version: glusterfs-3.8rc2
Doc Type: Bug Fix
Doc Text:
Clone Of:
: 1219467 (view as bug list)
Environment:
Last Closed: 2016-06-16 12:43:55 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)

Description Aravinda VK 2015-03-12 13:17:20 UTC
Description of problem:
If one or more node is down, tool will fail to get partial list of files from all the other up nodes. Provide partial list option.


Additional info:
Feature patch: http://review.gluster.org/#/c/9682/

Comment 1 Aravinda VK 2015-04-27 04:35:16 UTC
This Patch addresses this issue. http://review.gluster.org/#/c/10320/
Moving this to POST.

Comment 2 Anand Avati 2015-05-02 18:22:52 UTC
REVIEW: http://review.gluster.org/10320 (tools/glusterfind: Partial Find) posted (#8) for review on master by Aravinda VK (avishwan@redhat.com)

Comment 3 Anand Avati 2015-05-05 02:02:03 UTC
REVIEW: http://review.gluster.org/10320 (tools/glusterfind: Partial Find) posted (#11) for review on master by Aravinda VK (avishwan@redhat.com)

Comment 4 Anand Avati 2015-05-08 10:55:01 UTC
REVIEW: http://review.gluster.org/10320 (tools/glusterfind: Partial Find) posted (#12) for review on master by Aravinda VK (avishwan@redhat.com)

Comment 5 Anand Avati 2015-05-08 18:25:52 UTC
REVIEW: http://review.gluster.org/10320 (tools/glusterfind: Partial Find) posted (#13) for review on master by Aravinda VK (avishwan@redhat.com)

Comment 6 Anand Avati 2015-05-09 04:19:30 UTC
COMMIT: http://review.gluster.org/10320 committed in master by Vijay Bellur (vbellur@redhat.com) 
------
commit e561935d0153f00f2ddacde093c12284affe9538
Author: Aravinda VK <avishwan@redhat.com>
Date:   Mon Apr 20 14:03:58 2015 +0530

    tools/glusterfind: Partial Find
    
    Enabled by default, if one node fails Glusterfind will not fail
    to return list of files from other nodes. This behavior can be changed
    using --disable-partial
    
    Now session is maintained in each nodes as well as in initiator node.
    Every pre command will pick the status file from respective node and
    start collecting list of changes happened after the status time.
    
    --reset-session-time, new option to force reset the session time.
    Next incremental run will start from this time.
    
    Change-detector argument is removed since Changelog mode is required
    to detect deletes and Renames.
    
    Change-Id: I0b83bc7c0e1b30b13de772b2d21fe968db4ff964
    Signed-off-by: Aravinda VK <avishwan@redhat.com>
    BUG: 1201289
    Reviewed-on: http://review.gluster.org/10320
    Tested-by: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: Kotresh HR <khiremat@redhat.com>
    Reviewed-by: Vijay Bellur <vbellur@redhat.com>

Comment 7 Aravinda VK 2015-05-27 08:08:41 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.7.0, please open a new bug report.

Comment 8 Niels de Vos 2016-06-16 12:43:55 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.8.0, please open a new bug report.

glusterfs-3.8.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://blog.gluster.org/2016/06/glusterfs-3-8-released/
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user


Note You need to log in before you can comment on or make changes to this bug.