Bug 1201298 - Missing dependency in RabbitVCS: python-simplejson
Summary: Missing dependency in RabbitVCS: python-simplejson
Keywords:
Status: CLOSED DUPLICATE of bug 1083043
Alias: None
Product: Fedora
Classification: Fedora
Component: rabbitvcs
Version: 21
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Juan Manuel Rodriguez
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-03-12 13:25 UTC by Juan Orti
Modified: 2015-10-05 07:31 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-10-05 07:31:09 UTC
Type: Bug


Attachments (Terms of Use)

Description Juan Orti 2015-03-12 13:25:13 UTC
Description of problem:
RabbitVCS doesn't work out of the box.

Version-Release number of selected component (if applicable):
rabbitvcs-nautilus-0.16-3.fc21.x86_64
rabbitvcs-gedit-0.16-3.fc21.x86_64
rabbitvcs-core-0.16-3.fc21.noarch
rabbitvcs-cli-0.16-3.fc21.noarch

How reproducible:
Always

Steps to Reproduce:
1. nautilus

Actual results:
$ nautilus
Traceback (most recent call last):
  File "/usr/share/nautilus-python/extensions/RabbitVCS.py", line 79, in <module>
    import rabbitvcs.ui.property_page
  File "/usr/lib/python2.7/site-packages/rabbitvcs/ui/property_page.py", line 40, in <module>
    from rabbitvcs.services.checkerservice import StatusCheckerStub as StatusChecker
  File "/usr/lib/python2.7/site-packages/rabbitvcs/services/checkerservice.py", line 48, in <module>
    import simplejson
ImportError: No module named simplejson

Expected results:
RabbitVCS loaded

Additional info:
Please, add a dependency to python-simplejson

Comment 1 cube00 2015-10-04 06:41:06 UTC
Dup of 1083043

Comment 2 Ben Liblit 2015-10-04 23:09:38 UTC
Per comment #1, this bug report should

Comment 3 Ben Liblit 2015-10-04 23:10:47 UTC
Oops, sorry for my incomplete comment #2.  I meant to say that per comment #1, this bug report should be marked as a duplicate of bug #1083043.  I don't have the power to do that myself..  Can we get some help here?

Comment 4 Juan Orti 2015-10-05 07:31:09 UTC

*** This bug has been marked as a duplicate of bug 1083043 ***


Note You need to log in before you can comment on or make changes to this bug.