Bug 120131 - Please include Bangla/Bengali during the installation process
Please include Bangla/Bengali during the installation process
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jeremy Katz
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-04-06 06:21 EDT by Jamil Ahmed
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-06-21 08:36:07 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jamil Ahmed 2004-04-06 06:21:56 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1) Opera 
7.23  [en]

Description of problem:
The translation of the essential packages for the Bangla/Bengali 
language, at the time of this writing, is more then 90%, thus it 
should be included and supported during the installation process of 
Fedora Core 2.


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. start anaconda installer


Actual Results:  Bangla/Bengali is not present in the list of 
languages.


Expected Results:  Bangla/Bengali should be among the installation 
languages.


Additional info:
Comment 1 Jeremy Katz 2004-04-06 14:48:41 EDT
I need the following information:
1) Confirmation that we ship a working font to display the language in
X.  If it's a language with all new glyphs (which I believe Bengali is),
then I need to know what package the font comes from and which font to
use so that it will actually display in the installer
2) The following information for the lang-table
  * console keyboard map to use
  * default time zone (eg, America/New York)
  * console font to use
  * default locale
  * keyboard mapping to use in X
Comment 2 Jamil Ahmed 2004-04-08 02:19:54 EDT
1) Bengali fonts are suppose to included in FC by Owen Taylor 
<otaylor redhat com>. See the urls below,

http://www.redhat.
com/archives/fedora-devel-list/2004-January/msg01305.html
http://www.redhat.
com/archives/fedora-devel-list/2004-January/msg01330.html

The fonts should be in the stage2.img fs in the installer cd.
MuktiNarrow font looks ugly when you enable hinting.
This can be avoided by inserting the following lines in, 
stage2/etc/fonts/local.conf

        <match target="font">
                <test name="family">
                        <string>Mukti Narrow</string>
                </test>
                <edit name="hinting">
                        <bool>false</bool>
                </edit>
        </match>


2)Here is the information for the lang-table

Full language name...: Bangla/Bengali (Bangladesh)
Short name...........: bn
Default Locale.......: bn_BD.UTF-8
Default keyboard map.: en
Console font.........: default
Timezone.............: GMT+6  Asia/Dhaka

Full language name...: Bangla/Bengali (India)
Short name...........: bn
Default Locale.......: bn_IN.UTF-8
Default keyboard map.: en
Console font.........: default
Timezone.............: GMT+530  Asia/Calcutta

Comment 3 Sayamindu Dasgupta 2004-04-08 02:57:52 EDT
Some comments (sorry for the spam):

1. The keyboard layout should be en (or is it US?) in all cases (since
you can't have passwd and stuff like that in Bangla yet
2. The default console font should be whatever that used for English
install - since no console font has Bengali glyphs. I think the font
in that case would be latarcyrheb-sun16
3. Bengali is written in the Bengali script as বাংলা 

Comment 4 Sayamindu Dasgupta 2004-04-08 14:59:26 EDT
By the way, the SRPM for the bengali font is at
http://download.fedora.redhat.com/pub/fedora/linux/core/test/1.91/SRPMS/fonts-bengali-0.1-2.src.rpm

Apparently, the FreeType autohinter cannot handle Indic fonts
correctly.  Freetype with bytecode interpreter enabled works fine. I
don't suppose Fedora will be enabling that - so the best solution will
be disable autohinting for the MuktiNarrow font by adding the lines as
suggested by Jamil in comment #2.
Comment 5 Jeremy Katz 2004-04-14 16:57:30 EDT
Added to lang-table and pull in fonts. 
http://people.redhat.com/~katzj/anaconda/anaconda-bengali.png is
running in test mode

As far as the auto-hinting change, this would need to be done on a
global basis for the distro, so filing against fontconfig to get that
done would be the best approach.
Comment 6 Jamil Ahmed 2004-04-15 00:58:17 EDT
I am getting "Page Not Found 404" @
http://people.redhat.com/~katzj/anaconda/anaconda-bengali.png 

:(

`Jamil
Comment 7 Sayamindu Dasgupta 2004-04-15 03:28:40 EDT
Bug filed against fontconfig (bug #120915). Thanks for all the help :-)

Note You need to log in before you can comment on or make changes to this bug.