Bug 1201314 - incorrect results from rpmdev-vercmp with some filenames [NEEDINFO]
Summary: incorrect results from rpmdev-vercmp with some filenames
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: rpmdevtools
Version: 7.1
Hardware: All
OS: Linux
unspecified
unspecified
Target Milestone: rc
: ---
Assignee: Packaging Maintenance Team
QA Contact: BaseOS QE Security Team
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-03-12 13:38 UTC by Pat Riehecky
Modified: 2019-12-10 12:09 UTC (History)
8 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of: 1200528
: 1201375 (view as bug list)
Environment:
Last Closed: 2019-12-10 12:09:32 UTC
Target Upstream Version:
dapospis: needinfo? (twoerner)


Attachments (Terms of Use)

Description Pat Riehecky 2015-03-12 13:38:28 UTC
Description of problem:
For certain filenames rpmdev-vercmp reports an incorrect result.

Version-Release number of selected component (if applicable):rpmdevtools-8.3-5.el7.noarch


How reproducible:100%


Steps to Reproduce:
1.rpmdev-vercmp asdf-1.2-4.el6 asdf-1.2.3-5.el6
2.
3.

Actual results:
asdf-1.2-4.el6 > asdf-1.2.3-5.el6

Expected results:
asdf-1.2-4.el6 < asdf-1.2.3-5.el6


Additional info:

Comment 5 Daniel Mach 2019-12-10 12:09:32 UTC
This is not a bug, you've used rpmdev-vercmp incorrectly.
You need to omit the name from the input:
$ rpmdev-vercmp <EVR1> <EVR2>


Note You need to log in before you can comment on or make changes to this bug.