Bug 120136 - /usr/include/linux/user.h is missing
/usr/include/linux/user.h is missing
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: glibc-kernheaders (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Arjan van de Ven
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-04-06 07:00 EDT by Ralf Ertzinger
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-05-03 09:37:07 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ralf Ertzinger 2004-04-06 07:00:55 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6) Gecko/20040312

Description of problem:
The file /usr/include/linux/user.h is missing from the package. It was
still present in 2.4.8-36.

Version-Release number of selected component (if applicable):
glibc-kernheaders-2.4-8.44

How reproducible:
Always

Steps to Reproduce:
1. Compile a program that includes <linux/user.h>
2.
3.
    

Actual Results:  Compilation fails

Expected Results:  Compilation succeeds

Additional info:
Comment 1 Arjan van de Ven 2004-04-06 07:07:44 EDT
uuuhhhhhhhhhh... why would any userspace program need that header??
Which app is this ?
Comment 2 Ralf Ertzinger 2004-04-06 12:31:02 EDT
The program in question is StepMania (http://www.stepmania.com), a
Dance Dance Revolution look/workalike for PC/XBox.

The header file is included in src/archutils/unix/LinuxThreadHelpers.cpp.

Unfortunately I have clue in neither thread programming nor C++, and
the stepmania forums seem to be down atm.

Might well be a user error to use that header in the first place.
Comment 3 Alan Cox 2004-05-03 09:37:07 EDT
Looks like a user error to use that header. You might want to see if
it compiles with that line removed 8)

Note You need to log in before you can comment on or make changes to this bug.