Bug 1201400 - Fail to install nodejs cartridge with rhscl-2.0 - OSE 2.0
Summary: Fail to install nodejs cartridge with rhscl-2.0 - OSE 2.0
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Installer
Version: 2.0.0
Hardware: Unspecified
OS: Unspecified
high
medium
Target Milestone: ---
: ---
Assignee: John W. Lamb
QA Contact:
URL:
Whiteboard:
: 1241887 (view as bug list)
Depends On: 1198409
Blocks: 1201399
TreeView+ depends on / blocked
 
Reported: 2015-03-12 16:10 UTC by John W. Lamb
Modified: 2015-08-11 17:37 UTC (History)
9 users (show)

Fixed In Version: nodejs010-nodejs-express-3.2.5-3.el6op
Doc Type: Bug Fix
Doc Text:
Cause: Package dependency version specifier for nodejs "mkdirp" package was too specific. Consequence: The package "nodejs010-nodejs-express" wouldn't install on systems where nodejs "mkdirp" package would satisfy dependency, but which had a more recent version than what was specified in the package dependencies. This prevented the nodejs cartridge dependencies from being satisfied, thus preventing the nodejs cartridge from installing. Fix: Change nodejs "mkdirp" dependency version specifier to (correctly) include versions greater than or equal to 0.3.4. Result: "nodejs010-nodejs-express" package no longer fails to install, and the nodejs cartridge now installs properly.
Clone Of: 1198409
Environment:
Last Closed: 2015-08-11 17:37:05 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2015:1588 0 normal SHIPPED_LIVE Red Hat OpenShift Enterprise 2.0.9 bug fix update 2015-08-11 21:36:51 UTC

Comment 3 Ma xiaoqiang 2015-03-13 07:08:41 UTC
Install the nodejs cartridge successfully on ose-2.0

Comment 4 John W. Lamb 2015-07-13 20:45:38 UTC
*** Bug 1241887 has been marked as a duplicate of this bug. ***

Comment 6 errata-xmlrpc 2015-08-11 17:37:05 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2015-1588.html


Note You need to log in before you can comment on or make changes to this bug.