Bug 1201408 - Infrastructure > Capsules > Certificates. It is not possible to delete a pending certificate signing request.
Summary: Infrastructure > Capsules > Certificates. It is not possible to delete a pend...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Capsule
Version: Nightly
Hardware: All
OS: Linux
medium
medium vote
Target Milestone: Unspecified
Assignee: Shlomi Zadok
QA Contact: Kedar Bidarkar
URL: http://projects.theforeman.org/issues...
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-03-12 16:23 UTC by Chris Roberts
Modified: 2019-08-12 16:34 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-07-27 09:14:19 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2016:1501 normal SHIPPED_LIVE Red Hat Satellite 6.2 Capsule and Server 2016-07-27 12:28:58 UTC

Description Chris Roberts 2015-03-12 16:23:54 UTC
Description of problem:

Infrastructure > Capsules > Certificates. It is not possible to delete a pending certificate signing request. You first have to sign it, then you can delete it.

Version-Release number of selected component (if applicable):


Installed Packages

    candlepin-0.9.23.1-1.el6.noarch
    candlepin-common-1.0.1-1.el6_5.noarch
    candlepin-scl-1-5.el6_4.noarch
    candlepin-scl-quartz-2.1.5-5.el6_4.noarch
    candlepin-scl-rhino-1.7R3-1.el6_4.noarch
    candlepin-scl-runtime-1-5.el6_4.noarch
    candlepin-selinux-0.9.23.1-1.el6.noarch
    candlepin-tomcat6-0.9.23.1-1.el6.noarch
    elasticsearch-0.90.10-6.el6sat.noarch
    katello-1.5.0-30.el6sat.noarch
    katello-certs-tools-1.5.6-1.el6sat.noarch
    katello-default-ca-1.0-1.noarch
    katello-installer-0.0.67-1.el6sat.noarch
    katello-server-ca-1.0-1.noarch
    katello.croberts.org-apache-1.0-1.noarch
    katello.croberts.org-foreman-client-1.0-1.noarch
    katello.croberts.org-foreman-proxy-1.0-1.noarch
    katello.croberts.org-parent-cert-1.0-1.noarch
    katello.croberts.org-puppet-client-1.0-1.noarch
    katello.croberts.org-qpid-broker-1.0-1.noarch
    katello.croberts.org-qpid-client-cert-1.0-1.noarch
    mod_wsgi-3.4-1.pulp.el6sat.x86_64
    pulp-katello-0.3-4.el6sat.noarch
    pulp-nodes-common-2.4.4-1.el6sat.noarch
    pulp-nodes-parent-2.4.4-1.el6sat.noarch
    pulp-puppet-plugins-2.4.4-1.el6sat.noarch
    pulp-puppet-tools-2.4.4-1.el6sat.noarch
    pulp-rpm-plugins-2.4.4-1.1.el6sat.noarch
    pulp-selinux-2.4.4-1.el6sat.noarch
    pulp-server-2.4.4-1.el6sat.noarch
    python-gofer-qpid-1.3.0-1.el6sat.noarch
    python-isodate-0.5.0-1.pulp.el6sat.noarch
    python-kombu-3.0.15-12.pulp.el6sat.noarch
    python-pulp-bindings-2.4.4-1.el6sat.noarch
    python-pulp-common-2.4.4-1.el6sat.noarch
    python-pulp-puppet-common-2.4.4-1.el6sat.noarch
    python-pulp-rpm-common-2.4.4-1.1.el6sat.noarch
    python-qpid-0.22-14.el6sat.noarch
    python-qpid-qmf-0.22-37.el6.x86_64
    qpid-cpp-client-0.22-42.el6.x86_64
    qpid-cpp-server-0.22-42.el6.x86_64
    qpid-cpp-server-linearstore-0.22-42.el6.x86_64
    qpid-java-client-0.22-6.el6.noarch
    qpid-java-common-0.22-6.el6.noarch
    qpid-proton-c-0.7-1.el6.x86_64
    qpid-qmf-0.22-37.el6.x86_64
    qpid-tools-0.22-12.el6.noarch
    ruby193-rubygem-katello-1.5.0-98.el6sat.noarch
    rubygem-hammer_cli_katello-0.0.4-14.el6sat.noarch
    rubygem-smart_proxy_pulp-1.0.1-1.1.el6sat.noarch

How reproducible:


Steps to Reproduce:
1. Infrastructure > Capsules > Certificates
2. Try to delete a cert that has a pending request
3.

Actual results:
Have to sign the cert before you can delete

Expected results:
option to delete the cert

Additional info:

Comment 1 RHEL Product and Program Management 2015-03-12 16:33:33 UTC
Since this issue was entered in Red Hat Bugzilla, the release flag has been
set to ? to ensure that it is properly evaluated for this release.

Comment 3 Bryan Kearney 2016-02-23 18:41:35 UTC
Created redmine issue http://projects.theforeman.org/issues/13859 from this bug

Comment 5 Bryan Kearney 2016-02-23 18:58:54 UTC
Connecting redmine issue http://projects.theforeman.org/issues/13726 from this bug

Comment 6 Bryan Kearney 2016-02-23 19:08:41 UTC
Upstream bug component is Capsule

Comment 7 Bryan Kearney 2016-02-23 19:08:44 UTC
Moving to POST since upstream bug http://projects.theforeman.org/issues/13726 has been closed
-------------
Shlomi Zadok
Applied in changeset commit:21f39c1258e00341186137ee941ea858b91a9db7.

Comment 13 Kedar Bidarkar 2016-04-12 16:13:44 UTC
VERIFIED with sat62-snap7.1 

WE can now delete a pending certificate signing request.

Comment 15 errata-xmlrpc 2016-07-27 09:14:19 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2016:1501


Note You need to log in before you can comment on or make changes to this bug.