Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be available on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 1201455 - ovs-vswitchd crashing with RHEL 7.1 kernels
Summary: ovs-vswitchd crashing with RHEL 7.1 kernels
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: openvswitch
Version: 5.0 (RHEL 7)
Hardware: Unspecified
OS: Unspecified
urgent
urgent
Target Milestone: async
: 5.0 (RHEL 7)
Assignee: Lon Hohberger
QA Contact: Eran Kuris
URL:
Whiteboard:
: 1205215 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-03-12 17:55 UTC by Marko Myllynen
Modified: 2019-07-11 08:46 UTC (History)
10 users (show)

Fixed In Version: openvswitch-2.1.2-2.el7_0.2
Doc Type: Bug Fix
Doc Text:
Prior to this update, an incompatibility issue in 'openvswitch-2.1.2-2.el7_0.1' with the Red Hat Enterprise Linux 7.1 kernel resulted in 'ovs-vswitchd' crashing. This update addresses this issue by backporting the fix from upstream. As a result, correct operation can be expected with 'openvswitch' on Red Hat Enterprise Linux 7.1 kernels.
Clone Of:
Environment:
Last Closed: 2015-04-09 15:43:58 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2015:0796 0 normal SHIPPED_LIVE openvswitch bug fix advisory 2015-04-09 19:43:56 UTC

Description Marko Myllynen 2015-03-12 17:55:26 UTC
Description of problem:
Installing latest RHEL OSP 5 on RHEL 7.0 works fine but when doing the same installation on RHEL 7.1, the ctrl/network node is unreachable, it turns out that ovs-vswitchd crashes on startup everytime with RHEL 7.1 kernel (-229). After rebooting the same OSP5/RHEL7.1 installation with RHEL 7.0 kernel (-123) there are no crashes and networking works as expected.

I have no more access to the lab where this was seen but I will attach a core dump from one of the crashes.

Version-Release number of selected component (if applicable):
kernel-3.10.0-229.el7.x86_64
openvswitch-2.1.2-2.el7_0.1.x86_64

Comment 4 Kevin Fenzi 2015-03-12 19:55:22 UTC
Might be the same as: https://bugzilla.redhat.com/show_bug.cgi?id=1200918 ?

Comment 5 Marko Myllynen 2015-03-12 21:17:46 UTC
(In reply to Kevin Fenzi from comment #4)
> Might be the same as: https://bugzilla.redhat.com/show_bug.cgi?id=1200918 ?

Yes, very likely so, but since the RDO fix was just to upgrade to 2.3 there doesn't seem to be any detailed analysis of this at least in the RHBZ.

Thanks.

Comment 6 Lee Yarwood 2015-03-24 21:34:34 UTC
*** Bug 1205215 has been marked as a duplicate of this bug. ***

Comment 7 Lon Hohberger 2015-03-25 17:13:48 UTC
There's a known issue on 7.1 kernels with openvswitch 2.1.2.  This is fixed in RHEL OSP 6, and is likely the same issue here.

The OSP 6 bug is bug 1185521

Comment 8 Lon Hohberger 2015-03-25 17:16:54 UTC
openvswitch-2.1.2-2.el7_0.2 will need to be added to RHEL OSP 5 to resolve this; the openvswitch-2.1.2-2.el7_0.1 package is the one which exhibits the issue.

Comment 10 Eran Kuris 2015-03-30 08:10:27 UTC
The bug verified on OSP-5  with OS- rhel 7.1 
there is no crashes , I tried to stop & start openvswitch service to verify the 
beehive of it.
I created network with few instances on 2 compute nodes , I got full connectivity include using floating IP .
The version that verified : 
--------------------------------------------------
# rpm -qa | grep openvswitch
openstack-neutron-openvswitch-2014.1.4-1.el7ost.noarch
openvswitch-2.1.2-2.el7_0.2.x86_64
[root@puma15]# rpm -qa | grep neutron
openstack-neutron-openvswitch-2014.1.4-1.el7ost.noarch
openstack-neutron-2014.1.4-1.el7ost.noarch
python-neutronclient-2.3.4-3.el7ost.noarch
openstack-neutron-ml2-2014.1.4-1.el7ost.noarch
python-neutron-2014.1.4-1.el7ost.noarch
[root@puma15]# rpm -qa | grep kernel
kernel-3.10.0-229.el7.x86_64
abrt-addon-kerneloops-2.1.11-19.el7.x86_64
kernel-tools-3.10.0-229.el7.x86_64
erlang-kernel-R16B-03.7min.1.el7ost.x86_64
kernel-tools-libs-3.10.0-229.el7.x86_64

Comment 12 errata-xmlrpc 2015-04-09 15:43:58 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2015-0796.html


Note You need to log in before you can comment on or make changes to this bug.