Bug 1201471 - Tracer plugin ignores tracer errors
Tracer plugin ignores tracer errors
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: dnf-plugins-extras (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Igor Gnatenko
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-03-12 14:31 EDT by Radek Holy
Modified: 2015-10-05 22:14 EDT (History)
3 users (show)

See Also:
Fixed In Version: dnf-plugins-extras-0.0.6-2.fc22
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-04-06 14:49:33 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Radek Holy 2015-03-12 14:31:18 EDT
Description of problem:
Tracer is currently a bit broken (see bug 1201464). If you run the tracer plugin it reports that there is no need to restart system even if you install something that requires the restart because the plugin does not notice that tracer have failed.


Version-Release number of selected component (if applicable):
python3-dnf-plugins-extras-tracer-0.0.5-4.fc23.noarch


How reproducible:
always


Steps to Reproduce:
1. install a broken tracer (e.g. install tracer <= 0.5.8-1.fc23 on a system where is rpm-python missing)
2. install something that should cause tracer to say that a restart is needed


Actual results:
You should restart:
  Nothing needs to be restarted


Expected results:
An error message saying that tracer have failed.
Comment 1 Radek Holy 2015-03-12 14:32:17 EDT
Or, since the traceback of tracer is visible, it shouldn't print "Nothing needs to be restarted" at least.
Comment 3 Radek Holy 2015-03-16 09:41:41 EDT
Thank you. Do you think that it could make sense to check for a non-zero https://docs.python.org/2.7/library/subprocess.html#subprocess.Popen.returncode too?
Comment 4 Fedora Update System 2015-03-31 14:19:26 EDT
dnf-plugins-extras-0.0.6-2.fc22 has been submitted as an update for Fedora 22.
https://admin.fedoraproject.org/updates/dnf-plugins-extras-0.0.6-2.fc22
Comment 5 Fedora Update System 2015-04-01 21:45:03 EDT
Package dnf-plugins-extras-0.0.6-2.fc22:
* should fix your issue,
* was pushed to the Fedora 22 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing dnf-plugins-extras-0.0.6-2.fc22'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2015-5354/dnf-plugins-extras-0.0.6-2.fc22
then log in and leave karma (feedback).
Comment 6 Fedora Update System 2015-04-03 07:39:41 EDT
dnf-plugins-extras-0.0.6-2.fc22,yum-utils-1.1.31-505.fc22,yum-3.4.3-505.fc22,hawkey-0.5.4-1.fc22,dnf-0.6.5-1.fc22 has been submitted as an update for Fedora 22.
https://admin.fedoraproject.org/updates/dnf-plugins-extras-0.0.6-2.fc22,yum-utils-1.1.31-505.fc22,yum-3.4.3-505.fc22,hawkey-0.5.4-1.fc22,dnf-0.6.5-1.fc22
Comment 7 Fedora Update System 2015-04-06 14:49:33 EDT
dnf-plugins-extras-0.0.6-2.fc22, yum-3.4.3-505.fc22, dnf-0.6.5-1.fc22, yum-utils-1.1.31-505.fc22, hawkey-0.5.4-1.fc22 has been pushed to the Fedora 22 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.