Bug 1201481 - instack-undercloud: Upon completing overcloud deployment, sourcing /etc/tripleo/overcloudrc returns errors.
Summary: instack-undercloud: Upon completing overcloud deployment, sourcing /etc/tripl...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: instack-undercloud
Version: unspecified
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ga
: Director
Assignee: James Slagle
QA Contact: Alexander Chuzhoy
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-03-12 19:00 UTC by Alexander Chuzhoy
Modified: 2015-08-05 13:50 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-08-05 13:50:53 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2015:1549 normal SHIPPED_LIVE Red Hat Enterprise Linux OpenStack Platform director Release 2015-08-05 17:49:10 UTC

Description Alexander Chuzhoy 2015-03-12 19:00:31 UTC
instack-undercloud: Upon completing overcloud deployment, sourcing /etc/tripleo/overcloudrc returns errors.

Environment:
instack-undercloud-2.0.0-dev1430.g40fab93.el7.centos.noarch
instack-0.0.6.4-g57c723a.el7.centos.noarch
openstack-tripleo-image-elements-0.9.2.37-g3e3c022.el7.centos.noarch
openstack-tripleo-0.0.6-dev1669.g51331a7.el7.centos.noarch
openstack-tripleo-heat-templates-0.8.2.36-g8772095.el7.centos.noarch


Steps to reproduce:
1. Install the overcloud.
2. Try to source the /etc/tripleo/overcloudrc file to be able to run commands on the overcloud.

Result:

[stack@localhost ~]$ . /etc/tripleo/overcloudrc         
[2015/03/12 02:30:46 PM] [WARNING] DEPRECATED: falling back to /var/run/os-collect-config/os_config_files.json
[2015/03/12 02:30:46 PM] [ERROR] key overcloud.password does not exist in []                                  
[2015/03/12 02:30:46 PM] [WARNING] DEPRECATED: falling back to /var/run/os-collect-config/os_config_files.json
[2015/03/12 02:30:46 PM] [ERROR] key overcloud.endpoint does not exist in []        


Expected result:
The file should be sourced successfully.


Workaround:
Prior to sourcing the file, run:
export NODES_JSON=${NODES_JSON:-"instackenv.json"}
export TE_DATAFILE=$NODES_JSON

And only then:
. /etc/tripleo/overcloudrc

Comment 4 Ben Nemec 2015-03-12 20:26:41 UTC
Will be addressed by https://review.gerrithub.io/#/c/218589

Comment 7 Alexander Chuzhoy 2015-06-19 15:54:38 UTC
Verified:


Environment:
instack-undercloud-2.1.2-1.el7ost.noarch


The right way now is:
source overcloudrc  (in the home directory of the stack user)
openstack overcloud postconfig "[Overcloud IP]"

And it works with no issues.

Comment 9 errata-xmlrpc 2015-08-05 13:50:53 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2015:1549


Note You need to log in before you can comment on or make changes to this bug.