Bug 1201505 - Floating IPs can not be assigned in instack installed overcloud
Summary: Floating IPs can not be assigned in instack installed overcloud
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-tripleo-heat-templates
Version: 7.0 (Kilo)
Hardware: Unspecified
OS: Unspecified
urgent
high
Target Milestone: ga
: Director
Assignee: Tomas Sedovic
QA Contact: Leonid Natapov
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-03-12 20:24 UTC by John Trowbridge
Modified: 2015-08-05 13:50 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-08-05 13:50:57 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2015:1549 normal SHIPPED_LIVE Red Hat Enterprise Linux OpenStack Platform director Release 2015-08-05 17:49:10 UTC

Description John Trowbridge 2015-03-12 20:24:36 UTC
Description of problem:

The overcloud created by following the instack docs[1] does not pass instack-test-overcloud. It is failing when trying to assign a floating IP to the instance, with the following error:

"Agent with agent_type=L3 agent and host=ov-m2j5ki7vxp-0-xjo22likiwsd-novacompute-ctg26kpdcpfm.novalocal could not be found"

Environment:
instack-0.0.6.4-g57c723a.el7.centos.noarch
instack-undercloud-2.0.0-dev1431.gd72134b.el7.centos.noarch
openstack-tripleo-0.0.6-dev1669.g51331a7.el7.centos.noarch
openstack-tripleo-image-elements-0.9.2.37-g3e3c022.el7.centos.noarch
openstack-tripleo-heat-templates-0.8.2.36-g8772095.el7.centos.noarch


Steps to Reproduce:
1. Follow the instack-undercloud docs to get an environment
2. run `instack-test-overcloud`

Actual results:
+ PORT=' 8261dbc5-f011-402e-b939-eeadbb9e6f4b '
++ neutron floatingip-create ext-net --port-id 8261dbc5-f011-402e-b939-eeadbb9e6f4b
++ awk '$2=="floating_ip_address" {print $4}'
Agent with agent_type=L3 agent and host=ov-m2j5ki7vxp-0-xjo22likiwsd-novacompute-ctg26kpdcpfm.novalocal could not be found
+ FLOATINGIP=


Expected results:
+ PORT=' 8261dbc5-f011-402e-b939-eeadbb9e6f4b '
++ neutron floatingip-create ext-net --port-id 8261dbc5-f011-402e-b939-eeadbb9e6f4b
++ awk '$2=="floating_ip_address" {print $4}'
+ FLOATINGIP=10.0.0.46


[1] https://repos.fedorapeople.org/repos/openstack-m/instack-undercloud/html/index.html

Comment 3 John Trowbridge 2015-03-13 19:13:45 UTC
I am no longer seeing this issue when deploying a completely new setup. (re-provision the host and follow the instack-undercloud docs)

Oddly, all packages listed in the description are the same version as my current working setup.

Sasha, do you still see this if you start from a new host?

Comment 4 Alexander Chuzhoy 2015-03-16 15:56:37 UTC
No, 

I see among other lines:
+ FLOATINGIP=172.17.0.46

Comment 8 Leonid Natapov 2015-06-29 07:46:00 UTC
The issue doesnt' reproduce

Comment 10 errata-xmlrpc 2015-08-05 13:50:57 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2015:1549


Note You need to log in before you can comment on or make changes to this bug.