Bug 120161 - IllegalAccessError at Tomcat startup
IllegalAccessError at Tomcat startup
Status: CLOSED DEFERRED
Product: Fedora
Classification: Fedora
Component: commons-logging (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Gary Benson
:
Depends On:
Blocks: FC2Target
  Show dependency treegraph
 
Reported: 2004-04-06 10:55 EDT by Gary Benson
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-04-16 11:32:12 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Gary Benson 2004-04-06 10:55:54 EDT
An IllegalAccessError is thrown from within commons-logging during
Tomcat startup.  It happens because an anonymous inner class of
o.a.c.l.impl.LogFactoryImpl attempts to access a protected method of
o.a.c.l.impl.LogFactoryImpl's parent class.  I'm not sure whether
libgcj is doing the right thing here: jcf-dump shows the inner class's
superclass as java.lang.Object so by rights it shouldn't be able to
access the protected method that it is trying to.  However, I don't
know whether inner classes have special rights (I'm guessing not) or
whether they should be compiled with their containing class as their
superclass. Need to find a Java god to ask about this one...
Comment 1 Gary Benson 2004-04-16 11:32:12 EDT
This seems to be a bytecode generation issue, since it vanished when I
fixed the thing that was stopping us from using the shared objects.

Note You need to log in before you can comment on or make changes to this bug.