Bug 1201624 - Spurious failure of tests/bugs/quota/bug-1038598.t
Summary: Spurious failure of tests/bugs/quota/bug-1038598.t
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: GlusterFS
Classification: Community
Component: replicate
Version: 3.6.2
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Pranith Kumar K
QA Contact:
URL:
Whiteboard:
Depends On: 1199431
Blocks: glusterfs-3.6.3
TreeView+ depends on / blocked
 
Reported: 2015-03-13 06:22 UTC by Pranith Kumar K
Modified: 2016-02-04 15:20 UTC (History)
2 users (show)

Fixed In Version: glusterfs-v3.6.3
Doc Type: Bug Fix
Doc Text:
Clone Of: 1199431
Environment:
Last Closed: 2016-02-04 15:20:08 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)

Description Pranith Kumar K 2015-03-13 06:22:31 UTC
+++ This bug was initially created as a clone of Bug #1199431 +++

Description of problem:
    
    Afr needs to query QUOTA_SIZE_KEY from all the subvolumes and return the
    value which is maximum of the readable bricks.


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

--- Additional comment from Anand Avati on 2015-03-06 05:10:30 EST ---

REVIEW: http://review.gluster.org/9820 (cluster/afr: Handle getxattr of quota-size key) posted (#1) for review on master by Pranith Kumar Karampuri (pkarampu@redhat.com)

--- Additional comment from Anand Avati on 2015-03-09 05:40:57 EDT ---

COMMIT: http://review.gluster.org/9820 committed in master by Pranith Kumar Karampuri (pkarampu@redhat.com) 
------
commit 5ab4a17a63acf7215e9dc98276e7547ae527a5a7
Author: Pranith Kumar K <pkarampu@redhat.com>
Date:   Fri Mar 6 14:36:52 2015 +0530

    cluster/afr: Handle getxattr of quota-size key
    
    Afr needs to query QUOTA_SIZE_KEY from all the subvolumes and return the
    value which is maximum of the readable bricks.
    
    Change-Id: Ibb9064c8652aea0d984796e7a06f8adca72aa971
    BUG: 1199431
    Signed-off-by: Pranith Kumar K <pkarampu@redhat.com>
    Reviewed-on: http://review.gluster.org/9820
    Reviewed-by: Anuradha Talur <atalur@redhat.com>
    Tested-by: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: Krutika Dhananjay <kdhananj@redhat.com>

Comment 1 Anand Avati 2015-03-13 06:23:55 UTC
REVIEW: http://review.gluster.org/9873 (cluster/afr: Handle getxattr of quota-size key) posted (#1) for review on release-3.6 by Pranith Kumar Karampuri (pkarampu@redhat.com)

Comment 2 Anand Avati 2015-03-14 10:13:49 UTC
COMMIT: http://review.gluster.org/9873 committed in release-3.6 by Raghavendra Bhat (raghavendra@redhat.com) 
------
commit fe416a671dd6b6ce8cb4d94e64154491a148993c
Author: Pranith Kumar K <pkarampu@redhat.com>
Date:   Fri Mar 6 14:36:52 2015 +0530

    cluster/afr: Handle getxattr of quota-size key
    
            Backport of http://review.gluster.org/9820
    
    Afr needs to query QUOTA_SIZE_KEY from all the subvolumes and return the
    value which is maximum of the readable bricks.
    
    BUG: 1201624
    Change-Id: I41725a7323020c1480c38560dc5ae2c2e82d6d47
    Signed-off-by: Pranith Kumar K <pkarampu@redhat.com>
    Reviewed-on: http://review.gluster.org/9873
    Reviewed-by: Krutika Dhananjay <kdhananj@redhat.com>
    Tested-by: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: Raghavendra Bhat <raghavendra@redhat.com>

Comment 3 Kaushal 2016-02-04 15:20:08 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-v3.6.3, please open a new bug report.

glusterfs-v3.6.3 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] https://www.gluster.org/pipermail/gluster-users/2015-April/021669.html
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user


Note You need to log in before you can comment on or make changes to this bug.