Bug 1201679 - display is too small when open a vnc guest
Summary: display is too small when open a vnc guest
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: virt-viewer
Version: 6.7
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: rc
: ---
Assignee: Virt Viewer Maint
QA Contact: Virtualization Bugs
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-03-13 09:12 UTC by CongDong
Modified: 2015-07-22 06:32 UTC (History)
8 users (show)

Fixed In Version: virt-viewer-2.0-4.el6
Doc Type: Bug Fix
Doc Text:
No doc needed
Clone Of:
Environment:
Last Closed: 2015-07-22 06:32:19 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2015:1322 0 normal SHIPPED_LIVE virt-viewer and spice-gtk bug fix and enhancement update 2015-07-20 17:53:14 UTC

Description CongDong 2015-03-13 09:12:34 UTC
Description of problem:
As subject

Version-Release number of selected component (if applicable):
virt-viewer-2.0-3.el6.x86_64
gtk-vnc-0.3.10-3.el6.x86_64

How reproducible:
100

Steps to Reproduce:
1. prepare a vnc guest:
    <graphics type='vnc' port='5901' autoport='yes' listen='127.0.0.1'>
      <listen type='address' address='127.0.0.1'/>
    </graphics>
    <video>
      <model type='cirrus' vram='9216' heads='1'/>
      <alias name='video0'/>
      <address type='pci' domain='0x0000' bus='0x00' slot='0x02' function='0x0'/>
    </video>
2. #virt-viewer $vm

Actual results:
After 2, virt-viewer can open guest successfully, but always get a small size:
(virt-viewer:21143): virt-viewer-DEBUG: Preparing main window resize
(virt-viewer:21143): virt-viewer-DEBUG: Decided todo 1024x768 (desktop is 1024x768, fullscreen is 1680x1050
(virt-viewer:21143): virt-viewer-DEBUG: Allocated 1024x768
(virt-viewer:21143): virt-viewer-DEBUG: Child allocate 1024x768
(virt-viewer:21143): virt-viewer-DEBUG: Display size request 50x50 (desktop 1024x768)
(virt-viewer:21143): virt-viewer-DEBUG: Allocated 203x50
(virt-viewer:21143): virt-viewer-DEBUG: Child allocate 67x50
(virt-viewer:21143): virt-viewer-DEBUG: Window closed

Expected results:
The window size should be right

Additional info:

Comment 5 Fabiano Fidêncio 2015-03-18 09:57:27 UTC
Hmmm. It is not 100% reproducible, but it happens from time to time.

Comment 6 Fabiano Fidêncio 2015-03-24 00:56:17 UTC
(In reply to Fabiano Fidêncio from comment #5)
> Hmmm. It is not 100% reproducible, but it happens from time to time.

Interesting. I've done all tests on a RHEL-6.7 machine and the commit that introduces the issue is the same one that solves https://bugzilla.redhat.com/show_bug.cgi?id=1170071 on RHEL-7.2.

I also can affirm that we don't have the RHEL-7.2 zoom-level issue on RHEL-6.7, even with the patch reverted.

Cong Dong, please, can you test with this scratch build (both the tiny window and the zoom level)?
https://brewweb.devel.redhat.com/taskinfo?taskID=8893466

If everything works well, I'm going to revert https://git.fedorahosted.org/cgit/virt-viewer.git/commit/?id=68148e1bd1a47ff370c78e2569a57ae0f3d8a400 downstream.

Comment 7 CongDong 2015-03-24 02:20:27 UTC
I test with the scratch build:

1. prepare a vnc guest:
    <graphics type='vnc' port='5901' autoport='yes' listen='127.0.0.1'>
      <listen type='address' address='127.0.0.1'/>
    </graphics>
    <video>
      <model type='cirrus' vram='9216' heads='1'/>
      <alias name='video0'/>
      <address type='pci' domain='0x0000' bus='0x00' slot='0x02' function='0x0'/>
    </video>
2. # virt-viewer $vm (20 times)
3. # virt-viewer $vm --zoom=10

Result:
Step2, no tiny window comes out
Step3, the display is zoomed as expected value.

Comment 8 Christophe Fergeau 2015-03-24 09:42:09 UTC
(In reply to Fabiano Fidêncio from comment #6)
> (In reply to Fabiano Fidêncio from comment #5)
> > Hmmm. It is not 100% reproducible, but it happens from time to time.
> 
> Interesting. I've done all tests on a RHEL-6.7 machine and the commit that
> introduces the issue is the same one that solves
> https://bugzilla.redhat.com/show_bug.cgi?id=1170071 on RHEL-7.2.
> 
[..]
> 
> If everything works well, I'm going to revert
> https://git.fedorahosted.org/cgit/virt-viewer.git/commit/
> ?id=68148e1bd1a47ff370c78e2569a57ae0f3d8a400 downstream.

Is this 'small screen' issue showing up with gtk2 builds of latest upstream gtk-vnc/virt-viewer?

Comment 9 Fabiano Fidêncio 2015-03-24 11:47:29 UTC
(In reply to Christophe Fergeau from comment #8)
> (In reply to Fabiano Fidêncio from comment #6)
> > (In reply to Fabiano Fidêncio from comment #5)
> > > Hmmm. It is not 100% reproducible, but it happens from time to time.
> > 
> > Interesting. I've done all tests on a RHEL-6.7 machine and the commit that
> > introduces the issue is the same one that solves
> > https://bugzilla.redhat.com/show_bug.cgi?id=1170071 on RHEL-7.2.
> > 
> [..]
> > 
> > If everything works well, I'm going to revert
> > https://git.fedorahosted.org/cgit/virt-viewer.git/commit/
> > ?id=68148e1bd1a47ff370c78e2569a57ae0f3d8a400 downstream.
> 
> Is this 'small screen' issue showing up with gtk2 builds of latest upstream
> gtk-vnc/virt-viewer?

Nops. It doesn't happen with my f22 system using gtk-vnc and latest virt-viewer (using gtk2). That's the reason I'd like to have the patch as downstream only.

Comment 10 Christophe Fergeau 2015-03-24 13:15:15 UTC
Ok, let's go for this patch then

Comment 12 zhoujunqin 2015-03-25 10:53:49 UTC
I can reproduce this issue with:
virt-viewer-2.0-3.el6.x86_64

Then try to verify with new build:
virt-viewer-2.0-4.el6.x86_64

step to verify:
1. prepare a vnc guest:
    <graphics type='vnc' port='5901' autoport='yes' listen='127.0.0.1'>
      <listen type='address' address='127.0.0.1'/>
    </graphics>
    <video>
      <model type='cirrus' vram='9216' heads='1'/>
      <alias name='video0'/>
      <address type='pci' domain='0x0000' bus='0x00' slot='0x02' function='0x0'/>
    </video>

2. #virt-viewer $vm 

Try step 2 several times, the guest window shows normal, so move this bug from ON_QA to VERIFIED.

Comment 14 errata-xmlrpc 2015-07-22 06:32:19 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2015-1322.html


Note You need to log in before you can comment on or make changes to this bug.