Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be available on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 1201707 - CNFE exceptions when using infinispan-remote in FSW
Summary: CNFE exceptions when using infinispan-remote in FSW
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: JBoss Data Grid 6
Classification: JBoss
Component: Infinispan
Version: 6.4.0
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: ---
: ---
Assignee: Tristan Tarrant
QA Contact: Martin Gencur
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-03-13 10:11 UTC by Martin Gencur
Modified: 2015-04-01 10:46 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-04-01 10:46:53 UTC
Type: Bug


Attachments (Terms of Use)

Description Martin Gencur 2015-03-13 10:11:32 UTC
There are several CNFE exceptions thrown when infinispan-remote uber jar is used in containers such as FSW or EAP. Below is a list of the exceptions:

1) java.lang.ClassNotFoundException: com.sun.jdi.request.EventRequest

2) java.lang.ClassNotFoundException: org.jboss.logmanager.Level

3) java.lang.ClassNotFoundException: org.jboss.logmanager.Logger$AttachmentKey

4) Caused by: java.lang.ClassNotFoundException: infinispan.org.apache.log4j.Priority


Even with these exceptions, my tests for camel-jbossdatagrid component passed. But I'm not sure if there are not any hidden problems.

Comment 2 Martin Gencur 2015-04-01 10:46:53 UTC
We're testing with EAP now where this problem does not occur. Closing.


Note You need to log in before you can comment on or make changes to this bug.