Bug 1201724 - Handle the review comments in bit-rot patches
Summary: Handle the review comments in bit-rot patches
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: GlusterFS
Classification: Community
Component: unclassified
Version: mainline
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: ---
Assignee: Raghavendra Bhat
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-03-13 10:49 UTC by Raghavendra Bhat
Modified: 2015-05-15 17:09 UTC (History)
6 users (show)

Fixed In Version: glusterfs-3.7.0
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-05-15 17:09:20 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)

Description Raghavendra Bhat 2015-03-13 10:49:44 UTC
Description of problem:

Handle all the non critical review comments from the below patches submitted for bit-rot detection.

http://review.gluster.org/#/c/9710/
http://review.gluster.org/#/c/9707/
http://review.gluster.org/#/c/9706/
http://review.gluster.org/#/c/9775/
http://review.gluster.org/#/c/9709/

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Comment 1 Anand Avati 2015-04-06 14:18:31 UTC
REVIEW: http://review.gluster.org/10140 (tests/bitrot-stub: Object versioning test(s)) posted (#1) for review on master by Venky Shankar (vshankar@redhat.com)

Comment 2 Anand Avati 2015-04-07 08:39:24 UTC
REVIEW: http://review.gluster.org/10140 (tests/bitrot-stub: Object versioning test(s)) posted (#2) for review on master by Venky Shankar (vshankar@redhat.com)

Comment 3 Anand Avati 2015-04-07 10:38:39 UTC
REVIEW: http://review.gluster.org/10140 (tests/bitrot-stub: Object versioning test(s)) posted (#3) for review on master by Venky Shankar (vshankar@redhat.com)

Comment 4 Anand Avati 2015-04-08 06:49:28 UTC
COMMIT: http://review.gluster.org/10140 committed in master by Vijay Bellur (vbellur@redhat.com) 
------
commit 7fb55dbdabf73f9169b0f3021a42fa120d64b373
Author: Venky Shankar <vshankar@redhat.com>
Date:   Mon Apr 6 18:14:53 2015 +0530

    tests/bitrot-stub: Object versioning test(s)
    
    This patch introduces basic object versioning test(s) which
    is required for bitrot detection to work correctly. Basic
    test(s) such as opening a file in read-only mode, single
    open, multiple open()s are covered on FUSE mount _only_ as
    stub does not support anonymous fds yet. For this reason,
    the test case disables open-behind.
    
    Actual verification is implemented as a C source which
    makes use of the same on-disk data structures as used by
    the stub code. The data structures are moved to separate
    header file which is included by the test script. Such
    modularization helps in future enhancements to keep the
    version "data type" opaque and provide handful of APIs
    version checking (equal/greater/etc..).
    
    [
      This is just a start and should grow over time as stub
      is enhanced and codebase matures.
    ]
    
    Change-Id: Ibee20e65a15b56bbdd59fd2703f9305b115aec7a
    BUG: 1201724
    Signed-off-by: Venky Shankar <vshankar@redhat.com>
    Reviewed-on: http://review.gluster.org/10140
    Reviewed-by: Raghavendra Bhat <raghavendra@redhat.com>
    Tested-by: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: Vijay Bellur <vbellur@redhat.com>

Comment 5 Niels de Vos 2015-05-15 17:09:20 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.7.0, please open a new bug report.

glusterfs-3.7.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://thread.gmane.org/gmane.comp.file-systems.gluster.devel/10939
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user


Note You need to log in before you can comment on or make changes to this bug.