Bug 1201726 - org list doesn't show the updated description
Summary: org list doesn't show the updated description
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Satellite
Classification: Red Hat
Component: API
Version: 6.1.0
Hardware: Unspecified
OS: Unspecified
unspecified
medium vote
Target Milestone: Unspecified
Assignee: Brad Buckingham
QA Contact: Sachin Ghai
URL: http://projects.theforeman.org/issues...
Whiteboard: Verified in Upstream
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-03-13 11:04 UTC by Sachin Ghai
Modified: 2019-09-26 17:38 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-07-27 08:49:20 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Foreman Issue Tracker 11649 None None None 2016-04-22 16:17:16 UTC
Red Hat Product Errata RHBA-2016:1500 normal SHIPPED_LIVE Red Hat Satellite 6.2 Base Libraries 2016-07-27 12:24:38 UTC

Description Sachin Ghai 2015-03-13 11:04:57 UTC
Description of problem:
when we update org's description, its reflected under org info but org list doesn't show the same.

Update org's description:
==========================
# hammer --username admin --password changeme organization update  --id 3 --description='nice_description'
/usr/lib/ruby/gems/1.8/gems/hammer_cli-0.1.4/lib/hammer_cli/./apipie/../abstract.rb:68: warning: already initialized constant DEFAULT_LABEL_INDENT
Organization updated

check info:
================
[root@dhcp201-163 boot]# hammer --username admin --password changeme organization info --id 3
/usr/lib/ruby/gems/1.8/gems/hammer_cli-0.1.4/lib/hammer_cli/./apipie/../abstract.rb:68: warning: already initialized constant DEFAULT_LABEL_INDENT
Id:                     3
Name:                   testorg
Users:                  

Smart proxies:          
    dhcp201-163.englab.pnq.redhat.com
Subnets:                

Compute resources:      

Installation media:     

Templates:              
    Boot disk iPXE - generic host (Bootdisk)
    Boot disk iPXE - host (Bootdisk)
    freeipa_register ()
    Katello Kickstart Default (provision)
    Katello Kickstart Default Finish (finish)
    Katello Kickstart Default User Data (user_data)
    Kickstart default iPXE (iPXE)
    Kickstart default PXELinux (PXELinux)
    puppet.conf ()
    PXELinux global default (PXELinux)
    subscription_manager_registration ()
Domains:                

Environments:           

Hostgroups:             

Parameters:             

Created at:             2015/03/13 05:14:21
Updated at:             2015/03/13 05:28:07
Label:                  testorg
Description:            nice_description
Red Hat Repository URL: https://cdn.redhat.com



Above info correctly displayed the org's description but the list as below

# hammer --username admin --password changeme organization list
/usr/lib/ruby/gems/1.8/gems/hammer_cli-0.1.4/lib/hammer_cli/./apipie/../abstract.rb:68: warning: already initialized constant DEFAULT_LABEL_INDENT
---|----------------------|----------------------|------------
ID | NAME                 | LABEL                | DESCRIPTION
---|----------------------|----------------------|------------
1  | Default Organization | Default_Organization |            
3  | testorg              | testorg              |            
---|----------------------|----------------------|------------


Version-Release number of selected component (if applicable):

sat6.1 beta snap6 compose2
Satellite-6.1.0-RHEL-6-20150311.1/

How reproducible:
always

Steps to Reproduce:
1.
2.
3.

Actual results:
# hammer --username admin --password changeme organization list
/usr/lib/ruby/gems/1.8/gems/hammer_cli-0.1.4/lib/hammer_cli/./apipie/../abstract.rb:68: warning: already initialized constant DEFAULT_LABEL_INDENT
---|----------------------|----------------------|------------
ID | NAME                 | LABEL                | DESCRIPTION
---|----------------------|----------------------|------------
1  | Default Organization | Default_Organization |            
3  | testorg              | testorg              |            
---|----------------------|----------------------|------------

Expected results:
 org list cmd should also show the updated description

Additional info:

Comment 2 Brad Buckingham 2015-09-01 21:08:05 UTC
Created redmine issue http://projects.theforeman.org/issues/11649 from this bug

Comment 3 Brad Buckingham 2015-09-01 21:17:20 UTC
Foreman PR: https://github.com/theforeman/foreman/pull/2662

Comment 4 Bryan Kearney 2015-09-01 22:03:29 UTC
Upstream bug component is Provisioning

Comment 5 Bryan Kearney 2015-09-03 08:03:20 UTC
Upstream bug component is API

Comment 6 Bryan Kearney 2015-09-03 08:03:21 UTC
Moving to POST since upstream bug http://projects.theforeman.org/issues/11649 has been closed
-------------
Brad Buckingham
Applied in changeset commit:e2452a0b465a8ca3567a79d52f92ca7e988422df.

Comment 7 Sachin Ghai 2015-09-08 10:02:42 UTC
Verified with upstream:

foreman-release-1.10.0-0.develop.201509041547git84f7fc6.el6.noarch
foreman-1.10.0-0.develop.201509041547git84f7fc6.el6.noarch
katello-2.4.0-6.nightly.el6.noarch
katello-installer-base-2.4.0-1.nightly.201509040043gitb37b92b.el6.noarch
katello-installer-2.4.0-1.nightly.201509040043gitb37b92b.el6.noarch
tfm-rubygem-hammer_cli_foreman-0.3.0-2.201508261233git7334971.el6.noarch
tfm-rubygem-hammer_cli-0.3.0-2.201508280738git8a70aa0.el6.noarch
tfm-rubygem-hammer_cli_katello-0.0.17-4.el6.noarch

hammer org list now shows the updated description:

[root@cloud-qe-3 hammerify]# hammer --username admin --password changeme organization create --name "test_org"
Organization created

 hammer --username admin --password changeme organization list
---|----------------------|----------------------|------------
ID | NAME                 | LABEL                | DESCRIPTION
---|----------------------|----------------------|------------
1  | Default Organization | Default_Organization |            
3  | test_org             | test_org             |            
---|----------------------|----------------------|------------

[root@cloud-qe-3 hammerify]# hammer --username admin --password changeme organization update  --id 3 --description='nice_description'
Organization updated
[root@cloud-qe-3 hammerify]# hammer --username admin --password changeme organization list
---|----------------------|----------------------|-----------------
ID | NAME                 | LABEL                | DESCRIPTION     
---|----------------------|----------------------|-----------------
1  | Default Organization | Default_Organization |                 
3  | test_org             | test_org             | nice_description
---|----------------------|----------------------|-----------------

Comment 10 errata-xmlrpc 2016-07-27 08:49:20 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2016:1500


Note You need to log in before you can comment on or make changes to this bug.