Bug 1201740 - [New] - Adding RHS 3.0.4 node to RHSC overrides the values of vm.dirty_ratio and dirty_background_ratio to 5 and 2 from RHEL defaults.
Summary: [New] - Adding RHS 3.0.4 node to RHSC overrides the values of vm.dirty_ratio ...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: rhsc
Version: rhgs-3.0
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: ---
: RHGS 3.1.0
Assignee: Darshan
QA Contact: RamaKasturi
URL:
Whiteboard:
Depends On:
Blocks: 1191838 1202842 1209418
TreeView+ depends on / blocked
 
Reported: 2015-03-13 11:53 UTC by RamaKasturi
Modified: 2015-07-29 05:27 UTC (History)
10 users (show)

Fixed In Version: rhsc-3.1.0-0.57.master.el6.noarch.rpm
Doc Type: Bug Fix
Doc Text:
Previously, the Red Hat Storage Console override the Red Hat Enterprise Linux values for the vm.dirty_ratio and dirty_background_ratio to 5 and 2 respectively. This occurred when activating the tuned profile 'rhs-virtualization' while adding Red Hat Storage nodes to the Red Hat Storage Console. This had decreased the performance of the Red Hat Storage Trusted Storage Pool. With this fix, users are given an option to choose the tuned profile during cluster creation. Based on his use case, the user he can choose the profile.
Clone Of:
: 1209418 (view as bug list)
Environment:
Last Closed: 2015-07-29 05:27:26 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2015:1494 0 normal SHIPPED_LIVE Red Hat Gluster Storage Console 3.1 Enhancement and bug fixes 2015-07-29 09:24:02 UTC
oVirt gerrit 39599 0 None None None Never
oVirt gerrit 39769 0 None None None Never

Description RamaKasturi 2015-03-13 11:53:39 UTC
Description of problem:
As of now rhsc host-deploy overrides the existing tuned profile on RHS nodes and sets it to rhs-virtualization and because of this the values of vm.dirty_ratio and dirty_background_ratio changes to 5 and 2 and does not remain the RHEL default values 20 and 10.

UI should provide an option where user is able to select the profile which he wants to set on the node.

Version-Release number of selected component (if applicable):
rhsc-3.0.4-1.25.el6rhs.noarch

How reproducible:
Always.

Steps to Reproduce:
1. Install RHS 3.0.4 ISO.
2. Now add the node to rhsc.
3.

Actual results:
host-deploy overrides the existing profile to rhs-virtualization and because of this vm.dirty_ratio and dirty_background_ratio changes to 5 and 2 and there might be some performance impact because of this.

Expected results:
Either UI should provide an option where user is able to select the profile which he wants to set on the node.

Additional info:

Comment 3 Pavithra 2015-03-17 07:21:09 UTC
Ramesh,

Can you please review the edited doc text and clear the needinfo flag?

Comment 4 Ramesh N 2015-03-17 09:00:25 UTC
Doc text looks good to me

Comment 5 Darshan 2015-04-02 10:26:47 UTC
Currently by default rhs-virtualization profile is set for RHS nodes. One approach is to change this default to rhs-high-throughput profile, which is recommended for RHS nodes. The other option is to ask user to choose the profile during cluster creation in RHSC, and set the profile accordingly.

Comment 6 Darshan 2015-04-07 10:33:16 UTC
As discussed in triage meeting, the solution for this issue; User would be provided an option to choose the tuned profile during cluster creation.

Comment 8 RamaKasturi 2015-05-22 07:17:42 UTC
Please provide the fixed in version.

Comment 9 RamaKasturi 2015-05-28 09:23:06 UTC
Created a cluster with gluster Tuned Profile : rhs-high-throughput and added a RHS 3.0.4 ISO to the cluster.

I see the following as the profile in the RHS node which is added to RHSC and vm_dirty_background and vm_dirt)_

[root@dhcp37-153 ~]# tuned-adm list
Available profiles:
- server-powersave
- spindown-disk
- desktop-powersave
- virtual-guest
- virtual-host
- rhs-virtualization
- rhs-high-throughput
- enterprise-storage
- laptop-ac-powersave
- laptop-battery-powersave
- default
- throughput-performance
- latency-performance
Current active profile: rhs-high-throughput

[root@dhcp37-153 ~]# sysctl -a | grep "dirty"
vm.dirty_background_ratio = 10
vm.dirty_background_bytes = 0
vm.dirty_ratio = 20
vm.dirty_bytes = 0
vm.dirty_writeback_centisecs = 500
vm.dirty_expire_centisecs = 3000

When the cluster is created with rhs-virtualization profile and adds a node to this cluster the following values are seen.

[root@dhcp37-153 ~]# tuned-adm list
Available profiles:
- server-powersave
- spindown-disk
- desktop-powersave
- virtual-guest
- virtual-host
- rhs-virtualization
- rhs-high-throughput
- enterprise-storage
- laptop-ac-powersave
- laptop-battery-powersave
- default
- throughput-performance
- latency-performance
Current active profile: rhs-virtualization
[root@dhcp37-153 ~]# sysctl -a | grep "dirty"
vm.dirty_background_ratio = 1
vm.dirty_background_bytes = 0
vm.dirty_ratio = 20
vm.dirty_bytes = 0
vm.dirty_writeback_centisecs = 500
vm.dirty_expire_centisecs = 3000

setting the profile as rhs-virtualization changes the vm.dbr to 1 and leaves the vm.dr to what ever it was before.

Comment 10 RamaKasturi 2015-05-28 09:44:21 UTC
Verified and works fine with rhsc-3.1.0-0.57.master.el6.noarch

Comment 11 Divya 2015-07-26 10:26:15 UTC
Darshan,

Please review and sign-off the edited doc text.

Comment 12 Darshan 2015-07-27 05:22:22 UTC
(In reply to Divya from comment #11)
> Darshan,
> 
> Please review and sign-off the edited doc text.

Looks Good.

Comment 14 errata-xmlrpc 2015-07-29 05:27:26 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHEA-2015-1494.html


Note You need to log in before you can comment on or make changes to this bug.