Bug 1201798 (CVE-2015-2155) - CVE-2015-2155 tcpdump: force printer vulnerability
Summary: CVE-2015-2155 tcpdump: force printer vulnerability
Status: CLOSED WONTFIX
Alias: CVE-2015-2155
Product: Security Response
Classification: Other
Component: vulnerability
Version: unspecified
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Red Hat Product Security
QA Contact:
URL:
Whiteboard: impact=moderate,public=20150309,repor...
Keywords: Security
Depends On: 1201799
Blocks: 1201800 1415638
TreeView+ depends on / blocked
 
Reported: 2015-03-13 14:16 UTC by Martin Prpič
Modified: 2019-06-13 08:18 UTC (History)
4 users (show)

(edit)
Clone Of:
(edit)
Last Closed: 2016-06-01 19:23:04 UTC


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHSA-2017:1871 normal SHIPPED_LIVE Moderate: tcpdump security, bug fix, and enhancement update 2017-08-01 16:00:24 UTC

Description Martin Prpič 2015-03-13 14:16:25 UTC
A flaw was found in tcpdump's force printer. A remote attacker could use this flaw to cause tcpdump to crash, resulting in a denial of service, or possibly execute arbitrary code.

Upstream patch:

http://www.ca.tcpdump.org/cve/0002-test-case-files-for-CVE-2015-2153-2154-2155.patch

Comment 1 Martin Prpič 2015-03-13 14:17:37 UTC
Created tcpdump tracking bugs for this issue:

Affects: fedora-all [bug 1201799]

Comment 4 errata-xmlrpc 2017-08-01 12:14:34 UTC
This issue has been addressed in the following products:

  Red Hat Enterprise Linux 7

Via RHSA-2017:1871 https://access.redhat.com/errata/RHSA-2017:1871


Note You need to log in before you can comment on or make changes to this bug.