Bug 120180 - printconf-gui generates incorrect printers.conf
printconf-gui generates incorrect printers.conf
Status: CLOSED DUPLICATE of bug 117943
Product: Fedora
Classification: Fedora
Component: system-config-printer (Show other bugs)
rawhide
All Linux
medium Severity low
: ---
: ---
Assigned To: Tim Waugh
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-04-06 12:49 EDT by Michael Styne
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 14:02:26 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Michael Styne 2004-04-06 12:49:10 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6) Gecko/20040312

Description of problem:
According to the printers.conf file, the Info tag for a printer is
supposed to be used like this:

#<Printer sample>
#
# Info: the description for the printer.
#
                                                                     
          
#Info Acme LaserPrint 1000

etc;

However, FC2T2, (and FC1, as well) generate a printers.conf that looks
like this:

<DefaultPrinter cx5200>
Info Created by redhat-config-printer 0.6.x
DeviceURI usb:/dev/usb/lp0
Location Epson CX5200

etc;

The "Info" line is supposed to be a description of the Printer. So
when the printer is shared to other computers, it shows up as "Created
by redhat-config-printer 0.6.x", instead of the much more useful
"Epson CX5200" -- which for some unknown reason is placed in the
"Location" field. Even swapping the two would make more sense, but
this "Created by" line has no real place in the printer definition.
People using a shared printed don't really care what application
created the configuration file for cups.

Ideally, something like this would be generated:

# Created by redhat-config-printer 0.6.x
<DefaultPrinter cx5200>
Info Epson CX5200
DeviceURI usb:/dev/usb/lp0
Location Accounting



Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Start printconf-gui
2. Add a printer
3. Share the printer
4. View the shared queue from another machine

    

Actual Results:  I saw that a printer called Created by
redhat-config-printer 0.6.x was shared by the server.

Expected Results:  I wanted to see that a printer called Epson CX5200
was shared by the server.

Additional info:

The only current workaround is to edit /etc/cups/printers.conf by
hand, and then re-edit it by hand every time printconf-gui is used.
Comment 1 Tim Waugh 2004-04-06 12:53:07 EDT

*** This bug has been marked as a duplicate of 117943 ***
Comment 2 Red Hat Bugzilla 2006-02-21 14:02:26 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.