Bug 1201896 - KeyError: 'LANG' when running vnc kickstart installation
Summary: KeyError: 'LANG' when running vnc kickstart installation
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: anaconda
Version: 22
Hardware: s390x
OS: Linux
medium
medium
Target Milestone: ---
Assignee: David Shea
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks: ZedoraTracker
TreeView+ depends on / blocked
 
Reported: 2015-03-13 18:07 UTC by Jan Stodola
Modified: 2015-04-04 17:52 UTC (History)
4 users (show)

Fixed In Version: anaconda-22.20.7-1.fc22
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-04-04 17:52:37 UTC


Attachments (Terms of Use)

Description Jan Stodola 2015-03-13 18:07:03 UTC
Description of problem:
I got following traceback when running kickstart vnc installation on s390x:

anaconda 22.20.1-1 exception report
Traceback (most recent call first):
  File "/usr/lib64/python2.7/UserDict.py", line 23, in __getitem__
    raise KeyError(key)
  File "/usr/lib64/python2.7/site-packages/pyanaconda/ui/gui/hubs/progress.py", line 172, in _get_rnotes
    best_lang = find_best_locale_match(os.environ["LANG"], pixmap_langs)
  File "/usr/lib64/python2.7/site-packages/pyanaconda/ui/gui/hubs/progress.py", line 230, in initialize
    rnotes = self._get_rnotes()
  File "/usr/lib64/python2.7/site-packages/pyanaconda/ui/gui/__init__.py", line 794, in _on_continue_clicked
    nextAction.initialize()
KeyError: 'LANG'

kickstart:

install
lang en_US.UTF-8
keyboard us
reboot
vnc
rootpw redhat
timezone --utc America/New_York

# partitioning: autopart
bootloader --location=mbr
zerombr
clearpart --all --initlabel
autopart

%packages
@^server-product-environment
%end


Version-Release number of selected component (if applicable):
installation source: http://s390.koji.fedoraproject.org/test/20150312/s390x/os/
anaconda-22.20.1-1

How reproducible:
always on s390x

Steps to Reproduce:
1. run kickstart installation with the kickstart above

Actual results:
traceback

Expected results:
successful installation

Additional info:
Unable to reproduce during text/cmdline kickstart installation on s390x
Unable to reproduce during manual vnc/text installation on s390x
Unable to reproduce on x86_64 (with F22 Alpha)

Comment 2 David Shea 2015-03-23 19:14:57 UTC
(In reply to Jan Stodola from comment #0)
> Additional info:
> Unable to reproduce during text/cmdline kickstart installation on s390x
> Unable to reproduce during manual vnc/text installation on s390x
> Unable to reproduce on x86_64 (with F22 Alpha)

s390x is in the unique position of not using tmux and thus not having an initial $LANG set, is why it doesn't happen on other arches.

Comment 3 Fedora Update System 2015-03-26 19:53:50 UTC
anaconda-22.20.7-1.fc22 has been submitted as an update for Fedora 22.
https://admin.fedoraproject.org/updates/anaconda-22.20.7-1.fc22

Comment 4 Fedora Update System 2015-03-29 05:04:02 UTC
Package anaconda-22.20.7-1.fc22:
* should fix your issue,
* was pushed to the Fedora 22 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing anaconda-22.20.7-1.fc22'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2015-4952/anaconda-22.20.7-1.fc22
then log in and leave karma (feedback).

Comment 5 Fedora Update System 2015-03-31 21:42:48 UTC
Package anaconda-22.20.7-1.fc22, libblockdev-0.8-1.fc22:
* should fix your issue,
* was pushed to the Fedora 22 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing anaconda-22.20.7-1.fc22 libblockdev-0.8-1.fc22'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2015-4952/libblockdev-0.8-1.fc22,anaconda-22.20.7-1.fc22
then log in and leave karma (feedback).

Comment 6 Fedora Update System 2015-04-04 17:52:37 UTC
anaconda-22.20.7-1.fc22, libblockdev-0.8-1.fc22 has been pushed to the Fedora 22 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.