Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be unavailable on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 1201983 - Unable to install from Corsair Voyager GTX USB stick (missing uas module in initrd)
Summary: Unable to install from Corsair Voyager GTX USB stick (missing uas module in i...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: livecd-tools
Version: 22
Hardware: x86_64
OS: Linux
unspecified
unspecified
Target Milestone: ---
Assignee: Brian Lane
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-03-14 08:31 UTC by Sylvain Pasche
Modified: 2015-04-30 11:43 UTC (History)
13 users (show)

Fixed In Version: livecd-tools-22.1-1.fc22
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-04-30 11:43:55 UTC
Type: Bug


Attachments (Terms of Use)
patch adding the module to the live image initramfs. (1.06 KB, patch)
2015-03-18 21:07 UTC, Sylvain Pasche
no flags Details | Diff

Description Sylvain Pasche 2015-03-14 08:31:01 UTC
I copied the Fedora 22 Alpha live Workstation iso image to a Corsair Voyager GTX USB stick. When booting the installer, it fails with the error:

[   14.682655] localhost dracut-initqueue[421]: Warning: /dev/disk/by-label/Fedora-Live-WS-x86_64-22_A-3 does not exist
[   14.683216] localhost dracut-initqueue[421]: Warning: /dev/mapper/live-rw does not exist
[   14.692884] localhost systemd[1]: Starting Dracut Emergency Shell...

When looking at /sys/block, I can see that the USB stick is not detected.

The drive is detected from a Fedora 21 desktop. Apparently, the issue is that the live image initrd doesn't contain the uas (USB Attached SCSI) kernel module which is needed to access that drive.

To confirm, I copied the uas.ko.xz kernel module along with insmod on the /boot partition of my hard drive and loaded it from a dracut shell (rd.break=cmdline). Then, the disk was successfully detected and I could boot the live image.

Would it be possible to include that module in the live image initrd so that it's possible to install Fedora from such devices?

Comment 1 Kevin Fenzi 2015-03-17 22:57:09 UTC
Not sure what spin-kickstarts can do here... that module is part of kernel-core, so I would expect it to be available. 

Is it there after you install from the live image and boot the install?

Perhaps dracut is not including it for some reason?

Comment 2 David Shea 2015-03-18 13:24:00 UTC
I suppose it could be dracut. I just assumed spin-kickstarts was excluding/not-including something, since uas.ko is available in the initrd for the server ISOs but not the workstation live ISO (looking at Beta TC2 for both). uas.ko is included in the live image, though I can't say whether it would be included in the hostonly initrd generated by the install.

Comment 3 Sylvain Pasche 2015-03-18 21:05:38 UTC
(In reply to Kevin Fenzi from comment #1)
> Is it there after you install from the live image and boot the install?

It is.

Apparently, the module is not on the live initramfs because livecd-creator has a list of modules to include (https://github.com/rhinstaller/livecd-tools/blob/master/imgcreate/live.py#L83). It would be possible to add a "device uas" entry to the kickstart, but it seems more common to add it to livecd-tools? A benefit is that it would be available on all live images by default.

Comment 4 Sylvain Pasche 2015-03-18 21:07:56 UTC
Created attachment 1003452 [details]
patch adding the module to the live image initramfs.

Suggested patch to livecd-tools. I haven't tested it yet.

Comment 5 Brian Lane 2015-03-18 21:32:59 UTC
I'd do it like this:

https://github.com/rhinstaller/livecd-tools/pull/2

If you want to try making an iso that'd be great, but it's simple enough that it should fix it.

Comment 6 Sylvain Pasche 2015-03-19 20:50:37 UTC
I tested your change by building an iso and it works.

I believe it's not added by dracut in the live image initrd because if you explicitly set a list of drivers, it disables the code that builds the list of modules to copy (http://git.kernel.org/cgit/boot/dracut/dracut.git/tree/modules.d/90kernel-modules/module-setup.sh#n5).

Comment 7 Brian Lane 2015-03-20 15:46:45 UTC
Thanks for testing. Note that the list is additive:

https://github.com/rhinstaller/livecd-tools/blob/master/imgcreate/live.py#L302

Comment 8 Fedora Update System 2015-03-21 01:40:41 UTC
livecd-tools-22.1-1.fc22 has been submitted as an update for Fedora 22.
https://admin.fedoraproject.org/updates/livecd-tools-22.1-1.fc22

Comment 9 Fedora Update System 2015-03-22 04:33:42 UTC
Package livecd-tools-22.1-1.fc22:
* should fix your issue,
* was pushed to the Fedora 22 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing livecd-tools-22.1-1.fc22'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2015-4388/livecd-tools-22.1-1.fc22
then log in and leave karma (feedback).

Comment 10 Fedora Update System 2015-04-30 11:43:55 UTC
livecd-tools-22.1-1.fc22 has been pushed to the Fedora 22 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.