Bug 1201994 - [abrt] hplip: logger.py:199:log:OSError: [Errno 5] Input/output error
Summary: [abrt] hplip: logger.py:199:log:OSError: [Errno 5] Input/output error
Keywords:
Status: CLOSED DUPLICATE of bug 712537
Alias: None
Product: Fedora
Classification: Fedora
Component: hplip
Version: 22
Hardware: x86_64
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Tim Waugh
QA Contact: Fedora Extras Quality Assurance
URL: https://retrace.fedoraproject.org/faf...
Whiteboard: abrt_hash:8602bc74087e792cbc52b1ed278...
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-03-14 12:21 UTC by Onyeibo Oku
Modified: 2015-03-16 12:52 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-03-16 12:52:07 UTC
Type: ---


Attachments (Terms of Use)
File: backtrace (570 bytes, text/plain)
2015-03-14 12:21 UTC, Onyeibo Oku
no flags Details
File: environ (951 bytes, text/plain)
2015-03-14 12:21 UTC, Onyeibo Oku
no flags Details

Description Onyeibo Oku 2015-03-14 12:21:44 UTC
Description of problem:
HP Device Manager was downloading plugin for HP Laserjet 1020 when this happened.
Kept getting notified that keyserver could not be accessed
Plugin installation failed

Version-Release number of selected component:
hplip-3.15.2-5.fc22

Additional info:
reporter:       libreport-2.4.0
cmdline:        /usr/bin/python3 /bin/hp-plugin -u --required --reason 1 To_install_plugin_for_HP_Device
executable:     /bin/hp-plugin
kernel:         4.0.0-0.rc2.git0.1.fc22.x86_64
runlevel:       N 3
type:           Python3
uid:            0

Truncated backtrace:
logger.py:199:log:OSError: [Errno 5] Input/output error

Traceback (most recent call last):
  File "/bin/hp-plugin", line 418, in <module>
    log.info("")
  File "/usr/share/hplip/base/logger.py", line 298, in info
    self.log(message, Logger.LOG_LEVEL_INFO)
  File "/usr/share/hplip/base/logger.py", line 199, in log
    out.write('\n')
OSError: [Errno 5] Input/output error

Local variables in innermost frame:
level: 10
message: ''
newline: True
out: <_io.TextIOWrapper name='<stdout>' mode='w' encoding='UTF-8'>
self: <base.logger.Logger object at 0x7f1c4a66d828>

Comment 1 Onyeibo Oku 2015-03-14 12:21:48 UTC
Created attachment 1001595 [details]
File: backtrace

Comment 2 Onyeibo Oku 2015-03-14 12:21:50 UTC
Created attachment 1001596 [details]
File: environ

Comment 3 Jiri Popelka 2015-03-16 12:52:07 UTC

*** This bug has been marked as a duplicate of bug 712537 ***


Note You need to log in before you can comment on or make changes to this bug.