Bug 1201997 - Front Panel Sound Jack (headphone) not working with F21 and Fedora 22 Beta
Summary: Front Panel Sound Jack (headphone) not working with F21 and Fedora 22 Beta
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: pulseaudio
Version: 24
Hardware: x86_64
OS: Linux
unspecified
high
Target Milestone: ---
Assignee: Lennart Poettering
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-03-14 12:29 UTC by Leslie Satenstein
Modified: 2017-12-12 00:43 UTC (History)
19 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-05-04 17:04:48 UTC
Type: Bug


Attachments (Terms of Use)
pactl list sinks (3.83 KB, text/plain)
2015-04-16 13:28 UTC, Leslie Satenstein
no flags Details
This file was automatically sent up to target web address (47.35 KB, text/plain)
2015-04-17 01:36 UTC, Leslie Satenstein
no flags Details
alsa output (47.35 KB, text/plain)
2015-04-17 01:47 UTC, Leslie Satenstein
no flags Details
second test alsa-info (47.35 KB, text/plain)
2015-04-17 01:48 UTC, Leslie Satenstein
no flags Details
alsa-info.sh output (47.34 KB, text/plain)
2015-04-24 15:43 UTC, Leslie Satenstein
no flags Details


Links
System ID Private Priority Status Summary Last Updated
Launchpad 1248116 0 None None None Never
Linux Kernel 68071 0 None None None Never
Red Hat Bugzilla 1236028 0 unspecified CLOSED audio output doesn't automatically switch between speakers and earphones 2021-02-22 00:41:40 UTC

Internal Links: 1236028

Description Leslie Satenstein 2015-03-14 12:29:55 UTC
Description of problem:

Description of problem:
Headphone jack stopped working in linux after update.  Works fine in Fedora 21.

Version-Release number of selected component (if applicable):

Fedora 22 Beta (As of March 11, 2015)

How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Comment 1 Leslie Satenstein 2015-03-26 00:48:13 UTC
Ditto with Fedora21 as of March 24 updates (To prepare for transition from F21 to F22)

prior to updates of March 24, front jack was working properly.

It works with Suse13.1 (multi-boot)

Comment 2 Leslie Satenstein 2015-04-01 16:01:02 UTC
This problem appears to have started with Kernel 3.19.1

Comment 3 Leslie Satenstein 2015-04-15 19:48:08 UTC
This is a Fedora 21 and Fedora 22 problem. The desktop front panel sound jack was working with kernel 3.18.x on Fedora21 and stopped, until or coincident with the installation of kernel 3.19.0. It is no longer working for Fedora21 or Fedora 22.

In a room with several Fedora 21 systems, with wife, son, myself following courses or viewing youtube, front earphone jack functioning is not a luxury, it is a requirement. We can't all keep speakers on concurrently

In the interrim, we have installed SUSE13.2 with which the front earphone jack functions correctly.  The SUSE13.1 Linux version is 3.18.x

Comment 4 Raymond 2015-04-16 05:58:49 UTC
you have to provide output of alsa-info.sh 

pactl list sinks

Comment 5 Leslie Satenstein 2015-04-16 13:28:21 UTC
Created attachment 1015212 [details]
pactl list sinks

Comment 6 Raymond 2015-04-16 15:41:27 UTC
Ports:
		analog-output-lineout: Line Out (priority: 9900, available)
		analog-output-headphones: Headphones (priority: 9000, not available)
	Active Port: analog-output-lineout

 pulseaudio select line out when headphone is not plugged



http://git.alsa-project.org/?p=alsa-tools.git;a=tree

try 


hdajacksensetest -c1 -a


or

 hda-verb

Comment 7 Raymond 2015-04-16 15:43:44 UTC
should be

hdajacksensetest -c0 -a

when you plug and unplug headphone

Comment 8 Leslie Satenstein 2015-04-17 01:36:20 UTC
Created attachment 1015422 [details]
This file was automatically sent up to target web address

A second copy is attached.

Comment 9 Leslie Satenstein 2015-04-17 01:47:12 UTC
Created attachment 1015426 [details]
alsa output

first test

Comment 10 Leslie Satenstein 2015-04-17 01:48:36 UTC
Created attachment 1015427 [details]
second test alsa-info

Should one test be run with earphone plugged and second without it being plugged?

Comment 11 Raymond 2015-04-17 03:45:00 UTC
control.36 {
		iface CARD
		name 'Front Mic Jack'
		value false
		comment {
			access read
			type BOOLEAN
			count 1
		}
	}
	control.37 {
		iface CARD
		name 'Rear Mic Jack'
		value false
		comment {
			access read
			type BOOLEAN
			count 1
		}
	}
	control.38 {
		iface CARD
		name 'Line Jack'
		value false
		comment {
			access read
			type BOOLEAN
			count 1
		}
	}
	control.39 {
		iface CARD
		name 'Line Out Front Jack'
		value true
		comment {
			access read
			type BOOLEAN
			count 1
		}
	}
	control.40 {
		iface CARD
		name 'Line Out Surround Jack'
		value false
		comment {
			access read
			type BOOLEAN
			count 1
		}
	}
	control.41 {
		iface CARD
		name 'Line Out CLFE Jack'
		value false
		comment {
			access read
			type BOOLEAN
			count 1
		}
	}
	control.42 {
		iface CARD
		name 'Line Out Side Jack'
		value false
		comment {
			access read
			type BOOLEAN
			count 1
		}
	}
	control.43 {
		iface CARD
		name 'Front Headphone Jack'
		value false
		comment {
			access read
			type BOOLEAN
			count 1
		}
	}

seem cannot detect the headphone jack as green line out can be detected

check your computer chassis front audio panel is HDA which support jack detection


http://www.intel.com/support/motherboards/desktop/sb/cs-015851.htm


this also show you the states of your jack

amixer -c 0 content

https://communities.intel.com/docs/DOC-4393

Comment 12 Leslie Satenstein 2015-04-17 16:28:02 UTC
Hi Raymond

SUSE13.2 detects it and it works with SUSE13.2. When I my courcera.com courses (combinatorial maths, python, and Algorithms2, I reboot to SUSE13.2

If I install Fedora 21 of December, and not perform updates, I remember very well that it worked OK. I will retry with liveCD from Fedora 21 and post results here.

Comment 13 Raymond 2015-04-18 05:13:00 UTC
do you mean regression of this patch ?

https://git.kernel.org/cgit/linux/kernel/git/tiwai/sound.git/commit/sound/pci/hda?id=2f35c630f7d49efdef29b58d81ed2531ddd916d9

hda - Use standard workqueue for unsol and jack events


post outputs before and after you plug hp

hdajacksensetest

Comment 14 Leslie Satenstein 2015-04-23 11:27:37 UTC
pulseaudio-6.0-2.fc21.1.x86_64


This same problem was reported with OpenSuse13.2 following yesterdays(22March 2015) Suse update.

The author of the regression patch has not solved the proglem.

Please advise him that in a room of desktop computers, one has to use the headphone jack for sound, and not the speaker jack. (Can you imagine 5 users, each using the speakers and all on different topics?)

And its broken in Fedora 22 as well.

Comment 15 Leslie Satenstein 2015-04-24 15:43:47 UTC
Created attachment 1018531 [details]
alsa-info.sh output

The shell script uploaded the above file to alsa support.

Hopefully this bug can be a regular fix before Fedora22 goes live.

Comment 16 Leslie Satenstein 2015-04-28 00:21:06 UTC
This ius not a kernal problem but an alsa/pulseaudio problem.  I did the following test.

1)  Install Fedora 21 Respin from 1 January 2015.

2)  exclude Alsa and pulseaudio modules from YUM updates.

3)   bring that Fedora respin up to date with most recent kernel.


Audio jack  working  / alsa-5* and  pulseaudio-5*  

Not working   alsa-6* and pulseaudio-6*

Comment 17 Leslie Satenstein 2015-04-28 16:16:42 UTC
I have raised the importance from Fedora21 to Fedora22 (Same problem)

Comment 18 Leslie Satenstein 2015-05-05 02:52:07 UTC
With Fedora 22 I discovered that the amixer command is required.

I did receive the following patch and instructions

# Create this file "nojack"
  
copy the file to /lib/firmware/alsa/
If alsa does not exist in ...firmware, create it
You can omit the #==========
#========================
[codec]
0x10ec0888 0x104382fe 0
[hint]
jack_detect = no
#======================


The instructions to implement for Fedora 21. 

cd to /etc/modprobe.d  and add the following:

create 50-jack.conf with the following one line

options snd-hda-intel patch=alsa/nojack


save and reboot
enter 
 amixer -c0 set Headphone unmute 100%

Timing problems occurred if the above was placed into the user's .bash_profile.

Therefore a two line file was placed into /usr/local/bin as amixer.sh 
sleep 1
amixer -c0 set Headphone unmute 100%

and in the users .bash_profile I added

/usr/local/bin/amixer.sh &

This entire patch works for Fedora21 and Fedora 22.
 
The problem is that many older mother boards did not detect headphone jack in/out detection. These compuers have mother boards with dual core high performance systems.

Please post a recommendation as to where and what to paste so that headphone jack sound is enabled at boot time, as it worked with vanilla Fedora21 release.

Comment 19 Raymond 2015-05-20 08:23:18 UTC
you have to provide tracepoint and check the unsol events trigger get_pin_sense, set_pin_ctl or set_amp_mute (auto mute)

https://bugs.freedesktop.org/show_bug.cgi?id=90480#c5

Comment 20 Leslie Satenstein 2015-05-20 13:24:11 UTC
Good morning Raymond
 
You are asking me to provide tracepoint and sending me to another bug report.
My skills are not as a system maintainer, but as a system user.

Please provide a link to "tracepoint" jargon. 

I will do what I can after I complete the reading of 

https://www.kernel.org/doc/Documentation/trace/tracepoints.txt

I have also removed the alsa/nojack and the modset.d as described in comment 18 as my my workaround solution is to use the latter part of that comment 18, beginning with the text "Timing problems occurred..." 

Please note the final paragraph of comment 18.  Alsa headphone jack worked in January with the initial release of Fedora 21, and by the way, the initial release of Open Suse13.2. 

My background. I program in C, and have 20 years of development with encryption, C database interacting and  security. If you have some instructions for me regarding an existing tracepoint facility, just email it to me or post that instruction sheet or document to this bug report as an attachment file.

Comment 22 Leslie Satenstein 2015-06-08 13:53:17 UTC
I use Fedora 22, and as a dumb user, I have done the following.

within /bin

script amixer.sh
  
    #!/bin/bash 
    /bin/amixer -c0 set Headphone unmute 100%  >/dev/null
    

Within   /etc/skel/.bash_profile and within each users ~/.bash_profile

added

    /bin/amixer.sh &           


Explanation of /bin/amixer.sh
The sleep 1  is required so that the user's ~/.bash_profile completes before
the /bin/amixer command is invoked.

Comment 23 Leslie Satenstein 2015-08-13 15:31:58 UTC
I have to add
amixer.sh to /bin


 #!/bin/bash
     sleep 1 
    /bin/amixer -c0 set Headphone unmute 100%  >/dev/null 2>&1



Without the sleep 1 the amixer line will complete before the user is setup.
and in ./bash_profile 

      /bin/amixer.sh >/dev/null 2>&1  &

After the one second delay, the user is setup and this command turns on the front speaker jacks.

But

If I do switch user, and then return, the front jacks remain off.

This is also  Fedora 23 problem.   I am an end-user, not a software developer, 

And... hdajacksensetest  Was not able to find it or use it.  Where is it downloadable?

Comment 24 Leslie Satenstein 2015-10-18 00:06:39 UTC
I don't care if the speakers are left on. I would like to have the headphones left on continuously.

I am using a desktop system with ASUS motherboard and integrated sound chip.

With F21, I had continuous sound, With F22, F23, I have to run my little script, which if I do a "switch user", and return, I have lost sound in the headphones.

Why OK in F21, but no longer OK with F22, F23?

Comment 25 Leslie Satenstein 2015-10-23 16:15:05 UTC
Is this bug going to be resolved for F23 or F24? 

If not, please close, so I can drop it from my todo follow up list.

Comment 26 Paolo Antinori 2015-11-06 20:03:37 UTC
Hello, I'm facing the same problem on Fedora 23.

Please let me know if I can produce any output that can help you to debug the problem

Comment 27 Leslie Satenstein 2015-11-10 16:13:22 UTC
By the way, front headphone jack sound works "out of the box" with kubuntu.


This is the way I am performing a work around.
I monitor the script for changes.
thie script amixer.sh goes into /bin

#!/bin/bash
MYDIR=$(cat /etc/passwd | grep $(whoami) | cut -d ':' -f6 | sort -u)
out=$MYDIR/today.txt
sleep 1
echo "$0 $(date)" >>${out}
/bin/amixer -c0 set Headphone unmute 100% >>${out} 2>&1


This line is provided as the last entry in ~/bash_profile

/bin/amixer.sh  & >/dev/null 2>&1

Note the & within the .bash_profile and the sleep command within /bin/amixer.sh.
The intention is to delay the amixer setup line to after the user has fully completed the login command 

Is there a modeset or a nojack option to live patch alsa 
I would like to have sound at the jack at all times.

Comment 28 Leslie Satenstein 2016-05-04 15:57:52 UTC
Please close With F22-F23-F24(beta) front jack is selectable 
with selection on line, the following will also enable headphone jack.
 

/bin/amixer -c0 set Headphone unmute 100% 

The system setting (system->sound) has selection of either line or headphone.  There should be one called  line and headphone. (built-in Audio)

GNOME 3.20 interface.

Comment 29 Eric 2017-12-12 00:43:51 UTC
I have a Lenovo T61P running Windows 7 and Fedora 27 64-bit dual booting.  On Windows the headphones work fine, but when booted in Fedora 27 only the speakers work.  Plugging in the headphone, I see the device is detected but no sound comes out.  This laptop uses an AD1984 sound chipset.  Please re-open this bug.


Note You need to log in before you can comment on or make changes to this bug.