Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be unavailable on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 1202108 - Error: g-bd-utils-exec-error-quark: Process reported exit code 1280: Logical volume VolGroup00/LogVol03 in use. Can't deactivate volume group "VolGroup00" with 1 open logical volume(s) (0)
Summary: Error: g-bd-utils-exec-error-quark: Process reported exit code 1280: Logica...
Keywords:
Status: CLOSED DUPLICATE of bug 1202505
Alias: None
Product: Fedora
Classification: Fedora
Component: anaconda
Version: 22
Hardware: x86_64
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Anaconda Maintenance Team
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: abrt_hash:7b8ea3dbfe9af183ed351560cb6...
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-03-15 13:46 UTC by Joachim Frieben
Modified: 2015-03-17 18:25 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-03-17 18:25:21 UTC
Type: ---


Attachments (Terms of Use)
File: anaconda-tb (821.15 KB, text/plain)
2015-03-15 13:46 UTC, Joachim Frieben
no flags Details
File: anaconda.log (7.17 KB, text/plain)
2015-03-15 13:46 UTC, Joachim Frieben
no flags Details
File: environ (619 bytes, text/plain)
2015-03-15 13:46 UTC, Joachim Frieben
no flags Details
File: journalctl (513.10 KB, text/plain)
2015-03-15 13:46 UTC, Joachim Frieben
no flags Details
File: lsblk_output (3.45 KB, text/plain)
2015-03-15 13:46 UTC, Joachim Frieben
no flags Details
File: nmcli_dev_list (2.32 KB, text/plain)
2015-03-15 13:46 UTC, Joachim Frieben
no flags Details
File: os_info (443 bytes, text/plain)
2015-03-15 13:46 UTC, Joachim Frieben
no flags Details
File: program.log (76.08 KB, text/plain)
2015-03-15 13:46 UTC, Joachim Frieben
no flags Details
File: storage.log (212.02 KB, text/plain)
2015-03-15 13:46 UTC, Joachim Frieben
no flags Details
File: ifcfg.log (3.86 KB, text/plain)
2015-03-15 13:46 UTC, Joachim Frieben
no flags Details

Description Joachim Frieben 2015-03-15 13:46:24 UTC
Description of problem:
Install current Fedora 22 from a running live session after updating all installer-dependent packages.

Version-Release number of selected component:
anaconda-core-22.20.4-1.fc22.x86_64

The following was filed automatically by anaconda:
anaconda 22.20.4-1 exception report
Traceback (most recent call first):
  File "/usr/lib/python2.7/site-packages/blivet/devices/lvm.py", line 203, in _teardown
    blockdev.lvm_vgdeactivate(self.name)
  File "/usr/lib/python2.7/site-packages/blivet/devices/storage.py", line 470, in teardown
    self._teardown(recursive=recursive)
  File "/usr/lib/python2.7/site-packages/blivet/devices/device.py", line 211, in teardownParents
    parent.teardown(recursive=recursive)
  File "/usr/lib/python2.7/site-packages/blivet/devices/storage.py", line 476, in _postTeardown
    self.teardownParents(recursive=recursive)
  File "/usr/lib/python2.7/site-packages/blivet/devices/lvm.py", line 643, in _postTeardown
    StorageDevice._postTeardown(self, recursive=recursive)
  File "/usr/lib/python2.7/site-packages/blivet/devices/storage.py", line 471, in teardown
    self._postTeardown(recursive=recursive)
  File "/usr/lib/python2.7/site-packages/blivet/devicetree.py", line 2215, in teardownAll
    device.teardown(recursive=True)
  File "/usr/lib/python2.7/site-packages/blivet/devicetree.py", line 2186, in _populate
    self.teardownAll()
  File "/usr/lib/python2.7/site-packages/blivet/devicetree.py", line 2111, in populate
    self._populate()
  File "/usr/lib/python2.7/site-packages/blivet/blivet.py", line 277, in reset
    self.devicetree.populate(cleanupOnly=cleanupOnly)
  File "/usr/lib/python2.7/site-packages/blivet/osinstall.py", line 1116, in storageInitialize
    storage.reset()
  File "/usr/lib64/python2.7/threading.py", line 766, in run
    self.__target(*self.__args, **self.__kwargs)
  File "/usr/lib64/python2.7/site-packages/pyanaconda/threads.py", line 238, in run
    threading.Thread.run(self, *args, **kwargs)
Error: g-bd-utils-exec-error-quark: Process reported exit code 1280:   Logical volume VolGroup00/LogVol03 in use.
  Can't deactivate volume group "VolGroup00" with 1 open logical volume(s)
 (0)

Additional info:
cmdline:        /usr/bin/python2  /sbin/anaconda --liveinst --method=livecd:///dev/mapper/live-base
cmdline_file:   BOOT_IMAGE=vmlinuz0 initrd=initrd0.img root=live:CDLABEL=Fedora-Live-WS-x86_64-22-2015031 rootfstype=auto ro rd.live.image quiet  rhgb rd.luks=0 rd.md=0 rd.dm=0 
executable:     /sbin/anaconda
hashmarkername: anaconda
kernel:         4.0.0-0.rc1.git0.1.fc22.x86_64
other involved packages: python-libs-2.7.9-5.fc22.x86_64, python-blivet-1.0.3-1.fc22.noarch
product:        Fedora"
release:        Fedora release 22 (Twenty Two)
type:           anaconda
version:        Fedora

Comment 1 Joachim Frieben 2015-03-15 13:46:37 UTC
Created attachment 1001948 [details]
File: anaconda-tb

Comment 2 Joachim Frieben 2015-03-15 13:46:38 UTC
Created attachment 1001949 [details]
File: anaconda.log

Comment 3 Joachim Frieben 2015-03-15 13:46:39 UTC
Created attachment 1001950 [details]
File: environ

Comment 4 Joachim Frieben 2015-03-15 13:46:47 UTC
Created attachment 1001951 [details]
File: journalctl

Comment 5 Joachim Frieben 2015-03-15 13:46:49 UTC
Created attachment 1001952 [details]
File: lsblk_output

Comment 6 Joachim Frieben 2015-03-15 13:46:50 UTC
Created attachment 1001953 [details]
File: nmcli_dev_list

Comment 7 Joachim Frieben 2015-03-15 13:46:51 UTC
Created attachment 1001954 [details]
File: os_info

Comment 8 Joachim Frieben 2015-03-15 13:46:54 UTC
Created attachment 1001955 [details]
File: program.log

Comment 9 Joachim Frieben 2015-03-15 13:46:58 UTC
Created attachment 1001956 [details]
File: storage.log

Comment 10 Joachim Frieben 2015-03-15 13:46:59 UTC
Created attachment 1001957 [details]
File: ifcfg.log

Comment 11 David Shea 2015-03-17 18:25:21 UTC

*** This bug has been marked as a duplicate of bug 1202505 ***


Note You need to log in before you can comment on or make changes to this bug.