Bug 1202113 - initial-setup graphical service isn't enabled after installation of mate live spin f22
Summary: initial-setup graphical service isn't enabled after installation of mate live...
Keywords:
Status: CLOSED DUPLICATE of bug 1185447
Alias: None
Product: Fedora
Classification: Fedora
Component: initial-setup
Version: 22
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Martin Kolman
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: RejectedBlocker
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-03-15 14:44 UTC by Wolfgang Ulbrich
Modified: 2015-08-11 16:20 UTC (History)
11 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-08-11 16:20:45 UTC


Attachments (Terms of Use)
initial setup in MATE Live 03-15 (728.35 KB, image/jpeg)
2015-03-15 22:44 UTC, satellitgo
no flags Details
output of 'systemctl status initial-setup-graphical-service' on a TC9 BETA (KDE) (2.27 KB, text/plain)
2015-04-07 19:44 UTC, Giulio 'juliuxpigface'
no flags Details
output of 'systemctl status initial-setup-text-service' on a TC9 BETA (KDE) (439 bytes, text/plain)
2015-04-07 19:47 UTC, Giulio 'juliuxpigface'
no flags Details
output of 'journalctl -u initial-setup-graphical.service' on a TC9 BETA (KDE) (139.96 KB, text/plain)
2015-04-10 11:24 UTC, Giulio 'juliuxpigface'
no flags Details
output of 'journalctl -u initial-setup-text.service' on a TC9 BETA (KDE) (5.12 KB, text/plain)
2015-04-10 11:25 UTC, Giulio 'juliuxpigface'
no flags Details
complete first boot journal output when X starts (18.33 KB, text/plain)
2015-05-09 10:11 UTC, Wolfgang Ulbrich
no flags Details


Links
System ID Priority Status Summary Last Updated
Red Hat Bugzilla 1185447 None None None Never

Internal Links: 1185447

Description Wolfgang Ulbrich 2015-03-15 14:44:01 UTC
Description of problem:

After installation of nightly build Mate live spin from today
http://koji.fedoraproject.org/koji/taskinfo?taskID=9235773
initial-setup-graphical.service isn't enabled, in result only text mode comes up.
After i enabled the service in konsole initial-setup-gui displays well in installation.
I haven't tested if other spins are affected too.

Comment 1 Fedora Blocker Bugs Application 2015-03-15 15:13:00 UTC
Proposed as a Blocker for 22-beta by Fedora user raveit65 using the blocker tracking app because:

 Initial-setup graphical service needs to be enabled after installation if no user was created by anaconda.
Mentioned in alpha release critera (firstboot utilities).
On the first boot after installation, a utility for creating user accounts and other configuration may (may, not must) run prior to a log in screen appearing. 
https://fedoraproject.org/wiki/Fedora_22_Alpha_Release_Criteria#Expected_installed_system_boot_behavior

Comment 2 Adam Williamson 2015-03-15 16:43:35 UTC
Are you sure it isn't enabled, or does it just not run?

I've already filed https://bugzilla.redhat.com/show_bug.cgi?id=1185447 for Xfce. In my tests it seems both are enabled, but for some reason, text wins the race to run (which is supposed to be rigged so graphical will always win if possible).

Comment 3 Wolfgang Ulbrich 2015-03-15 17:21:07 UTC
systemctl shows that both units text and grapical mode isn't enabled.
And only the text mode runs.
I tested xfce livecd and i got same results.
http://koji.fedoraproject.org/koji/taskinfo?taskID=9235784
Note, don't use gnome-boxes.
For some reasons gnome-boxes starts the graphical service although the service is disabled.
I used virtual-manager in my tests.

Comment 4 Wolfgang Ulbrich 2015-03-15 17:48:08 UTC
I tested again xfce livecd and both services are enabled after installation and booting in rescue target, but only text mode runs after switch to default target.
So, the issue might be different.
Anyways, i will run mate livcd once again to be shure.

Comment 5 Wolfgang Ulbrich 2015-03-15 18:29:03 UTC
Now, it's get weird.

third attempt mate livecd:
1. boot to rescue target after installation
2. systemctl listed both services as enabled
3. switch to default target
4. boom, initial-setup graphical service runs well !

fourth attempt mate livecd:
1. boot to default target after installation
2. only initial-setup in text mode is running
3. quitting initial-setup (nothing is configurated)
4. switch konsole
5. both services *aren't enabled*

So, it seems the issue isn't 100% reproducible, but in most attempts (5/6 today) it doesn't work.

Comment 6 satellitgo 2015-03-15 22:37:35 UTC
I see initial setup in gnome-boxes and VirtualBox  if I do root password and not USer (no user)

Comment 7 satellitgo 2015-03-15 22:44:46 UTC
Created attachment 1002071 [details]
initial setup in MATE Live 03-15

Anaconda stops before writing configs; waits for  user setup then will write
final configuration with/ or (without user and user password)

Comment 8 Vratislav Podzimek 2015-03-16 11:07:34 UTC
Martin, can you please have a look at this? There seems to be some race condition between the graphical and text service. (or something has changed in systemd)

Comment 9 Martin Kolman 2015-03-16 11:24:33 UTC
(In reply to Vratislav Podzimek from comment #8)
> Martin, can you please have a look at this? There seems to be some race
> condition between the graphical and text service. (or something has changed
> in systemd)

Sure!

Comment 10 Dan Mossor [danofsatx] 2015-03-16 17:38:58 UTC
Discussed at Fedora Blocker Review Meeting 2015-03-16[0]:

RejectedBlocker - This bug only seems to apply to non-blocking DE's and therefore isn't considered a blocker.

[0]: http://meetbot.fedoraproject.org/fedora-blocker-review/2015-03-16/f22-blocker-review.2015-03-16-16.01.log.txt

Comment 11 Jaroslav Reznik 2015-03-17 09:16:01 UTC
(In reply to Dan Mossor from comment #10)
> Discussed at Fedora Blocker Review Meeting 2015-03-16[0]:
> 
> RejectedBlocker - This bug only seems to apply to non-blocking DE's and
> therefore isn't considered a blocker.
> 
> [0]:
> http://meetbot.fedoraproject.org/fedora-blocker-review/2015-03-16/f22-
> blocker-review.2015-03-16-16.01.log.txt

Confirmed it's not happening in release-blocking KDE TC2 spin and works as expected.

Comment 12 Wolfgang Ulbrich 2015-03-17 11:53:54 UTC
Same with Mate live TC2, the services are both enabled but only the text mode comes up.
Tested with virtual-manager (qemu-kvm) and gnome-boxes on f20 host.

Comment 13 Wolfgang Ulbrich 2015-04-06 14:02:08 UTC
With Mate beta-tc7 i see the issue only inside f20 host quemu-kvm.
On the same machine inside a f22 installation the issue don't exists with qemu-kvm.
Ok, looks like a issue with grapic driver from VM.
I will ignore it.

Comment 14 Adam Williamson 2015-04-06 16:26:47 UTC
Multiple people have reported this with multiple spins, I don't think we can close it that easily.

Comment 15 Giulio 'juliuxpigface' 2015-04-07 19:43:18 UTC
The issue appears to be still here in Beta TC9. I'm running it inside a KVM guest.
The system has been installed from a KDE spin.

With another KVM guest, but installed from a Xfce TC9 live, I didn't encounter the issue. initial-setup was displayed as expected, and I successfully created the user.

Comment 16 Giulio 'juliuxpigface' 2015-04-07 19:44:46 UTC
Created attachment 1011915 [details]
output of 'systemctl status initial-setup-graphical-service' on a TC9 BETA (KDE)

Comment 17 Giulio 'juliuxpigface' 2015-04-07 19:47:48 UTC
Created attachment 1011916 [details]
output of 'systemctl status initial-setup-text-service' on a TC9 BETA (KDE)

Comment 18 Vratislav Podzimek 2015-04-10 08:31:36 UTC
Giulio, could you please attach the outputs of 'journalctl -u SERVICE' for both services? Thanks!

Comment 19 Vratislav Podzimek 2015-04-10 08:58:56 UTC
I think this is the same issue as described in the bug #1185447

Comment 20 Giulio 'juliuxpigface' 2015-04-10 11:24:35 UTC
Created attachment 1013107 [details]
output of 'journalctl -u initial-setup-graphical.service' on a TC9 BETA (KDE)

Comment 21 Giulio 'juliuxpigface' 2015-04-10 11:25:40 UTC
Created attachment 1013108 [details]
output of 'journalctl -u initial-setup-text.service' on a TC9 BETA (KDE)

Comment 22 Wolfgang Ulbrich 2015-05-09 10:08:44 UTC
It seems that initial-setup is complete broken now with Fedora-Live-MATE_Compiz-x86_64-22-TC3.iso.
Both services text and grapic don't start after installation, both services are enabled.

Mai 09 11:03:35 f22-test.mother.loc xinit[731]: X.Org X Server 1.17.1
Mai 09 11:03:35 f22-test.mother.loc xinit[731]: Release Date: 2015-02-10
Mai 09 11:03:35 f22-test.mother.loc xinit[731]: X Protocol Version 11, Revision 0
Mai 09 11:03:35 f22-test.mother.loc xinit[731]: Build Operating System:  3.19.1-201.fc21.x86_64
Mai 09 11:03:35 f22-test.mother.loc xinit[731]: Current Operating System: Linux f22-test.mother.loc 4.0.1-300.fc22.x86_64 #1 SMP Wed Apr 29 15:48:25 UTC 2015 x86_64
Mai 09 11:03:35 f22-test.mother.loc xinit[731]: Kernel command line: BOOT_IMAGE=/vmlinuz-4.0.1-300.fc22.x86_64 root=/dev/vda3 ro rhgb quiet LANG=de_DE.UTF-8
Mai 09 11:03:35 f22-test.mother.loc xinit[731]: Build Date: 02 May 2015  06:30:17AM
Mai 09 11:03:35 f22-test.mother.loc xinit[731]: Build ID: xorg-x11-server 1.17.1-10.fc22
Mai 09 11:03:35 f22-test.mother.loc xinit[731]: Current version of pixman: 0.32.6
Mai 09 11:03:35 f22-test.mother.loc xinit[731]: Before reporting problems, check http://wiki.x.org
Mai 09 11:03:35 f22-test.mother.loc xinit[731]: to make sure that you have the latest version.
Mai 09 11:03:35 f22-test.mother.loc xinit[731]: Markers: (--) probed, (**) from config file, (==) default setting,
Mai 09 11:03:35 f22-test.mother.loc xinit[731]: (++) from command line, (!!) notice, (II) informational,
Mai 09 11:03:35 f22-test.mother.loc xinit[731]: (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
Mai 09 11:03:35 f22-test.mother.loc xinit[731]: (==) Log file: "/var/log/Xorg.9.log", Time: Sat May  9 11:03:35 2015
Mai 09 11:03:35 f22-test.mother.loc xinit[731]: (==) Using config directory: "/etc/X11/xorg.conf.d"
Mai 09 11:03:35 f22-test.mother.loc xinit[731]: (==) Using system config directory "/usr/share/X11/xorg.conf.d"

Mai 09 11:03:35 f22-test.mother.loc xinit[731]: (II) [KMS] Kernel modesetting enabled.
Mai 09 11:03:35 f22-test.mother.loc audit: <audit-1325> table=filter family=2 entries=26
Mai 09 11:03:35 f22-test.mother.loc xinit[731]: resizing primary to 1024x768
Mai 09 11:03:35 f22-test.mother.loc xinit[731]: primary is 0x1cefb60

Mai 09 11:03:35 f22-test.mother.loc xinit[731]: The XKEYBOARD keymap compiler (xkbcomp) reports:
Mai 09 11:03:35 f22-test.mother.loc xinit[731]: > Warning:          Type "ONE_LEVEL" has 1 levels, but <RALT> has 2 symbols
Mai 09 11:03:35 f22-test.mother.loc xinit[731]: >                   Ignoring extra symbols
Mai 09 11:03:35 f22-test.mother.loc xinit[731]: Errors from xkbcomp are not fatal to the X server

Mai 09 11:03:35 f22-test.mother.loc root[795]: Running 0 window manager (/usr/bin/marco)
Mai 09 11:03:35 f22-test.mother.loc audit: <audit-1325> table=mangle family=2 entries=26
Mai 09 11:03:36 f22-test.mother.loc root[798]: Running /bin/initial-setup

Mai 09 11:03:36 f22-test.mother.loc root[802]: Running initial_setup

Mai 09 11:03:36 f22-test.mother.loc xinit[731]: ** (process:805): WARNING **: Cannot load the swap plugin: Failed to determine mkswap's version from: mkswap von util-linux 2.26.2

Mai 09 11:03:36 f22-test.mother.loc xinit[731]: ** (process:805): WARNING **: Cannot load the loop plugin: Failed to determine losetup's version from: losetup von util-linux 2.26.2

Mai 09 11:03:36 f22-test.mother.loc python[805]: detected unhandled Python exception in '/usr/lib/python2.7/site-packages/initial_setup/__main__.py'

Mai 09 11:03:37 f22-test.mother.loc dbus[558]: [system] Activating service name='org.freedesktop.problems' (using servicehelper)

Mai 09 11:03:37 f22-test.mother.loc xinit[731]: Traceback (most recent call last):
Mai 09 11:03:37 f22-test.mother.loc xinit[731]: File "/usr/lib64/python2.7/runpy.py", line 162, in _run_module_as_main
Mai 09 11:03:37 f22-test.mother.loc xinit[731]: "__main__", fname, loader, pkg_name)
Mai 09 11:03:37 f22-test.mother.loc xinit[731]: File "/usr/lib64/python2.7/runpy.py", line 72, in _run_code
Mai 09 11:03:37 f22-test.mother.loc xinit[731]: exec code in run_globals
Mai 09 11:03:37 f22-test.mother.loc xinit[731]: File "/usr/lib/python2.7/site-packages/initial_setup/__main__.py", line 8, in <module>
Mai 09 11:03:37 f22-test.mother.loc xinit[731]: from initial_setup.post_installclass import PostInstallClass
Mai 09 11:03:37 f22-test.mother.loc xinit[731]: File "/usr/lib/python2.7/site-packages/initial_setup/post_installclass.py", line 20, in <module>
Mai 09 11:03:37 f22-test.mother.loc xinit[731]: from pyanaconda.installclass import BaseInstallClass
Mai 09 11:03:37 f22-test.mother.loc xinit[731]: File "/usr/lib64/python2.7/site-packages/pyanaconda/installclass.py", line 28, in <module>
Mai 09 11:03:37 f22-test.mother.loc xinit[731]: from blivet.partspec import PartSpec
Mai 09 11:03:37 f22-test.mother.loc xinit[731]: File "/usr/lib/python2.7/site-packages/blivet/__init__.py", line 70, in <module>
Mai 09 11:03:37 f22-test.mother.loc xinit[731]: if not blockdev.try_init(require_plugins=_required_plugins, log_func=log_bd_message):
Mai 09 11:03:37 f22-test.mother.loc xinit[731]: GLib.Error: g-bd-init-error-quark: Failed to load plugins (0)

Mai 09 11:03:37 f22-test.mother.loc root[956]: initial_setup failed, keeping enabled

Mai 09 11:03:37 f22-test.mother.loc xinit[731]: /bin/xinit: connection to X server lost

Also starting initial-setup-graphical.service by hand didn't work.

Comment 23 Wolfgang Ulbrich 2015-05-09 10:11:11 UTC
Created attachment 1023704 [details]
complete first boot journal output when X starts

Comment 24 Wolfgang Ulbrich 2015-08-11 16:20:45 UTC

*** This bug has been marked as a duplicate of bug 1185447 ***


Note You need to log in before you can comment on or make changes to this bug.