Bug 1202116 - column sort on calculated value incorrect
Summary: column sort on calculated value incorrect
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: libreoffice
Version: 7.1
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: rc
: ---
Assignee: Eike Rathke
QA Contact: Desktop QE
URL:
Whiteboard:
Depends On: 1196704 1205091
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-03-15 15:04 UTC by Johnny Hughes
Modified: 2015-11-23 16:14 UTC (History)
13 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of: 1164898
Environment:
Last Closed: 2015-11-23 16:14:27 UTC


Attachments (Terms of Use)
use cases summary (42.59 KB, application/vnd.oasis.opendocument.spreadsheet)
2015-03-19 13:33 UTC, Jiri Koten
no flags Details


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2015:2197 normal SHIPPED_LIVE libreoffice bug fix and enhancement update 2015-11-23 21:13:16 UTC
FreeDesktop.org 85490 None None None Never

Description Johnny Hughes 2015-03-15 15:04:13 UTC
+++ This bug was initially created as a clone of Bug #1164898 +++

I am seeing similar symptoms in RHEL 7.1 libreoffice version 4.2.6.3
(Build ID: 4.2.6.3-5.el7).

Sorts of specific ranges on a sheet also change/sort other cells not in the sorted area.

This issue seems similar to this bug upstream bug:

https://bugs.documentfoundation.org/show_bug.cgi?id=79441


===== Original Bug Content ==========
Description of problem:
Given a spreadsheet with some columns of numbers, with average of each column calculated below, and a column at left with the average of each row: sorting the columns on their averages yields incorrect result and disconnects column averages from their columns.

Version-Release number of selected component (if applicable):
libreoffice-calc-4.2.7.2-6.fc20.x86_64

How reproducible: always


Steps to Reproduce:
1. Create spreadsheet with a series of columns of numbers.  (Attached example uses columns C thru S, rows 4 through 17.)  In row below last data row, put formulas calculating averages of the columns.  (In example, this is row 19.)
2. Select the columns of data (entire columns) to be sorted.  (In example, columns C thru S.)
3. Click Data - Sort...  In Options select Direction Left to Right (sort columns).  All other options can be unchecked.  In Sort Criteria select the row containing the column averages.  (In example, row 19.)  Ascending or Descending does not matter. Click OK.

Actual results: Columns are not sorted in order of average value.  Cells containing averages have averages of different columns than the columns they are in.  (In the example after sort, for instance, below the data in column G the average is for column M.)


Expected results: Columns should be rearranged so that row containing averages has them in sorted order, and each average should be the average of the numbers in the column it is in.


Additional info: I haven't tested it on sorting rows to see if the same thing happens.  If the row averages are removed

--- Additional comment from Robert K. Moniot on 2014-11-17 15:00:42 EST ---



--- Additional comment from Eike Rathke on 2014-11-18 13:41:04 EST ---

This appears to be one of the cases tracked in https://bugs.freedesktop.org/show_bug.cgi?id=85490 meta bug regarding broken sort behavior.

--- Additional comment from Fedora Update System on 2014-11-27 05:28:26 EST ---

libreoffice-4.2.7.2-10.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/libreoffice-4.2.7.2-10.fc20

--- Additional comment from Fedora Update System on 2014-11-28 04:50:54 EST ---

libreoffice-4.2.7.2-11.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/libreoffice-4.2.7.2-11.fc20

--- Additional comment from Fedora Update System on 2014-12-04 01:24:02 EST ---

libreoffice-4.2.7.2-11.fc20 has been pushed to the Fedora 20 stable repository.  If problems still persist, please make note of it in this bug report.

--- Additional comment from Robert K. Moniot on 2014-12-06 09:14:02 EST ---


Thank you, sort is working correctly now.
I agree fully with comment 8 at https://bugs.freedesktop.org/show_bug.cgi?id=85490

Comment 3 Jiri Koten 2015-03-19 13:31:29 UTC
Reproducer is included in the use case summary document, sheet Ranking_Columns.

Comment 4 Jiri Koten 2015-03-19 13:33:00 UTC
Created attachment 1003844 [details]
use cases summary

Comment 5 Eike Rathke 2015-03-20 12:56:36 UTC
My recommendation is to upgrade to LibreOffice 4.2.8.2-7 (or then current F20), where these sorting and many other bugs are fixed.

Comment 6 Johnny Hughes 2015-04-05 04:06:38 UTC
I would point out that I don't think this fix can wait until RHEL-7.2 .. this makes calc virtually unusable.

Comment 8 Bill Sanford 2015-09-11 18:01:25 UTC
Verified with RHEL-7.2-20150904.0 & libreoffice-4.3.7.2-5.el7.x86_64

Comment 10 errata-xmlrpc 2015-11-23 16:14:27 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2015-2197.html


Note You need to log in before you can comment on or make changes to this bug.