Bug 120220 - devhelp can't find libgtkembedmoz.so
devhelp can't find libgtkembedmoz.so
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: devhelp (Show other bugs)
rawhide
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jonathan Blandford
:
Depends On:
Blocks: FC2Blocker
  Show dependency treegraph
 
Reported: 2004-04-06 17:56 EDT by George Karabin
Modified: 2013-04-02 00:19 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-04-20 16:38:05 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
cleanear workaround - exporting LD_LIBRARY_PATH in devhelp script (287 bytes, patch)
2004-04-06 18:10 EDT, George Karabin
no flags Details | Diff

  None (edit)
Description George Karabin 2004-04-06 17:56:41 EDT
Description of problem:

The new devhelp is embedding gecko for HTML (spiffy) but it's caused a
hiccup, at least on my box.

$ devhelp
/usr/bin/devhelp-bin: error while loading shared libraries:
libgtkembedmoz.so: cannot open shared object file: No such file or
directory


Version-Release number of selected component (if applicable):

0.9-1

How reproducible:

100%

Additional info:

I'm not sure why devhelp has the problem and epiphany doesn't. Both
are dynamically linked against /usr/lib/mozilla-1.6/libgtkembedmoz.so. 

The quick hack is to fix up ld.so.conf with the path or symlink from
mozilla lib location to something already in the standard ld.so path,
pushing it to a mozilla packaging issue. But since epiphany doesn't
have a problem, maybe there's a better way to handle it that ought to
be pushed upstream to devhelp, or maybe it's a build time option?
Comment 1 George Karabin 2004-04-06 18:10:45 EDT
Created attachment 99164 [details]
cleanear workaround - exporting LD_LIBRARY_PATH in devhelp script

This workaround is perhaps cleaner than hacking ld.so.conf. The epiphany
wrapper script does the same thing. 

Oddly enough, after playing a bit, it appears epiphany-bin is linked to the
absolute path /usr/lib/mozilla-1.6, so exporting LD_LIBRARY_PATH probably isn't
needed there. However, devhelp-bin isn't, but the wrapper script doesn't export
the variable.
Comment 2 Colin Walters 2004-04-20 16:38:05 EDT
Applied, thanks!

Note You need to log in before you can comment on or make changes to this bug.