Bug 1202264 - qemu-img give wrong prompt message when create a image with cluster_size which is not power of two
Summary: qemu-img give wrong prompt message when create a image with cluster_size whic...
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: qemu-kvm
Version: 6.7
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: rc
: ---
Assignee: Virtualization Maintenance
QA Contact: Virtualization Bugs
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-03-16 09:21 UTC by Sibiao Luo
Modified: 2015-03-19 15:46 UTC (History)
12 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-03-19 15:46:50 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Sibiao Luo 2015-03-16 09:21:01 UTC
Description of problem:


Version-Release number of selected component (if applicable):
host info:
# uname -r && rpm -q qemu-kvm
2.6.32-544.el6.x86_64
qemu-kvm-0.12.1.2-2.458.el6.x86_64

How reproducible:
100%

Steps to Reproduce:
1.# qemu-img create -f qcow2 -o cluster_size=500 foo.qcow2 1G
Formatting 'foo.qcow2', fmt=qcow2 size=1073741824 encryption=off cluster_size=500 
Cluster size must be a power of two between 512 and 2048k

foo.qcow2: error while creating qcow2: Invalid argument

2.
3.

Actual results:


Expected results:
# qemu-img create -f qcow2 -o cluster_size=500 foo.qcow2 1G
Formatting 'foo.qcow2', fmt=qcow2 size=1073741824 encryption=off cluster_size=500 lazy_refcounts=off 
qemu-img: foo.qcow2: Cluster size must be a power of two between 512 and 2048k


Additional info:

Comment 1 Kevin Wolf 2015-03-16 11:27:52 UTC
What you put there as the expected result seems to be the RHEL 7 output, right?
I'll happily agree that the RHEL 7 output with everything in once line is nicer,
but why would the RHEL 6 output (in two lines) be wrong?

Comment 2 Ademar Reis 2015-03-19 15:46:50 UTC
I don't see this as a valid bug. The error message is different, but not wrong.

If we're missing something, please reopen.


Note You need to log in before you can comment on or make changes to this bug.