Bug 120228 - umlauts in new qt broken
umlauts in new qt broken
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: qt (Show other bugs)
rawhide
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Ngo Than
Ben Levenson
:
Depends On:
Blocks: FC2Blocker
  Show dependency treegraph
 
Reported: 2004-04-06 19:17 EDT by Roland Wolters
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-04-17 09:10:56 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Screenshot of KDE with broken umlauts (271.12 KB, image/png)
2004-04-06 19:19 EDT, Roland Wolters
no flags Details

  None (edit)
Description Roland Wolters 2004-04-06 19:17:59 EDT
Description of problem: 
After update the whole FC2T2 System to newest development packages, 
all umlauts in KDE were replaced by some other fonts: per mille, 
dots, and so on, compare screenshot. 
 
Version-Release number of selected component (if applicable): 
qt-3.3.1-0.7 brought the problem first, qt-3.3.1-0.8 has it too, 
downgrade to qt-3.3.1-0.5 brings the right umlauts back. 
 
How reproducible: 
Update FC2t2 from development tree. 
 
Steps to Reproduce: 
1. make fresh fc2t2 installation in german 
2. add development tree as source into yum.conf 
3. yum update 
   
Actual results: 
everything but the umlauts is fine 
 
Expected results: 
everything must be fine :) 
 
Additional info: 
I tried to downgrade only kdebase, or just kdelibs, but nothing 
solved the problem, I had to downgrade qt.
Comment 1 Roland Wolters 2004-04-06 19:19:48 EDT
Created attachment 99166 [details]
Screenshot of KDE with broken umlauts

Look at the window lines and at the kde boxes and the open button - in german
it must be "öffnen".
Comment 2 Ngo Than 2004-04-07 10:06:47 EDT
Could you please send me your KDE default font setting? just select
kcontrol->Appearance->fonts

Does this problem appear if you start KDE with an fresh new user?

I cannot reproduce this problem with LANG=de_DE.UTF-8
Comment 3 Roland Wolters 2004-04-08 13:13:43 EDT
To add: I had not tried it with a fresh installation, I updatet my 
system from FC2t1 to FC2t2 and then to development tree every time by 
yum through internet. 
So my description above maybe is not exactly how you can reproduce 
the failure! 
 
My font Settings: 
Allgemein/General: Sans 10 
Feste Zeichenbreite/Fixed: Monospace 10 
Werkzeugleiste/Toolbar: Sans 10 
Menü/Menue: Sans 10 
Fenstertitel/Window title: Sans 10 (bold) 
Fensterleiste/Windowbar: Sans 10 
Arbeitsfläche/Desktop: Sans 10 
 
Other users: I added a user, updatet, logged in (I use KDM as 
"login-manager"), and the same problems. 
Than I added a second user (so the user was added after the upgrade), 
and there were the same problems. 
 
My system language: LANG=de_DE.UTF-8 
Comment 4 Ngo Than 2004-04-14 17:35:50 EDT
strange, i have tried to reproduce this problem on many local machines
with FC2 test2, but it works fine for me.

Could you please try with a fresh installion?
Comment 5 Roland Wolters 2004-04-17 09:10:08 EDT
Ok, I made a fresh FC2t1 install (FC2t2 seems to be impossible for me 
for several reasons), and everything works normal. 
So the bug was just once and is not reproduceable. 
 
Roland 

Note You need to log in before you can comment on or make changes to this bug.