Bug 1202343 - user (with discovery_manager) is unable to check/uncheck discovered host, user can only select_all
Summary: user (with discovery_manager) is unable to check/uncheck discovered host, use...
Keywords:
Status: CLOSED DEFERRED
Alias: None
Product: Red Hat Satellite
Classification: Red Hat
Component: Discovery Plugin
Version: 6.1.0
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: Unspecified
Assignee: Lukas Zapletal
QA Contact: Sachin Ghai
URL:
Whiteboard:
Depends On:
Blocks: 1193977
TreeView+ depends on / blocked
 
Reported: 2015-03-16 12:52 UTC by Sachin Ghai
Modified: 2019-09-26 17:38 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-06-20 19:47:13 UTC
Target Upstream Version:


Attachments (Terms of Use)
see the checkboxes are disabled but user can select all on clicking "Name" (39.10 KB, image/png)
2015-03-16 12:52 UTC, Sachin Ghai
no flags Details

Description Sachin Ghai 2015-03-16 12:52:44 UTC
Created attachment 1002246 [details]
see the checkboxes are disabled but user can select all on clicking "Name"

Description of problem:
User can't select specific discovered hosts, because checkboxes are disabled. But user can select all. this needs to be fixed.

user should be able to check/uncheck selected discovered hosts

Version-Release number of selected component (if applicable):
sat6.1 beta snap6 compose2 (Satellite-6.1.0-RHEL-6-20150311.1).

How reproducible:
always 

Steps to Reproduce:
1. Assign "discovery_Manger role to new created user
2. login with new user
2. go to hosts --> discovered_host page
3. select a specific host

Actual results:
User can't select specific discovered hosts, because checkboxes are disabled. But user can select all. this needs to be fixed.

Expected results:

user should be able to check/uncheck selected discovered hosts

Additional info:

Comment 2 Lukas Zapletal 2016-05-12 15:36:24 UTC
Brad, if possible, I suggest this one for GA, since mass assignment is actually a workaround for Taxonomy.

Comment 4 Lukas Zapletal 2016-05-13 14:04:22 UTC
Hi, not a regression I assume. I think z-stream is reasonable, sure.

Comment 6 Lukas Zapletal 2017-05-24 08:43:32 UTC
This was fixed I believe in 6.3, plese give it a spin.


Note You need to log in before you can comment on or make changes to this bug.