Bug 120237 - Man page poorly describes --aid option
Man page poorly describes --aid option
Status: CLOSED DEFERRED
Product: Fedora
Classification: Fedora
Component: rpm (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jeff Johnson
Mike McLean
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-04-06 21:53 EDT by Michal Jaegermann
Modified: 2007-11-30 17:10 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-04-07 19:30:23 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Michal Jaegermann 2004-04-06 21:53:16 EDT
Description of problem:

Manpage for rpm says this:

    --aid  Add suggested packages to the transaction set when needed.

and something similar comes from 'rpm --help'.

On a system without 'policy' packages installed:

# rpm -Uvh --aid policy*
error: Failed dependencies:
        checkpolicy is needed by policy-sources-1.9.2-12

Hm, so either I do not understand what I am reading, or this
option is broken ('checkpolicy-...*.rpm' is available in the
current directory) or documentation skips some essential details.
Does something like 'rpmdb-fedora' has to be installed for this
to work?  I do not see any mention of such precondition anywhere?

BTW - asking a shell subprocess to supply a name if a suitably
named file is present in the current directory does not seem
to be overly difficult.  One can always fail later if a match
was bad.

Version-Release number of selected component (if applicable):
rpm-4.3.1-0.1
Comment 1 Jeff Johnson 2004-04-07 07:49:07 EDT
The --aid option requires a *.rpm repository and the path
to be configured in

#       The path to the dependency universe packages. This should
#       be a path to the packages contained in the solve database.
%_solve_pkgsdir /mnt/redhat/test/latest-i386/Fedora/RPMS/

Shell subprocesses don't work in empty chroot's because there
is no /bin/sh there.
Comment 2 Michal Jaegermann 2004-04-07 11:21:46 EDT
> The --aid option requires ....
Then this is a documentation bug as none of the above is mentioned.
Not even "such-and-such package has to be installed".

Moreover the option has a rather limited use because 'rpmdb-...'
is updated constantly in a development series but for a release
it will quickly get out of sync when updates will show up.
Or you mean that "a *.rpm repository" can be maintained with
a help of '--justdb'?  Documentation again?

Also "try this and fall back on something else if it did not work"
mechanisms are not unthinkable.
Comment 3 Jeff Johnson 2004-04-07 12:49:32 EDT
Documenting unfinished work ain't exactly wise.

"limited use" well known.

rpm is complicated enough without adding Yet More Complexity.

Do you have a bug here, or are you just kvetching?
Comment 4 Michal Jaegermann 2004-04-07 14:22:16 EDT
> Do you have a bug here, or are you just kvetching?

Yes, I do have a bug.  An incomplete and/or misleading manpage.
It does not take very much to fix that.  A sentence like this:
"An appriopriate 'rpmdb' package has to be installed for this
option to work".

If it would be possible to explain shortly how to update such
*.rpm repository, if a need would arise, that would be even better.
Comment 5 Jeff Johnson 2004-04-07 19:30:23 EDT
OK, a bug. Deferred until it's clear whether --aid is sufficiently
useful.
Comment 6 Leonard den Ottolander 2004-04-08 21:09:55 EDT
Very useful option it is "--aid", for various uses (minimalistic
--root installs, adding packages to an existing system without having
to sort out dependencies). All you have to do is keep the rpmdb in sync.

Michal, if you feel this should be documented in some more detail
please attach a (terse, 2, 3 lines) man page patch. But note that this
is essentially an RFE to a man page. Not very high priority.
Comment 7 Michal Jaegermann 2004-04-08 21:40:37 EDT
Well, there is already a one-liner in my earlier comment which,
I think, should be adequate for now.  If this is supposed to be
a short description how to keep rpmdb in sync then I am not so
sure about such process myself.  I imagine that '--justdb' can
be helpful here but I did not try anything of that sort.
Comment 8 Leonard den Ottolander 2004-04-09 11:42:41 EDT
The one liner is not only hinting in the direction of what it should
be, and it is not a patch.

How to keep the rpmdb in sync is not relevant for the man page.

Something along the lines "fedora-rpmdb needs to be installed (and
kept in sync) and the macros in /etc/rpm/ need to be setup correctly
for --aid to work".

Correctly worded and to the point, and as a patch. If you want small
and relatively unimportant changes like these applied your chances are
best if you apply a nice clean patch, so the developer only has to
apply and not bother any further.
Comment 9 Leonard den Ottolander 2004-04-09 11:45:24 EDT
Changing subject line and severity.
Comment 10 Michal Jaegermann 2004-04-09 12:07:43 EDT
> Something along the lines "fedora-rpmdb needs to be installed ...
That wording is wrong as rpm is not something Fedora specific.
Comment 11 Leonard den Ottolander 2004-04-18 18:45:43 EDT
So supply the patch!
Comment 12 Barry K. Nathan 2004-07-15 12:56:18 EDT
Re: comment #3

What's the "unfinished work"? The suggestions in comment #2 or the
current implementation of --aid itself?

If --aid is unfinished, that may actually be the most important thing
to mention in the manpage (IMO).

(It's possible that I'll write up some brief changes to the manpage,
but before I do that I want to make sure I understand the situation.)

Note You need to log in before you can comment on or make changes to this bug.