Bug 1202376 - [amqp1.0] asserting legacy-amqp-topic-binding on xml exchange node does not fail
Summary: [amqp1.0] asserting legacy-amqp-topic-binding on xml exchange node does not fail
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise MRG
Classification: Red Hat
Component: qpid-cpp
Version: Development
Hardware: Unspecified
OS: Unspecified
high
low
Target Milestone: 3.1
: ---
Assignee: Irina Boverman
QA Contact: Petr Matousek
URL:
Whiteboard:
Depends On: 1133948
Blocks: 1010399
TreeView+ depends on / blocked
 
Reported: 2015-03-16 13:54 UTC by Petr Matousek
Modified: 2015-04-14 13:49 UTC (History)
5 users (show)

Fixed In Version: qpid-cpp-0.30-8
Doc Type: Bug Fix
Doc Text:
Clone Of: 1133948
Environment:
Last Closed: 2015-04-14 13:49:10 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Apache JIRA QPID-6045 None None None Never
Red Hat Product Errata RHEA-2015:0805 normal SHIPPED_LIVE Red Hat Enterprise MRG Messaging 3.1 Release 2015-04-14 17:45:54 UTC

Description Petr Matousek 2015-03-16 13:54:44 UTC
+++ This bug was initially created as a clone of Bug #1133948 +++

Description of problem:
asserting AMQP 1.0 link filter legacy-amqp-topic-binding when subscribing to a xml exchange does not fail, although it is not supported in that configuration.

Version-Release number of selected component (if applicable):
qpid-cpp-0.22-47

How reproducible:
100%

Steps to Reproduce:
1. subscribe to a xml exchange (create) with legacy-amqp-topic-binding
./qc2_drain --connection-options "{protocol:'amqp1.0'}" --log-msgs dict -c 0 -f "my-xml2;{create:always,assert:always,node:{type:topic,'properties':{'exchange-type':xml}},link:{filter:{value:'a.#', name:'x', descriptor: 'apache.org:legacy-amqp-topic-binding:string'}}}"


Actual results:
Does not fail, 
and filter does not work (latter is expected)

Expected results:
Client should fail with assert exception

Additional info:

--- Additional comment from Gordon Sim on 2014-08-26 11:22:07 EDT ---

Fixed upstream: https://svn.apache.org/r1620630

--- Additional comment from Zdenek Kraus on 2014-08-26 11:48:34 EDT ---

adding mrg-3.0.0? as agreed with gsim

--- Additional comment from Zdenek Kraus on 2014-09-01 02:58:38 EDT ---

Tested on RHEL 6.5 i686 && x86_64 with following packages:

qpid-cpp-client-0.22-48.el6
qpid-cpp-client-devel-0.22-48.el6
qpid-cpp-client-devel-docs-0.22-48.el6
qpid-cpp-client-rdma-0.22-48.el6
qpid-cpp-debuginfo-0.22-48.el6
qpid-cpp-server-0.22-48.el6
qpid-cpp-server-devel-0.22-48.el6
qpid-cpp-server-ha-0.22-48.el6
qpid-cpp-server-linearstore-0.22-48.el6
qpid-cpp-server-rdma-0.22-48.el6
qpid-cpp-server-xml-0.22-48.el6

Works as expected.

Comment 1 Petr Matousek 2015-03-16 13:58:08 UTC
This issue was fixed for 3.0.x stream, but appeared again on 3.1:

Packages:
qpid-cpp-*-0.30-7

Marking regression.

Comment 5 Petr Matousek 2015-04-02 08:12:03 UTC
This issue has been fixed. Verified on rhel6.6 (x86_64 and i386).
Marking unique-rhel6 because XML exchange is not supported on rhel7.

Packages:
qpid-cpp-*-0.30-8

-> VERIFIED

Comment 7 errata-xmlrpc 2015-04-14 13:49:10 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHEA-2015-0805.html


Note You need to log in before you can comment on or make changes to this bug.