Bug 1202444 - OverflowError: long too big to convert
Summary: OverflowError: long too big to convert
Keywords:
Status: CLOSED DUPLICATE of bug 1200812
Alias: None
Product: Fedora
Classification: Fedora
Component: anaconda
Version: 22
Hardware: x86_64
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Anaconda Maintenance Team
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: abrt_hash:015f7f315ad25e8bc2e2d3d9b38...
Depends On:
Blocks: F22BetaBlocker
TreeView+ depends on / blocked
 
Reported: 2015-03-16 15:46 UTC by Kamil Páral
Modified: 2015-03-16 16:41 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-03-16 16:29:35 UTC
Type: ---


Attachments (Terms of Use)
File: anaconda-tb (379.57 KB, text/plain)
2015-03-16 15:46 UTC, Kamil Páral
no flags Details
File: anaconda.log (15.96 KB, text/plain)
2015-03-16 15:46 UTC, Kamil Páral
no flags Details
File: dnf.log (10.21 KB, text/plain)
2015-03-16 15:46 UTC, Kamil Páral
no flags Details
File: environ (492 bytes, text/plain)
2015-03-16 15:46 UTC, Kamil Páral
no flags Details
File: lsblk_output (1.73 KB, text/plain)
2015-03-16 15:46 UTC, Kamil Páral
no flags Details
File: nmcli_dev_list (1.02 KB, text/plain)
2015-03-16 15:46 UTC, Kamil Páral
no flags Details
File: os_info (443 bytes, text/plain)
2015-03-16 15:46 UTC, Kamil Páral
no flags Details
File: storage.log (97.77 KB, text/plain)
2015-03-16 15:46 UTC, Kamil Páral
no flags Details
File: syslog (65.81 KB, text/plain)
2015-03-16 15:46 UTC, Kamil Páral
no flags Details
File: ifcfg.log (2.25 KB, text/plain)
2015-03-16 15:46 UTC, Kamil Páral
no flags Details
File: packaging.log (996 bytes, text/plain)
2015-03-16 15:46 UTC, Kamil Páral
no flags Details
File: program.log (34.52 KB, text/plain)
2015-03-16 15:46 UTC, Kamil Páral
no flags Details

Description Kamil Páral 2015-03-16 15:46:04 UTC
Description of problem:
I simply opened the partitioning spoke and hit Alt+D (for Done, not sure if that got registered or the exception occurred sooner).

Version-Release number of selected component:
anaconda-22.20.4-1

The following was filed automatically by anaconda:
anaconda 22.20.4-1 exception report
Traceback (most recent call first):
  File "/usr/lib64/python2.7/site-packages/gi/overrides/BlockDev.py", line 109, in lvm_round_size_to_pe
    return _lvm_round_size_to_pe(size, pe_size, roundup)
  File "/usr/lib/python2.7/site-packages/blivet/devices/lvm.py", line 377, in align
    return Size(blockdev.lvm_round_size_to_pe(size, self.peSize, roundup))
  File "/usr/lib/python2.7/site-packages/blivet/partitioning.py", line 941, in __init__
    lv.vg.align(lv.format.maxSize)) if l > Size(0)]
  File "/usr/lib/python2.7/site-packages/blivet/partitioning.py", line 1848, in growLVM
    chunk = VGChunk(vg, requests=[LVRequest(l) for l in fatlvs])
  File "/usr/lib/python2.7/site-packages/blivet/autopart.py", line 477, in doAutoPartition
    growLVM(storage)
  File "/usr/lib64/python2.7/site-packages/pyanaconda/kickstart.py", line 340, in execute
    doAutoPartition(storage, ksdata, min_luks_entropy=MIN_CREATE_ENTROPY)
  File "/usr/lib64/python2.7/site-packages/pyanaconda/kickstart.py", line 2062, in doKickstartStorage
    ksdata.autopart.execute(storage, ksdata, instClass)
  File "/usr/lib64/python2.7/site-packages/pyanaconda/ui/gui/spokes/storage.py", line 326, in _doExecute
    doKickstartStorage(self.storage, self.data, self.instclass)
  File "/usr/lib64/python2.7/threading.py", line 766, in run
    self.__target(*self.__args, **self.__kwargs)
  File "/usr/lib64/python2.7/site-packages/pyanaconda/threads.py", line 238, in run
    threading.Thread.run(self, *args, **kwargs)
OverflowError: long too big to convert

Additional info:
addons:         com_redhat_kdump
cmdline:        /usr/bin/python2  /sbin/anaconda
cmdline_file:   BOOT_IMAGE=vmlinuz initrd=initrd.img inst.stage2=hd:LABEL=Fedora-22_B_T2-x86_64 quiet
dnf.rpm.log:    Mar 16 15:43:46 INFO --- logging initialized ---
executable:     /sbin/anaconda
hashmarkername: anaconda
kernel:         4.0.0-0.rc1.git0.1.fc22.x86_64
product:        Fedora"
release:        Cannot get release name.
type:           anaconda
version:        Fedora

Comment 1 Kamil Páral 2015-03-16 15:46:08 UTC
Created attachment 1002369 [details]
File: anaconda-tb

Comment 2 Kamil Páral 2015-03-16 15:46:09 UTC
Created attachment 1002370 [details]
File: anaconda.log

Comment 3 Kamil Páral 2015-03-16 15:46:10 UTC
Created attachment 1002371 [details]
File: dnf.log

Comment 4 Kamil Páral 2015-03-16 15:46:12 UTC
Created attachment 1002372 [details]
File: environ

Comment 5 Kamil Páral 2015-03-16 15:46:13 UTC
Created attachment 1002373 [details]
File: lsblk_output

Comment 6 Kamil Páral 2015-03-16 15:46:14 UTC
Created attachment 1002374 [details]
File: nmcli_dev_list

Comment 7 Kamil Páral 2015-03-16 15:46:15 UTC
Created attachment 1002375 [details]
File: os_info

Comment 8 Kamil Páral 2015-03-16 15:46:17 UTC
Created attachment 1002376 [details]
File: storage.log

Comment 9 Kamil Páral 2015-03-16 15:46:19 UTC
Created attachment 1002377 [details]
File: syslog

Comment 10 Kamil Páral 2015-03-16 15:46:20 UTC
Created attachment 1002378 [details]
File: ifcfg.log

Comment 11 Kamil Páral 2015-03-16 15:46:21 UTC
Created attachment 1002379 [details]
File: packaging.log

Comment 12 Kamil Páral 2015-03-16 15:46:23 UTC
Created attachment 1002380 [details]
File: program.log

Comment 13 Kamil Páral 2015-03-16 15:50:18 UTC
Another user experienced a similar problem:

Happened again. Happes after I press Done. There's no dialog asking me to free up some space, even though it seems I have none left. If just closes the dialog and then crashes.

addons:         com_redhat_kdump
cmdline:        /usr/bin/python2  /sbin/anaconda
cmdline_file:   BOOT_IMAGE=vmlinuz initrd=initrd.img inst.stage2=hd:LABEL=Fedora-22_B_T2-x86_64 quiet
dnf.rpm.log:    Mar 16 15:47:16 INFO --- logging initialized ---
hashmarkername: anaconda
kernel:         4.0.0-0.rc1.git0.1.fc22.x86_64
package:        anaconda-22.20.4-1
product:        Fedora"
reason:         OverflowError: long too big to convert
release:        Cannot get release name.
version:        Fedora

Comment 14 Kamil Páral 2015-03-16 15:55:35 UTC
Another user experienced a similar problem:

I reproduced on a different VM with different disk contents. Seem to be pretty reliably broken :)

addons:         com_redhat_kdump
cmdline:        /usr/bin/python2  /sbin/anaconda
cmdline_file:   BOOT_IMAGE=vmlinuz initrd=initrd.img inst.stage2=hd:LABEL=Fedora-22_B_T2-x86_64 quiet
dnf.rpm.log:    Mar 16 15:51:46 INFO --- logging initialized ---
hashmarkername: anaconda
kernel:         4.0.0-0.rc1.git0.1.fc22.x86_64
package:        anaconda-22.20.4-1
product:        Fedora"
reason:         OverflowError: long too big to convert
release:        Cannot get release name.
version:        Fedora

Comment 15 Kamil Páral 2015-03-16 15:56:46 UTC
Proposing as a Beta blocker. Violates the usual "work with common disk contents" criteria.

Comment 16 Kamil Páral 2015-03-16 16:24:09 UTC
This is with Beta TC2 Server netinst x86_64.

Comment 17 Kamil Páral 2015-03-16 16:28:56 UTC
Probably a duplicate of bug 1200812.

Comment 18 Vratislav Podzimek 2015-03-16 16:29:35 UTC

*** This bug has been marked as a duplicate of bug 1200812 ***


Note You need to log in before you can comment on or make changes to this bug.