Bug 12025 - References to buildroot in compiled files
Summary: References to buildroot in compiled files
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: python   
(Show other bugs)
Version: 7.1
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Matt Wilson
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2000-06-09 14:17 UTC by Frank Sweetser
Modified: 2008-05-01 15:37 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-08-04 23:17:59 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Frank Sweetser 2000-06-09 14:17:30 UTC
Since the python include files were byte compiled during rpm build time,
they contain references to the full paths of files - the buildroot path
instead of the actual path after install.  This causes some module loading
to fail.

Comment 1 Frank Sweetser 2000-06-27 12:16:22 UTC
Still present in beta 2.

Comment 2 Matt Wilson 2000-07-24 13:49:38 UTC
Exactly which modules?


Comment 3 Frank Sweetser 2000-08-04 23:17:57 UTC
All compiled files appear to have the problem - 'grep *.py[oc]' will give a list.

Comment 4 Matt Wilson 2000-08-05 01:38:57 UTC
That's unfixible, and isn't a big deal.



Note You need to log in before you can comment on or make changes to this bug.