Bug 1202541 - Perf: Metadata operation performance on replicated volumes regressed on 3.0.4 builds.
Summary: Perf: Metadata operation performance on replicated volumes regressed on 3.0....
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: core
Version: rhgs-3.0
Hardware: x86_64
OS: Linux
urgent
urgent
Target Milestone: ---
: RHGS 3.0.4
Assignee: Krutika Dhananjay
QA Contact: Ben Turner
URL:
Whiteboard:
Depends On:
Blocks: 1182947 1202669 1202673 1202675 1203122
TreeView+ depends on / blocked
 
Reported: 2015-03-16 20:41 UTC by Ben Turner
Modified: 2016-09-17 14:39 UTC (History)
5 users (show)

Fixed In Version: glusterfs-3.6.0.53-1
Doc Type: Bug Fix
Doc Text:
Clone Of:
: 1202669 (view as bug list)
Environment:
Last Closed: 2015-03-26 06:37:08 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2015:0682 0 normal SHIPPED_LIVE Red Hat Storage 3.0 enhancement and bug fix update #4 2015-03-26 10:32:55 UTC

Description Ben Turner 2015-03-16 20:41:08 UTC
Description of problem:

Metadata, specifically ls -l performance has been greatly reduced on replicated volumes with 3.0.4.  I do not see this perf hit on distributed volumes, and perf on replicated 3.0.3 volumes is good.

Version-Release number of selected component (if applicable):

glusterfs-3.6.0.51

How reproducible:

Every time.

Steps to Reproduce:
1.  Create 10k files
2.  Clear buffers and cache on both servers and clients
3.  Run ls -l on files

Actual results:

Perf hit vs 3.0.3.

Expected results:

Perf within 10% of 3.0.3.

Additional info:

Comment 7 Ben Turner 2015-03-19 17:02:11 UTC
Verified on 3.6.0.53.

Comment 9 errata-xmlrpc 2015-03-26 06:37:08 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2015-0682.html


Note You need to log in before you can comment on or make changes to this bug.