Red Hat Satellite engineering is moving the tracking of its product development work on Satellite to Red Hat Jira (issues.redhat.com). If you're a Red Hat customer, please continue to file support cases via the Red Hat customer portal. If you're not, please head to the "Satellite project" in Red Hat Jira and file new tickets here. Individual Bugzilla bugs will be migrated starting at the end of May. If you cannot log in to RH Jira, please consult article #7032570. That failing, please send an e-mail to the RH Jira admins at rh-issues@redhat.com to troubleshoot your issue as a user management inquiry. The email creates a ServiceNow ticket with Red Hat. Individual Bugzilla bugs that are migrated will be moved to status "CLOSED", resolution "MIGRATED", and set with "MigratedToJIRA" in "Keywords". The link to the successor Jira issue will be found under "Links", have a little "two-footprint" icon next to it, and direct you to the "Satellite project" in Red Hat Jira (issue links are of type "https://issues.redhat.com/browse/SAT-XXXX", where "X" is a digit). This same link will be available in a blue banner at the top of the page informing you that that bug has been migrated.
Bug 1202558 - Satellite host summary email triggered when email is disabled in user settings
Summary: Satellite host summary email triggered when email is disabled in user settings
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Satellite
Classification: Red Hat
Component: Content Management
Version: 6.1.0
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: Unspecified
Assignee: Stephen Benjamin
QA Contact: sthirugn@redhat.com
URL: http://projects.theforeman.org/issues...
Whiteboard:
Depends On: 1215820
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-03-16 21:33 UTC by sthirugn@redhat.com
Modified: 2017-02-23 20:18 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-08-12 13:56:11 UTC
Target Upstream Version:
Embargoed:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Foreman Issue Tracker 9795 0 None None None 2016-04-22 15:37:52 UTC

Description sthirugn@redhat.com 2015-03-16 21:33:04 UTC
Description of problem:
Satellite host summary email triggered when email is disabled in user settings

Version-Release number of selected component (if applicable):
Satellite-6.1.0-RHEL-6-20150311.1

How reproducible:
Always


Steps to Reproduce:
1. UI -> User -> My Account -> Mail Preferences -> Uncheck Mail Enabled
2. But subscribe to all 5 different email notifications 
- Puppet error state - Subscribe
- Satellite promote errata - Subscribe
- Satellite sync errata - Subscribe
- Puppet Summary - Daily
- Satellite host advisory - Daily
3. Run #foreman-rake reports:daily

Actual results:
Email notification triggered for Satellite Host Advisory

Expected results:
If Mail Enabled is unchecked, no email should be triggered

Additional info:

Comment 1 RHEL Program Management 2015-03-16 21:33:18 UTC
Since this issue was entered in Red Hat Bugzilla, the release flag has been
set to ? to ensure that it is properly evaluated for this release.

Comment 3 Stephen Benjamin 2015-03-17 14:24:24 UTC
Created redmine issue http://projects.theforeman.org/issues/9795 from this bug

Comment 4 Bryan Kearney 2015-03-22 18:05:22 UTC
Moving to POST since upstream bug http://projects.theforeman.org/issues/9795 has been closed
-------------
Anonymous
Applied in changeset commit:7ca39b3442be76da89c2c52d8da0c2d6afb74af1.

Comment 6 sthirugn@redhat.com 2015-04-27 20:28:08 UTC
Testing blocked because of https://bugzilla.redhat.com/show_bug.cgi?id=1215820

Comment 7 sthirugn@redhat.com 2015-05-04 19:53:52 UTC
Verified.

Now the emails are not sent when email is disabled in user settings.

Version Tested: 
Satellite-6.1.0-RHEL-7-20150429.2

Comment 8 Bryan Kearney 2015-08-11 13:19:58 UTC
This bug is slated to be released with Satellite 6.1.

Comment 9 Bryan Kearney 2015-08-12 13:56:11 UTC
This bug was fixed in version 6.1.1 of Satellite which was released on 12 August, 2015.


Note You need to log in before you can comment on or make changes to this bug.